aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-encfs
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-13 20:48:02 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-13 20:48:02 +0000
commit5c082df1ce5853075f13b3ea7e872f7d27ff5ec4 (patch)
tree68c62087765f1a516579bff45364de0b5602e282 /sysutils/fusefs-encfs
parent45cf8dcf1d446178d4387a5407d339bbf1e92d54 (diff)
downloadports-5c082df1ce5853075f13b3ea7e872f7d27ff5ec4.tar.gz
ports-5c082df1ce5853075f13b3ea7e872f7d27ff5ec4.zip
Notes
Diffstat (limited to 'sysutils/fusefs-encfs')
-rw-r--r--sysutils/fusefs-encfs/Makefile2
-rw-r--r--sysutils/fusefs-encfs/files/patch-implement-encf_create46
2 files changed, 47 insertions, 1 deletions
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index 4ca88ad8ce8f..491d3ed4b68d 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= encfs
PORTVERSION= 1.7.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-encfs/files/patch-implement-encf_create b/sysutils/fusefs-encfs/files/patch-implement-encf_create
new file mode 100644
index 000000000000..3dc1d8aa2109
--- /dev/null
+++ b/sysutils/fusefs-encfs/files/patch-implement-encf_create
@@ -0,0 +1,46 @@
+As described in PR 192563
+
+--- encfs/encfs.cpp.orig 2014-04-21 15:10:48.592664000 +0000
++++ encfs/encfs.cpp
+@@ -587,6 +587,19 @@
+ return res;
+ }
+
++int encfs_create(const char *path, mode_t mode, struct fuse_file_info *file)
++{
++ int res;
++
++ res = encfs_mknod(path, mode, 0);
++ if (res)
++ return res;
++
++ res = encfs_open(path, file);
++
++ return res;
++}
++
+ int _do_flush(FileNode *fnode, int )
+ {
+ /* Flush can be called multiple times for an open file, so it doesn't
+--- encfs/encfs.h.orig 2014-04-21 15:10:48.592664000 +0000
++++ encfs/encfs.h
+@@ -74,6 +74,7 @@
+ struct fuse_file_info *fi);
+ int encfs_utime(const char *path, struct utimbuf *buf);
+ int encfs_open(const char *path, struct fuse_file_info *info);
++int encfs_create(const char *path, mode_t mode, struct fuse_file_info *info);
+ int encfs_release(const char *path, struct fuse_file_info *info);
+ int encfs_read(const char *path, char *buf, size_t size, off_t offset,
+ struct fuse_file_info *info);
+diff -ur encfs-1.7.4.orig/encfs/main.cpp encfs-1.7.4/encfs/main.cpp
+--- encfs/main.cpp.orig 2014-04-21 15:10:48.592664000 +0000
++++ encfs/main.cpp
+@@ -563,7 +563,7 @@
+ encfs_oper.init = encfs_init;
+ encfs_oper.destroy = encfs_destroy;
+ //encfs_oper.access = encfs_access;
+- //encfs_oper.create = encfs_create;
++ encfs_oper.create = encfs_create;
+ encfs_oper.ftruncate = encfs_ftruncate;
+ encfs_oper.fgetattr = encfs_fgetattr;
+ //encfs_oper.lock = encfs_lock;