aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-httpfs
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 01:03:39 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 01:03:39 +0000
commit30ec470b97c54f10598d65c0dfd298c3e9dc1e84 (patch)
treeca1863b352e9f712ffe408acfae9ca943109d3ca /sysutils/fusefs-httpfs
parent98674709781c98094e7032ac4651d9a5cd334d8e (diff)
downloadports-30ec470b97c54f10598d65c0dfd298c3e9dc1e84.tar.gz
ports-30ec470b97c54f10598d65c0dfd298c3e9dc1e84.zip
Notes
Diffstat (limited to 'sysutils/fusefs-httpfs')
-rw-r--r--sysutils/fusefs-httpfs/Makefile42
-rw-r--r--sysutils/fusefs-httpfs/distinfo3
-rw-r--r--sysutils/fusefs-httpfs/files/patch-httpfs.c14
-rw-r--r--sysutils/fusefs-httpfs/pkg-descr6
4 files changed, 65 insertions, 0 deletions
diff --git a/sysutils/fusefs-httpfs/Makefile b/sysutils/fusefs-httpfs/Makefile
new file mode 100644
index 000000000000..8c6d97fed121
--- /dev/null
+++ b/sysutils/fusefs-httpfs/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: fusefs-httpfs
+# Date created: 2006-07-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httpfs
+PORTVERSION= 2.06.07.10
+CATEGORIES= sysutils www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= fusefs-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Fuse-based http filesystem
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+PLIST_FILES= bin/httpfs
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
+ -DUSE_AUTH -D_FILE_OFFSET_BITS=64 -D_REENTRANT \
+ -DFUSE_USE_VERSION=25 -D_POSIX_C_SOURCE=200112L -D_POSIX_SOURCE \
+ -D_SVID_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE=500 \
+ -o httpfs httpfs.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/httpfs ${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 # Inherited from sysutils/fusefs-kmod
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-httpfs/distinfo b/sysutils/fusefs-httpfs/distinfo
new file mode 100644
index 000000000000..2775af148b38
--- /dev/null
+++ b/sysutils/fusefs-httpfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (httpfs_2.06.07.10.tar.bz2) = f62e2f333651a7c21b610d0ec4f52f03
+SHA256 (httpfs_2.06.07.10.tar.bz2) = b6291852ae2810528585447b835aa9d507c6ee7d1a4e7889e183e0305f753223
+SIZE (httpfs_2.06.07.10.tar.bz2) = 13990
diff --git a/sysutils/fusefs-httpfs/files/patch-httpfs.c b/sysutils/fusefs-httpfs/files/patch-httpfs.c
new file mode 100644
index 000000000000..6cac4cbb3088
--- /dev/null
+++ b/sysutils/fusefs-httpfs/files/patch-httpfs.c
@@ -0,0 +1,14 @@
+--- httpfs.c.orig Sun Jul 16 22:48:19 2006
++++ httpfs.c Sun Jul 16 22:48:39 2006
+@@ -32,9 +32,10 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <sys/stat.h>
+-#include <sys/dir.h>
++#include <dirent.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <sys/select.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+ #include <time.h>
diff --git a/sysutils/fusefs-httpfs/pkg-descr b/sysutils/fusefs-httpfs/pkg-descr
new file mode 100644
index 000000000000..36326a581085
--- /dev/null
+++ b/sysutils/fusefs-httpfs/pkg-descr
@@ -0,0 +1,6 @@
+httpfs depends on FUSE. It uses HTTP/1.1 extensions to read arbitrary
+bytes from a file on a web-server. This is particular interesting for
+an iso, since it can be investigated (loop device) without actually
+downloading the whole iso.
+
+WWW: http://httpfs.sourceforge.net/