aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-kmod
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-01-27 16:50:34 +0000
committerRene Ladan <rene@FreeBSD.org>2014-01-27 16:50:34 +0000
commitc2a75bbd9311efa319e04dddd650817afb45d128 (patch)
tree72e666e09ff698784c326ff7d31c84ba32bfaea7 /sysutils/fusefs-kmod
parent3f6868dacb3401134e538392b02829178aa45e49 (diff)
downloadports-c2a75bbd9311efa319e04dddd650817afb45d128.tar.gz
ports-c2a75bbd9311efa319e04dddd650817afb45d128.zip
Notes
Diffstat (limited to 'sysutils/fusefs-kmod')
-rw-r--r--sysutils/fusefs-kmod/Makefile25
-rw-r--r--sysutils/fusefs-kmod/pkg-plist10
2 files changed, 15 insertions, 20 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index c06664310fd5..4faf9b589954 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -27,19 +27,15 @@ DISABLE_SIZE= yes
OPTIONS_DEFINE= AUTOSETUP DOCS
AUTOSETUP_DESC= Automatic global config file setup
-NO_STAGE= yes
-
USES= kmod
-.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= deplate:${PORTSDIR}/textproc/ruby-deplate
-.endif
+DOCS_BUILD_DEPENDS= deplate:${PORTSDIR}/textproc/ruby-deplate
+
+.include <bsd.port.pre.mk>
SETUP= setup.sh
HG_SHORTREV= 498acaef33b0
-MAN8= mount_fusefs.8
TXT_DOCS= doc.text
HTML_DOCS= Faq.html \
Implementation.html \
@@ -66,7 +62,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extrapatch-fuse_module__fuse_vnops.c
.endif
.if exists(${SRC_BASE}/sys/fs/fuse)
-IGNORE= Integrated into base
+IGNORE= integrated into base
.endif
.if !exists(${SRC_BASE}/sbin/mount)
IGNORE= requires the userland sources to be installed. Set SRC_BASE if it is not in /usr/src
@@ -81,7 +77,6 @@ SUB_FILES+= ${SETUP}
.else
SUB_FILES+= pkg-message
.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/deplate.rb/deplate/g' \
${WRKSRC}/doc/Makefile
@@ -97,21 +92,21 @@ post-build:
.endif
post-install:
- @${LN} -fs ${PREFIX}/sbin/mount_fusefs /usr/sbin
+ ${MKDIR} ${STAGEDIR}/usr/sbin
+ (cd ${STAGEDIR} && ${LN} -fs ${PREFIX}/sbin/mount_fusefs \
+ usr/sbin/mount_fusefs)
.if ${PORT_OPTIONS:MAUTOSETUP} && !defined(PACKAGE_BUILDING)
@${ECHO} "Modifying global startup config files and loading module..."
@${SH} ${WRKDIR}/${SETUP}
-.else
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.endif
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/kmod/html
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/kmod/html
.for i in ${TXT_DOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/plaintext_out/$i ${DOCSDIR}/kmod
+ ${INSTALL_DATA} ${WRKSRC}/doc/plaintext_out/$i ${STAGEDIR}${DOCSDIR}/kmod
.endfor
.for i in ${HTML_DOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/html_chunked_out/$i ${DOCSDIR}/kmod/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/html_chunked_out/$i ${STAGEDIR}${DOCSDIR}/kmod/html
.endfor
.endif
diff --git a/sysutils/fusefs-kmod/pkg-plist b/sysutils/fusefs-kmod/pkg-plist
index 6ccde8bf6d28..a3bcbdb11721 100644
--- a/sysutils/fusefs-kmod/pkg-plist
+++ b/sysutils/fusefs-kmod/pkg-plist
@@ -1,6 +1,5 @@
sbin/mount_fusefs
-@exec ln -fs %D/%F /usr/sbin
-@unexec rm -f /usr/sbin/mount_fusefs
+man/man8/mount_fusefs.8.gz
%%PORTDOCS%%%%DOCSDIR%%/kmod/doc.text
%%PORTDOCS%%%%DOCSDIR%%/kmod/html/Faq.html
%%PORTDOCS%%%%DOCSDIR%%/kmod/html/Implementation.html
@@ -19,6 +18,7 @@ sbin/mount_fusefs
%%PORTDOCS%%%%DOCSDIR%%/kmod/html/tabbar-right.css
%%PORTDOCS%%@dirrm %%DOCSDIR%%/kmod/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/kmod
-@dirrmtry %%DOCSDIR%%
-@cwd /%%KMODDIR%%
-fuse.ko
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@cwd /
+usr/sbin/mount_fusefs
+%%KMODDIR%%/fuse.ko