aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-kmod
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-09-21 20:29:34 +0000
committerSteve Wills <swills@FreeBSD.org>2011-09-21 20:29:34 +0000
commit8d145b4c60a4141e6257c49470d50b4bfc9646d2 (patch)
treee3c64bed5675e17e80fcbbccc2f347f2ffcb2412 /sysutils/fusefs-kmod
parentd2cf36eec8000e2ae8ef506c7ac689e1a1a8c489 (diff)
downloadports-8d145b4c60a4141e6257c49470d50b4bfc9646d2.tar.gz
ports-8d145b4c60a4141e6257c49470d50b4bfc9646d2.zip
Notes
Diffstat (limited to 'sysutils/fusefs-kmod')
-rw-r--r--sysutils/fusefs-kmod/Makefile6
-rw-r--r--sysutils/fusefs-kmod/files/extra-patch-fuse_module__fuse_vnops.c11
2 files changed, 16 insertions, 1 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index 41f8c56215fd..b08c7aecf470 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1.20080208
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils kld
MASTER_SITES= http://mercurial.creo.hu/repos/fuse4bsd-hg/index.cgi/archive/
PKGNAMESUFFIX= -kmod
@@ -58,6 +58,10 @@ OPTIONS= AUTOSETUP "Automatic global config file setup" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 900040
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fuse_module__fuse_vnops.c
+.endif
+
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires the Kernel source to be installed. Set SRC_BASE if it is not in /usr/src
.endif
diff --git a/sysutils/fusefs-kmod/files/extra-patch-fuse_module__fuse_vnops.c b/sysutils/fusefs-kmod/files/extra-patch-fuse_module__fuse_vnops.c
new file mode 100644
index 000000000000..f776c3bd9cb5
--- /dev/null
+++ b/sysutils/fusefs-kmod/files/extra-patch-fuse_module__fuse_vnops.c
@@ -0,0 +1,11 @@
+--- fuse_module/fuse_vfsops.c.orig 2008-02-05 07:25:57.000000000 +0200
++++ fuse_module/fuse_vfsops.c 2011-09-08 10:27:43.000000000 +0300
+@@ -224,7 +231,7 @@
+ struct cdev *fdev;
+ struct sx *slock;
+ struct fuse_data *data;
+- int mntopts = 0, __mntopts = 0, max_read_set = 0, secondary = 0;
++ uint64_t mntopts = 0, __mntopts = 0, max_read_set = 0, secondary = 0;
+ unsigned max_read = ~0;
+ struct vnode *rvp;
+ struct fuse_vnode_data *fvdat;