aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-ntfs/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-06-07 04:01:33 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-06-07 04:01:33 +0000
commitd50259282a811203d50e7ceb213f2d6a99ffd5c6 (patch)
treef11f80c76c9ac68c23ccf5c5f24d2f9cdd642f4a /sysutils/fusefs-ntfs/Makefile
parent96c543cde1175f340b417f9b05d85a6b0baca0d0 (diff)
Notes
Diffstat (limited to 'sysutils/fusefs-ntfs/Makefile')
-rw-r--r--sysutils/fusefs-ntfs/Makefile48
1 files changed, 37 insertions, 11 deletions
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index 877a9c43fd42..86384fcf7443 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -6,35 +6,61 @@
PORTNAME= ntfs
PORTVERSION= 1.417
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
-MASTER_SITES= http://www.ntfs-3g.org/
-MASTER_SITE_SUBDIR= fuse
+MASTER_SITES= http://www.ntfs-3g.org/:ntfs \
+ ${MASTER_SITE_LOCAL:S|$|alepulver/:ublio|}
PKGNAMEPREFIX= fusefs-
DISTNAME= ${PORTNAME}-3g-${PORTVERSION}
EXTRACT_SUFX= .tgz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:ntfs
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Mount NTFS partitions and disk images
+BUILD_DEPENDS= fusefs-libs>=2.6.0:${PORTSDIR}/sysutils/fusefs-libs
LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
-BUILD_DEPENDS= fusefs-libs>=2.6.0:${PORTSDIR}/sysutils/fusefs-libs
-USE_AUTOTOOLS= libtool:15
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
ONLY_FOR_ARCHS= i386 amd64
USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+OPTIONS= LOCK "Lock the device when mounting (avoids access)" off \
+ UBLIO "Enable user space cache for improved speed" on
+
MAN8= ntfs-3g.8
-post-patch:
- @${CP} ${FILESDIR}/unix_io_raw.c ${WRKSRC}/libntfs-3g
+UBLIO_SRC= libublio-20070103
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.if defined(WITH_LOCK)
+CFLAGS+= -DUSE_LOCK
.endif
+.if defined(WITH_UBLIO)
+DISTFILES+= ${UBLIO_SRC}.tar.gz:ublio
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ublio
+CFLAGS+= -DUSE_UBLIO
+SUB_FILES+= pkg-message
+
+post-extract:
+ @cd ${WRKDIR}/${UBLIO_SRC} && \
+ ${CP} ublio.c ${WRKSRC}/libntfs-3g && \
+ ${CP} *.h ${WRKSRC}/include/ntfs-3g
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+.else
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "WARNING: FreeBSD does not have cache support for block devices. This will considerably reduce the performance of this application, please consider enabling the UBLIO option and following the indications in the post-installation message." | ${FMT}
+ @${ECHO_MSG}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|,nonempty||' ${WRKSRC}/src/ntfs-3g.c
+
.include <bsd.port.post.mk>