aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-rar2fs
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-27 19:32:10 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-27 19:32:10 +0000
commitbc31fc84dad093544f3b956557378924bdde95f7 (patch)
tree5b17ef6299acd00b67db04adae1c3d8c8dd29a47 /sysutils/fusefs-rar2fs
parent577d93bf4ddc69623582d80e34c6ba2314fba018 (diff)
downloadports-bc31fc84dad093544f3b956557378924bdde95f7.tar.gz
ports-bc31fc84dad093544f3b956557378924bdde95f7.zip
Notes
Diffstat (limited to 'sysutils/fusefs-rar2fs')
-rw-r--r--sysutils/fusefs-rar2fs/Makefile37
-rw-r--r--sysutils/fusefs-rar2fs/distinfo4
-rw-r--r--sysutils/fusefs-rar2fs/files/patch-config.mk52
-rw-r--r--sysutils/fusefs-rar2fs/pkg-descr9
4 files changed, 102 insertions, 0 deletions
diff --git a/sysutils/fusefs-rar2fs/Makefile b/sysutils/fusefs-rar2fs/Makefile
new file mode 100644
index 000000000000..ddaade55d407
--- /dev/null
+++ b/sysutils/fusefs-rar2fs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection Makefile for: rar2fs
+# Date created: 30 May 2011
+# Whom: Joris Vandalon
+#
+# $FreeBSD$
+#
+
+PORTNAME= rar2fs
+PORTVERSION= 1.13.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}:rar2fs http://www.rarlab.com/rar/:unrarsrc
+PKGNAMEPREFIX= fusefs-
+DISTFILES= rar2fs-1.13.0.tar.gz:rar2fs unrarsrc-4.0.7.tar.gz:unrarsrc
+
+MAINTAINER= joris@vandalon.nl
+COMMENT= Mount rar archives as filesystem
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= unrar.3:${PORTSDIR}/archivers/libunrar4 \
+ fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= rar2fs.1
+USE_GMAKE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' \
+ -e 's,%%PREFIX%%,${LOCALBASE},' \
+ ${WRKSRC}/config.mk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-rar2fs/distinfo b/sysutils/fusefs-rar2fs/distinfo
new file mode 100644
index 000000000000..e4c205423688
--- /dev/null
+++ b/sysutils/fusefs-rar2fs/distinfo
@@ -0,0 +1,4 @@
+SHA256 (rar2fs-1.13.0.tar.gz) = 8ab2740b3d7dc073d67a502db8f822c66d533175fca54a79a1c905140b165dec
+SIZE (rar2fs-1.13.0.tar.gz) = 63785
+SHA256 (unrarsrc-4.0.7.tar.gz) = eac9ed7493870ca7f67b23e9208aef1db701c381123ac462e97f703777a33071
+SIZE (unrarsrc-4.0.7.tar.gz) = 152853
diff --git a/sysutils/fusefs-rar2fs/files/patch-config.mk b/sysutils/fusefs-rar2fs/files/patch-config.mk
new file mode 100644
index 000000000000..5ce1ddb44e94
--- /dev/null
+++ b/sysutils/fusefs-rar2fs/files/patch-config.mk
@@ -0,0 +1,52 @@
+$FreeBSD$
+
+Automatically fills in the correct areas in config.mk with FreeBSD-sane
+defaults. Sed is used to correct the substitutions.
+
+--- config.mk.orig 2011-05-17 21:17:09.000000000 +0200
++++ config.mk 2011-05-30 14:11:09.689753703 +0200
+@@ -1,37 +1,39 @@
+ # Change below to match current configuration
+ ##########################
+
++DESTDIR=%%PREFIX%%
++
+ ##########################
+ # This is the path (absolute or relative) to the folder containing
+ # the full portable "Unrar C++ library" (libunrar) sources
+-UNRAR_SRC=./unrar
++UNRAR_SRC=../unrar
+
+ ##########################
+ # This is the path (absolute or relative) to the folder containing
+ # the compiled libunrar.so.
+ # This can be left blank if the system already points out the location
+ # of a compatible unrarlib.so, eg. /lib.
+-UNRAR_LIB=
++UNRAR_LIB=%%LOCALBASE%%/lib
+
+ ##########################
+ # This is the path (absolute or relative) to the folder containing
+ # the FUSE development header files.
+ # This can be left blank if the header files are already placed in
+ # some default location such as /usr/include.
+-FUSE_SRC=
++FUSE_SRC=%%LOCALBASE%%/include
+
+ ##########################
+ # This is the path (absolute or relative) to the folder containing
+ # the FUSE library files.
+ # This can be left blank if the system already points out the location
+ # of a compatible FUSE library, eg. /lib.
+-FUSE_LIB=
++FUSE_LIB=%%LOCALBASE%%/lib
+
+ ##########################
+ # Does the host support glibc custom streams?
+ # If unsure try 'y' here. If linker fails to find e.g. fmemopen()
+ # your answer was most likely incorrect.
+-HAS_GLIBC_CUSTOM_STREAMS=y
++HAS_GLIBC_CUSTOM_STREAMS=n
+
+ ##########################
+ # For Mac OS X, choose if 64-bit inodes (file serial number) should
diff --git a/sysutils/fusefs-rar2fs/pkg-descr b/sysutils/fusefs-rar2fs/pkg-descr
new file mode 100644
index 000000000000..ddba1c0a5f1b
--- /dev/null
+++ b/sysutils/fusefs-rar2fs/pkg-descr
@@ -0,0 +1,9 @@
+rar2fs is a FUSE based file system that can mount a source RAR
+archive/volume or a directory containing any number of RAR
+archives and access (read only) the contents as plain files/directories.
+Other files located in the source directory are handled transparently.
+Both compressed and non-compressed archives/volumes are supported but
+full media seek support (aka. indexing) is only available for
+non-compressed plaintext archives.
+
+WWW: http://code.google.com/p/rar2fs/