aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-s3fs
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-01-18 15:21:20 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-01-18 15:21:20 +0000
commit105219b57fa5d5896d7d9c63e09b68f08f884dc8 (patch)
treec091f1608fa764495fe4651208146b74f1b64c7a /sysutils/fusefs-s3fs
parentdbe759b042caeda328bfaa673095af7082cdb77e (diff)
downloadports-105219b57fa5d5896d7d9c63e09b68f08f884dc8.tar.gz
ports-105219b57fa5d5896d7d9c63e09b68f08f884dc8.zip
Upgrade to 1.74.
Notes
Notes: svn path=/head/; revision=377334
Diffstat (limited to 'sysutils/fusefs-s3fs')
-rw-r--r--sysutils/fusefs-s3fs/Makefile3
-rw-r--r--sysutils/fusefs-s3fs/distinfo4
-rw-r--r--sysutils/fusefs-s3fs/files/patch-src-curl.cpp11
-rw-r--r--sysutils/fusefs-s3fs/files/patch-src__curl.h11
4 files changed, 14 insertions, 15 deletions
diff --git a/sysutils/fusefs-s3fs/Makefile b/sysutils/fusefs-s3fs/Makefile
index 64fbe2f90256..3c2412bae027 100644
--- a/sysutils/fusefs-s3fs/Makefile
+++ b/sysutils/fusefs-s3fs/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= s3fs
-DISTVERSION= 1.71
-PORTREVISION= 2
+DISTVERSION= 1.74
CATEGORIES= sysutils
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-s3fs/distinfo b/sysutils/fusefs-s3fs/distinfo
index 62529840974d..f220aa3a00eb 100644
--- a/sysutils/fusefs-s3fs/distinfo
+++ b/sysutils/fusefs-s3fs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (s3fs-1.71.tar.gz) = a31a2c318c7149a5f387a69583fcecbf0ce8afa581a89a2a683c5ca5f7331e8d
-SIZE (s3fs-1.71.tar.gz) = 167136
+SHA256 (s3fs-1.74.tar.gz) = d77d540582fe8287354fd3637e48064f81f6fe80c5f0e0f8253221c56b892b88
+SIZE (s3fs-1.74.tar.gz) = 199120
diff --git a/sysutils/fusefs-s3fs/files/patch-src-curl.cpp b/sysutils/fusefs-s3fs/files/patch-src-curl.cpp
deleted file mode 100644
index 963a094b2c2d..000000000000
--- a/sysutils/fusefs-s3fs/files/patch-src-curl.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/curl.cpp.orig 2014-03-04 22:16:31.000000000 +0100
-+++ src/curl.cpp 2014-03-04 22:16:41.000000000 +0100
-@@ -53,7 +53,7 @@
- // Typedef
- //-------------------------------------------------------------------
- struct case_insensitive_compare_func {
-- bool operator ()(const string &a, const string &b) {
-+ bool operator ()(const string &a, const string &b) const {
- return strcasecmp(a.c_str(), b.c_str()) < 0;
- }
- };
diff --git a/sysutils/fusefs-s3fs/files/patch-src__curl.h b/sysutils/fusefs-s3fs/files/patch-src__curl.h
new file mode 100644
index 000000000000..7bae7dec826d
--- /dev/null
+++ b/sysutils/fusefs-s3fs/files/patch-src__curl.h
@@ -0,0 +1,11 @@
+--- src/curl.h.orig 2015-01-18 22:44:00.232344078 +0800
++++ src/curl.h 2015-01-18 22:44:37.736341674 +0800
+@@ -85,7 +85,7 @@ struct filepart
+ // for progress
+ struct case_insensitive_compare_func
+ {
+- bool operator()(const std::string& a, const std::string& b){
++ bool operator()(const std::string& a, const std::string& b) const {
+ return strcasecmp(a.c_str(), b.c_str()) < 0;
+ }
+ };