aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-smbnetfs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-28 20:41:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-28 20:41:33 +0000
commit55ae413eca29e228d1868963eff2aa8134cae3f6 (patch)
tree48b7744faf29faa2c7bf609b7ba794520b4b0ded /sysutils/fusefs-smbnetfs
parentdebe315de95bacb01041810afdf3487bc998fe1f (diff)
downloadports-55ae413eca29e228d1868963eff2aa8134cae3f6.tar.gz
ports-55ae413eca29e228d1868963eff2aa8134cae3f6.zip
Notes
Diffstat (limited to 'sysutils/fusefs-smbnetfs')
-rw-r--r--sysutils/fusefs-smbnetfs/Makefile38
-rw-r--r--sysutils/fusefs-smbnetfs/distinfo3
-rw-r--r--sysutils/fusefs-smbnetfs/files/pkg-message.in23
-rw-r--r--sysutils/fusefs-smbnetfs/pkg-descr20
-rw-r--r--sysutils/fusefs-smbnetfs/pkg-plist5
5 files changed, 89 insertions, 0 deletions
diff --git a/sysutils/fusefs-smbnetfs/Makefile b/sysutils/fusefs-smbnetfs/Makefile
new file mode 100644
index 000000000000..756ca557705b
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: smbnetfs
+# Date created: 06 August 2006
+# Whom: Denis Barov
+# $FreeBSD$
+#
+
+PORTNAME= smbnetfs
+PORTVERSION= 0.3.6
+CATEGORIES= sysutils net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= fusefs-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= dindin@freebsd.org.ua
+COMMENT= Mount smb shares (Fuse filesystem)
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= fusefs-libs>2.4.1:${PORTSDIR}/sysutils/fusefs-libs
+
+USE_BZIP2= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include"
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-smbnetfs/distinfo b/sysutils/fusefs-smbnetfs/distinfo
new file mode 100644
index 000000000000..75d375f1764a
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (smbnetfs-0.3.6.tar.bz2) = 22e922e50c3ffaada89e463d57526ef4
+SHA256 (smbnetfs-0.3.6.tar.bz2) = f63c56302b533aa9138ee84ce59e8014baec86c7105184679c51f574f2db7749
+SIZE (smbnetfs-0.3.6.tar.bz2) = 101942
diff --git a/sysutils/fusefs-smbnetfs/files/pkg-message.in b/sysutils/fusefs-smbnetfs/files/pkg-message.in
new file mode 100644
index 000000000000..00d5b9302f08
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/files/pkg-message.in
@@ -0,0 +1,23 @@
+===> Basic Instructions:
+
+After kldload fuse.ko (see sysutils/fusefs-kmod documentation) and setting
+
+ # sysctl vfs.usermount=1
+
+you should make .smb directory in your homedir:
+
+ % mkdir ~/.smb
+
+Copy your smb.conf (usually in %%PREFIX%%/etc/) and
+%%PREFIX%%/share/doc/smbnetfs/smbnetfs.conf to this directory:
+
+ % cp %%PREFIX%%/smb.conf %%PREFIX%%/share/doc/smbnetfs/smbnetfs.conf ~/.smb/
+
+Make mountpoint for smb network and mount it:
+
+ % mkdir ~/mountpoint
+ % smbnetfs ~/mountpoint
+
+Now you can get access to smb shares in your network, for example:
+
+ % cd ~/mountpoint/ip-addr
diff --git a/sysutils/fusefs-smbnetfs/pkg-descr b/sysutils/fusefs-smbnetfs/pkg-descr
new file mode 100644
index 000000000000..7c82c6e60f67
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/pkg-descr
@@ -0,0 +1,20 @@
+SMBNetFS is a filesystem that allow you to use samba/microsoft network
+in the same manner as the network neighborhood in Microsoft Windows.
+
+Featuries:
+ * you can use Samba/Microsoft network as a regular unix filesystem
+ * workgroup/computer/share entries are dynamically created
+ * windows domain supported
+ * kerberos support (New)
+ * user defined workgroup/link/hosts are supported
+ * national character supported
+ * in config files you can specify different user/password to access
+ different network shares
+ * you can access any computer in the world by "cd mountpoint/ip-addr"
+ command, where "ip-addr" is the IP address of the desired computer. Do
+ not warry that there is no file with such name :-)
+ * command "cd mountpoint/username:password@computer_or_ip" allows
+ you to access "computer_or_ip" as user "username" with password
+ "password" (this is insecure, but usefull)
+
+WWW: http://sourceforge.net/projects/smbnetfs
diff --git a/sysutils/fusefs-smbnetfs/pkg-plist b/sysutils/fusefs-smbnetfs/pkg-plist
new file mode 100644
index 000000000000..621ac687956a
--- /dev/null
+++ b/sysutils/fusefs-smbnetfs/pkg-plist
@@ -0,0 +1,5 @@
+bin/smbnetfs
+share/doc/smbnetfs/INSTALL
+share/doc/smbnetfs/RUSSIAN.FAQ
+share/doc/smbnetfs/smbnetfs.conf
+@dirrm share/doc/smbnetfs