aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-sqlfs/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 14:29:25 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 14:29:25 +0000
commit560bc217f1211d041da8228ff24c830b8e3e5670 (patch)
tree0d1f4349aa86f2d7751fa83f2738e68a45e818fe /sysutils/fusefs-sqlfs/Makefile
parent5fed5ec4d974f1a5e61f044641303b409083e5da (diff)
downloadports-560bc217f1211d041da8228ff24c830b8e3e5670.tar.gz
ports-560bc217f1211d041da8228ff24c830b8e3e5670.zip
Notes
Diffstat (limited to 'sysutils/fusefs-sqlfs/Makefile')
-rw-r--r--sysutils/fusefs-sqlfs/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/fusefs-sqlfs/Makefile b/sysutils/fusefs-sqlfs/Makefile
new file mode 100644
index 000000000000..cbe6edb68c30
--- /dev/null
+++ b/sysutils/fusefs-sqlfs/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: fusefs-sqlfs
+# Date created: 2006-08-19
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= sqlfs
+PORTVERSION= 20060811
+CATEGORIES= sysutils
+MASTER_SITES= http://www.palmsource.com/opensource/downloads/
+PKGNAMEPREFIX= fusefs-
+DISTNAME= lib${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= SQLite backed FUSE file system
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_SQLITE= 3
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
+PLIST_FILES= bin/sqlfs
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+do-build:
+ (cd ${WRKSRC} && ${CC} -DFUSE -DFUSE_USE_VERSION=25 \
+ -D_FILE_OFFSET_BITS=64 -D_REENTRANT ${CFLAGS} \
+ -I${LOCALBASE}/include -I. -L${LOCALBASE}/lib \
+ -lfuse -lsqlite${SQLITE_VER} ${PTHREAD_CFLAGS} \
+ ${PTHREAD_LIBS} sqlfs.c fuse_main.c -o sqlfs)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sqlfs ${TARGETDIR}/bin/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>