aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-sshfs
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-10-31 12:49:43 +0000
committerSimon Barner <barner@FreeBSD.org>2005-10-31 12:49:43 +0000
commit4e1f2cf3f4e254976f5f343f97ee7c3d009e7339 (patch)
tree45b8d34c60699f74535caa87e488659b06c07315 /sysutils/fusefs-sshfs
parente86bfbbaee6c8353afbc61c62ff1e5e35cf5b94e (diff)
downloadports-4e1f2cf3f4e254976f5f343f97ee7c3d009e7339.tar.gz
ports-4e1f2cf3f4e254976f5f343f97ee7c3d009e7339.zip
Notes
Diffstat (limited to 'sysutils/fusefs-sshfs')
-rw-r--r--sysutils/fusefs-sshfs/Makefile4
-rw-r--r--sysutils/fusefs-sshfs/distinfo4
-rw-r--r--sysutils/fusefs-sshfs/files/patch-sshfs.c31
-rw-r--r--sysutils/fusefs-sshfs/pkg-message2
4 files changed, 26 insertions, 15 deletions
diff --git a/sysutils/fusefs-sshfs/Makefile b/sysutils/fusefs-sshfs/Makefile
index 232d3a15e637..d0755bd6d7c9 100644
--- a/sysutils/fusefs-sshfs/Makefile
+++ b/sysutils/fusefs-sshfs/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= sshfs
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fuse
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 600000
-IGNORE= Depends on kernel module that requires FreeBSD 6 or later
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
.endif
post-install:
diff --git a/sysutils/fusefs-sshfs/distinfo b/sysutils/fusefs-sshfs/distinfo
index 772f595da15e..f4185a8fe551 100644
--- a/sysutils/fusefs-sshfs/distinfo
+++ b/sysutils/fusefs-sshfs/distinfo
@@ -1,2 +1,2 @@
-MD5 (sshfs-fuse-1.2.tar.gz) = 685dc6611e20242602105fe4960a6ab9
-SIZE (sshfs-fuse-1.2.tar.gz) = 86239
+MD5 (sshfs-fuse-1.3.tar.gz) = 40fe4a353d03b80f8b37e4b0cc6159d3
+SIZE (sshfs-fuse-1.3.tar.gz) = 88738
diff --git a/sysutils/fusefs-sshfs/files/patch-sshfs.c b/sysutils/fusefs-sshfs/files/patch-sshfs.c
index 81e22c2e5041..629d99af3de0 100644
--- a/sysutils/fusefs-sshfs/files/patch-sshfs.c
+++ b/sysutils/fusefs-sshfs/files/patch-sshfs.c
@@ -1,5 +1,5 @@
---- sshfs.c.orig Mon Aug 15 05:07:08 2005
-+++ sshfs.c Sun Oct 9 13:12:45 2005
+--- sshfs.c.orig Fri Oct 28 08:15:35 2005
++++ sshfs.c Mon Oct 31 02:59:33 2005
@@ -14,7 +14,11 @@
#include <unistd.h>
#include <fcntl.h>
@@ -27,7 +27,7 @@
#include "cache.h"
#include "opts.h"
-@@ -970,7 +981,11 @@
+@@ -1070,7 +1081,11 @@
err = req->error;
goto out;
}
@@ -39,7 +39,7 @@
if (req->reply_type != expect_type && req->reply_type != SSH_FXP_STATUS) {
fprintf(stderr, "protocol error\n");
goto out;
-@@ -985,21 +1000,35 @@
+@@ -1085,21 +1100,35 @@
if (expect_type == SSH_FXP_STATUS)
err = 0;
else
@@ -76,19 +76,19 @@
}
} else {
buf_init(outbuf, req->reply.size - req->reply.len);
-@@ -1039,7 +1068,11 @@
+@@ -1142,7 +1171,11 @@
err = sftp_request(SSH_FXP_LSTAT, &buf, SSH_FXP_ATTRS, &outbuf);
if (!err) {
- if (buf_get_attrs(&outbuf, stbuf) == -1)
+ if (buf_get_attrs(&outbuf, stbuf, NULL) == -1)
+#ifdef EPROTO
err = -EPROTO;
+#else
-+ err = -EPROTONOSUPPORT;
++ err = -EPROTONOSUPPORT;
+#endif
buf_free(&outbuf);
}
buf_free(&buf);
-@@ -1061,7 +1094,11 @@
+@@ -1164,7 +1197,11 @@
if (!err) {
uint32_t count;
char *link;
@@ -100,7 +100,7 @@
if(buf_get_uint32(&name, &count) != -1 && count == 1 &&
buf_get_string(&name, &link) != -1) {
strncpy(linkbuf, link, size-1);
-@@ -1092,7 +1129,11 @@
+@@ -1195,7 +1232,11 @@
err = sftp_request(SSH_FXP_READDIR, &handle, SSH_FXP_NAME, &name);
if (!err) {
if (buf_get_entries(&name, h, filler) == -1)
@@ -112,7 +112,7 @@
buf_free(&name);
}
} while (!err);
-@@ -1377,7 +1418,11 @@
+@@ -1528,7 +1569,11 @@
err = sftp_request(SSH_FXP_READ, &buf, SSH_FXP_DATA, &data);
if (!err) {
uint32_t retsize;
@@ -124,7 +124,7 @@
if (buf_get_uint32(&data, &retsize) != -1) {
if (retsize > size)
fprintf(stderr, "long read\n");
-@@ -1399,7 +1444,11 @@
+@@ -1550,7 +1595,11 @@
if (req->error)
chunk->res = req->error;
else if (req->replied) {
@@ -136,3 +136,12 @@
if (req->reply_type == SSH_FXP_STATUS) {
uint32_t serr;
+@@ -1771,7 +1820,7 @@
+ {
+ (void) path;
+
+- buf->f_namelen = 255;
++ buf->f_namemax = 255;
+ buf->f_bsize = 512;
+ buf->f_blocks = 999999999 * 2;
+ buf->f_bfree = 999999999 * 2;
diff --git a/sysutils/fusefs-sshfs/pkg-message b/sysutils/fusefs-sshfs/pkg-message
index 648b854e7af7..84f26708b576 100644
--- a/sysutils/fusefs-sshfs/pkg-message
+++ b/sysutils/fusefs-sshfs/pkg-message
@@ -17,3 +17,5 @@ or
2)
% mount_fusefs auto /path/to/mount/point sshfs -o uid=<local uid> \
-o gid=<local gid> username@example.org:
+
+For further options see ``sshfs -h''.