aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-unionfs
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-06 04:01:20 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-06 04:01:20 +0000
commit3b602210acda290149ab29547b0ce76bc893b324 (patch)
tree907981fc8d0217f87951d3765e601b8d5afec0ae /sysutils/fusefs-unionfs
parentb5e4fe7bf1da6ca43a016d8925a23d9b961f216d (diff)
downloadports-3b602210acda290149ab29547b0ce76bc893b324.tar.gz
ports-3b602210acda290149ab29547b0ce76bc893b324.zip
Notes
Diffstat (limited to 'sysutils/fusefs-unionfs')
-rw-r--r--sysutils/fusefs-unionfs/Makefile4
-rw-r--r--sysutils/fusefs-unionfs/distinfo6
-rw-r--r--sysutils/fusefs-unionfs/files/patch-unionfs.c26
3 files changed, 17 insertions, 19 deletions
diff --git a/sysutils/fusefs-unionfs/Makefile b/sysutils/fusefs-unionfs/Makefile
index bf97694ef775..2d8e6a7bec0c 100644
--- a/sysutils/fusefs-unionfs/Makefile
+++ b/sysutils/fusefs-unionfs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= unionfs
-PORTVERSION= 0.16
+PORTVERSION= 0.17
CATEGORIES= sysutils
MASTER_SITES= http://podgorny.cz/unionfs-fuse/releases/
PKGNAMEPREFIX= fusefs-
@@ -25,7 +25,7 @@ USE_BZIP2= yes
do-build:
(cd ${WRKSRC} && \
${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
- -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26 \
+ -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26 -U_POSIX_SYNCHRONIZED_IO \
-o unionfs *.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
do-install:
diff --git a/sysutils/fusefs-unionfs/distinfo b/sysutils/fusefs-unionfs/distinfo
index 29e4dd7c5a71..5bcb915156e9 100644
--- a/sysutils/fusefs-unionfs/distinfo
+++ b/sysutils/fusefs-unionfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (unionfs-fuse-0.16.tar.bz2) = 7eb99f9b217463c2e378533b89219440
-SHA256 (unionfs-fuse-0.16.tar.bz2) = 2264fa51df47bbe62deb0ff78c63db6b4fb9ce59ec1b14f6dd46baa1c89aaa8f
-SIZE (unionfs-fuse-0.16.tar.bz2) = 6175
+MD5 (unionfs-fuse-0.17.tar.bz2) = fba9ebebcc5e8b7d3613f608f1ce1647
+SHA256 (unionfs-fuse-0.17.tar.bz2) = 2f04050f91afb3f9a56d390e5958875531c7e3b90d00c06efe08544968076386
+SIZE (unionfs-fuse-0.17.tar.bz2) = 6447
diff --git a/sysutils/fusefs-unionfs/files/patch-unionfs.c b/sysutils/fusefs-unionfs/files/patch-unionfs.c
index 884a3448e366..52938c5dbe0d 100644
--- a/sysutils/fusefs-unionfs/files/patch-unionfs.c
+++ b/sysutils/fusefs-unionfs/files/patch-unionfs.c
@@ -1,16 +1,14 @@
---- unionfs.c.orig Mon Aug 7 07:20:13 2006
-+++ unionfs.c Tue Aug 8 13:53:17 2006
-@@ -188,12 +188,7 @@
+--- unionfs.c.orig Tue Mar 6 10:40:41 2007
++++ unionfs.c Tue Mar 6 10:46:09 2007
+@@ -192,11 +192,7 @@
- if (stats_enabled && strcmp(path, STATS_FILENAME) == 0) return 0;
-
-- int res;
-- if (isdatasync) {
+ int res;
+ if (isdatasync) {
+-#ifdef _POSIX_SYNCHRONIZED_IO
- res = fdatasync(fi->fh);
-- } else {
-- res = fsync(fi->fh);
-- }
-+ int res = fsync(fi->fh);
-
- if (res == -1) return -errno;
-
+-#else
+ res = fsync(fi->fh);
+-#endif
+ } else {
+ res = fsync(fi->fh);
+ }