aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-unionfs
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-17 03:50:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-17 03:50:17 +0000
commit0a5d49084aa119a5fb64d9794dfe10966e88d428 (patch)
tree2775a4dcf111f47d181358126e3f2ab2da37f085 /sysutils/fusefs-unionfs
parent315060a5340133e4d07ddb0732fc59c0b96e44c7 (diff)
downloadports-0a5d49084aa119a5fb64d9794dfe10966e88d428.tar.gz
ports-0a5d49084aa119a5fb64d9794dfe10966e88d428.zip
Notes
Diffstat (limited to 'sysutils/fusefs-unionfs')
-rw-r--r--sysutils/fusefs-unionfs/Makefile40
-rw-r--r--sysutils/fusefs-unionfs/distinfo3
-rw-r--r--sysutils/fusefs-unionfs/files/patch-unionfs.c16
-rw-r--r--sysutils/fusefs-unionfs/pkg-descr6
4 files changed, 65 insertions, 0 deletions
diff --git a/sysutils/fusefs-unionfs/Makefile b/sysutils/fusefs-unionfs/Makefile
new file mode 100644
index 000000000000..e4c83a32e1b6
--- /dev/null
+++ b/sysutils/fusefs-unionfs/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: fusefs-unionfs
+# Date created: 2006-07-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unionfs
+PORTVERSION= 0.14
+CATEGORIES= sysutils
+MASTER_SITES= http://podgorny.cz/unionfs-fuse/releases/
+PKGNAMEPREFIX= fusefs-
+DISTNAME= unionfs-fuse-${PORTVERSION}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= FUSE based implementation of the well-known unionfs
+
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+PLIST_FILES= bin/unionfs
+
+USE_BZIP2= yes
+
+do-build:
+ (cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
+ -D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=25 \
+ -o unionfs *.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unionfs ${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000 # Inherited from fusefs-kmod
+IGNORE= requires FreeBSD 6.x or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-unionfs/distinfo b/sysutils/fusefs-unionfs/distinfo
new file mode 100644
index 000000000000..53412d77f756
--- /dev/null
+++ b/sysutils/fusefs-unionfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (unionfs-fuse-0.14.tar.bz2) = 7730e9b99830f50a2c8f884e5a8c0870
+SHA256 (unionfs-fuse-0.14.tar.bz2) = dd32cd853e650c742f87ee5f4aa92892e74add38e72bf9b518dec6783249fe0d
+SIZE (unionfs-fuse-0.14.tar.bz2) = 6025
diff --git a/sysutils/fusefs-unionfs/files/patch-unionfs.c b/sysutils/fusefs-unionfs/files/patch-unionfs.c
new file mode 100644
index 000000000000..e37e1aebd5ad
--- /dev/null
+++ b/sysutils/fusefs-unionfs/files/patch-unionfs.c
@@ -0,0 +1,16 @@
+--- unionfs.c.orig Sun Jul 16 19:02:07 2006
++++ unionfs.c Sun Jul 16 19:05:45 2006
+@@ -189,9 +189,13 @@
+ if (stats_enabled && strcmp(path, STATS_FILENAME) == 0) return 0;
+
+ int res;
++#if FUSE_USE_VERSION >= 26
+ if (isdatasync) {
+ res = fdatasync(fi->fh);
+ } else {
++#else
++ {
++#endif
+ res = fsync(fi->fh);
+ }
+
diff --git a/sysutils/fusefs-unionfs/pkg-descr b/sysutils/fusefs-unionfs/pkg-descr
new file mode 100644
index 000000000000..767af71c5dbf
--- /dev/null
+++ b/sysutils/fusefs-unionfs/pkg-descr
@@ -0,0 +1,6 @@
+This is my effort to create a unionfs filesystem implementation which
+is probably slower but way more flexible than the current in-kernel
+unionfs solution. Currently it's almost fully usable, the only problem
+is new file/directory creation which I will fix soon...
+
+WWW: http://podgorny.cz/moin/UnionFsFuse