aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gather/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-02-16 13:06:12 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-02-16 13:06:12 +0000
commit076ac1652449c6e2b025bc4f8b13996fb7458709 (patch)
treed0500758b72637d50870b0d854c3934480f3c153 /sysutils/gather/Makefile
parentfb12b96b42d5f9541f9c37e02d03846bdb517a4e (diff)
downloadports-076ac1652449c6e2b025bc4f8b13996fb7458709.tar.gz
ports-076ac1652449c6e2b025bc4f8b13996fb7458709.zip
Notes
Diffstat (limited to 'sysutils/gather/Makefile')
-rw-r--r--sysutils/gather/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/sysutils/gather/Makefile b/sysutils/gather/Makefile
new file mode 100644
index 000000000000..fc1a2713c7f1
--- /dev/null
+++ b/sysutils/gather/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: gather
+# Date created: 14 February 2010
+# Whom: Mikolaj Golub <to.my.trociny@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gather
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= to.my.trociny@gmail.com
+COMMENT= Utility to store and display system statistics
+
+PROJECTHOST= gatherit
+
+USE_PERL5= yes
+
+DATADIR= /var/db/gather
+MAKE_ENV+= CONFDIR=${PREFIX}/etc/gather DATADIR=${DATADIR}
+
+SUB_FILES= pkg-message
+
+MAN1= gather.1
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changelog README
+.endif
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= *
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/gather ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/gather.1 ${PREFIX}/man/man1
+.if !exists(${PREFIX}/etc/gather)
+ @${MKDIR} ${PREFIX}/etc/gather
+.endif
+ @${INSTALL_DATA} ${WRKSRC}/gather.cfg ${PREFIX}/etc/gather/gather.cfg.sample
+.if !exists(${CONFDIR}/gather.cfg)
+ @${INSTALL_DATA} ${WRKSRC}/gather.cfg ${PREFIX}/etc/gather/gather.cfg
+.endif
+ @${INSTALL_DATA} ${WRKSRC}/examples/gather.map.freebsd ${PREFIX}/etc/gather/gather.map.sample
+.if !exists(${PREFIX}/etc/gather/gather.cfg)
+ @${INSTALL_DATA} ${WRKSRC}/examples/gather.map.freebsd ${PREFIX}/etc/gather/gather.map
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>