aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gather
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-02-16 13:06:12 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-02-16 13:06:12 +0000
commit076ac1652449c6e2b025bc4f8b13996fb7458709 (patch)
treed0500758b72637d50870b0d854c3934480f3c153 /sysutils/gather
parentfb12b96b42d5f9541f9c37e02d03846bdb517a4e (diff)
downloadports-076ac1652449c6e2b025bc4f8b13996fb7458709.tar.gz
ports-076ac1652449c6e2b025bc4f8b13996fb7458709.zip
Notes
Diffstat (limited to 'sysutils/gather')
-rw-r--r--sysutils/gather/Makefile60
-rw-r--r--sysutils/gather/distinfo3
-rw-r--r--sysutils/gather/files/pkg-message.in23
-rw-r--r--sysutils/gather/pkg-descr6
-rw-r--r--sysutils/gather/pkg-plist6
5 files changed, 98 insertions, 0 deletions
diff --git a/sysutils/gather/Makefile b/sysutils/gather/Makefile
new file mode 100644
index 000000000000..fc1a2713c7f1
--- /dev/null
+++ b/sysutils/gather/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: gather
+# Date created: 14 February 2010
+# Whom: Mikolaj Golub <to.my.trociny@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gather
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= to.my.trociny@gmail.com
+COMMENT= Utility to store and display system statistics
+
+PROJECTHOST= gatherit
+
+USE_PERL5= yes
+
+DATADIR= /var/db/gather
+MAKE_ENV+= CONFDIR=${PREFIX}/etc/gather DATADIR=${DATADIR}
+
+SUB_FILES= pkg-message
+
+MAN1= gather.1
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changelog README
+.endif
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= *
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/gather ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/gather.1 ${PREFIX}/man/man1
+.if !exists(${PREFIX}/etc/gather)
+ @${MKDIR} ${PREFIX}/etc/gather
+.endif
+ @${INSTALL_DATA} ${WRKSRC}/gather.cfg ${PREFIX}/etc/gather/gather.cfg.sample
+.if !exists(${CONFDIR}/gather.cfg)
+ @${INSTALL_DATA} ${WRKSRC}/gather.cfg ${PREFIX}/etc/gather/gather.cfg
+.endif
+ @${INSTALL_DATA} ${WRKSRC}/examples/gather.map.freebsd ${PREFIX}/etc/gather/gather.map.sample
+.if !exists(${PREFIX}/etc/gather/gather.cfg)
+ @${INSTALL_DATA} ${WRKSRC}/examples/gather.map.freebsd ${PREFIX}/etc/gather/gather.map
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/gather/distinfo b/sysutils/gather/distinfo
new file mode 100644
index 000000000000..061dd91d00a2
--- /dev/null
+++ b/sysutils/gather/distinfo
@@ -0,0 +1,3 @@
+MD5 (gather-0.3.tar.gz) = 3a599727542fbf8dc741e7211eb262dd
+SHA256 (gather-0.3.tar.gz) = 184991f065ae390243b87cff4708f935fbb447a31e6a0e7e620c1a929882655c
+SIZE (gather-0.3.tar.gz) = 13235
diff --git a/sysutils/gather/files/pkg-message.in b/sysutils/gather/files/pkg-message.in
new file mode 100644
index 000000000000..55248905978c
--- /dev/null
+++ b/sysutils/gather/files/pkg-message.in
@@ -0,0 +1,23 @@
+**********************************************************************
+
+To setup statistics gathering you could e.g. add something like this
+to /etc/crontab:
+
+ */5 * * * * root %%PREFIX%%/bin/gather collect
+ 18 0 * * * root %%PREFIX%%/bin/gather expire 7
+
+Before adding this, please, review the configuration in
+%%PREFIX%%/etc/gather.
+
+To check that the configuration is correct, run:
+
+ gather show utils
+ gather -v collect
+
+After setting cron up, you can check if gathering works running:
+
+ gather show -t 1h grep . uptime
+
+See gather(1) and %%DOCSDIR%%/README for more details.
+
+**********************************************************************
diff --git a/sysutils/gather/pkg-descr b/sysutils/gather/pkg-descr
new file mode 100644
index 000000000000..49afe490d936
--- /dev/null
+++ b/sysutils/gather/pkg-descr
@@ -0,0 +1,6 @@
+gather utility can be used to store system statistics provided by
+variety of system utils and display it. It is just a wrapper around
+these utilities to make a work with system statistics more convenient.
+
+WWW: http://gatherit.googlecode.com/
+Author: Mikolaj Golub <to.my.trociny@gmail.com>
diff --git a/sysutils/gather/pkg-plist b/sysutils/gather/pkg-plist
new file mode 100644
index 000000000000..9f0be011901e
--- /dev/null
+++ b/sysutils/gather/pkg-plist
@@ -0,0 +1,6 @@
+bin/gather
+@unexec if cmp -s %D/etc/gather/gather.cfg.sample %D/etc/gather/gather.cfg; then rm -f %D/etc/gather/gather.cfg; else echo "If permanently deleting this package, %D/etc/gather/gather.cfg must be removed manually."; fi
+etc/gather/gather.cfg.sample
+@unexec if cmp -s %D/etc/gather/gather.map.sample %D/etc/gather/gather.map; then rm -f %D/etc/gather/gather.map; else echo "If permanently deleting this package, %D/etc/gather/gather.map must be removed manually."; fi
+etc/gather/gather.map.sample
+@dirrmtry etc/gather