aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gdisk
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-22 16:54:24 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-22 16:54:24 +0000
commitc31ce5539e3a081ce353bc3962cf8a4c49d41991 (patch)
tree51079ad1de36720f0afd3988115ba6ad1ef1a2c5 /sysutils/gdisk
parente95200bc3920c9f4e2cda25019802130456b7dd2 (diff)
downloadports-c31ce5539e3a081ce353bc3962cf8a4c49d41991.tar.gz
ports-c31ce5539e3a081ce353bc3962cf8a4c49d41991.zip
Notes
Diffstat (limited to 'sysutils/gdisk')
-rw-r--r--sysutils/gdisk/Makefile53
-rw-r--r--sysutils/gdisk/distinfo3
-rw-r--r--sysutils/gdisk/files/patch-gdisk.821
-rw-r--r--sysutils/gdisk/files/patch-gdisk.html21
-rw-r--r--sysutils/gdisk/files/patch-sgdisk.821
-rw-r--r--sysutils/gdisk/files/patch-sgdisk.html21
-rw-r--r--sysutils/gdisk/pkg-descr16
-rw-r--r--sysutils/gdisk/pkg-message14
-rw-r--r--sysutils/gdisk/pkg-plist5
9 files changed, 175 insertions, 0 deletions
diff --git a/sysutils/gdisk/Makefile b/sysutils/gdisk/Makefile
new file mode 100644
index 000000000000..356d6f53afde
--- /dev/null
+++ b/sysutils/gdisk/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: gdisk
+# Date created: 12 July 2010
+# Whom: Dmitry N Fomin <fdn@okbire.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdisk
+PORTVERSION= 0.6.9
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gptfdisk/gptfdisk/${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fdn@okbire.ru
+COMMENT= GPT fdisk
+
+LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ popt.0:${PORTSDIR}/devel/popt
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+FETCH_ARGS= -Rr
+
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 701100
+IGNORE= is unsupported on FreeBSD 7.1-RELEASE or earlier
+.endif
+
+MAKEFILE= Makefile.freebsd
+
+MAN8= gdisk.8 sgdisk.8
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.endif
+.for i in gdisk sgdisk
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/${i}.8 ${MANPREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/${i}.html ${DOCSDIR}
+.endif
+.endfor
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/gdisk/distinfo b/sysutils/gdisk/distinfo
new file mode 100644
index 000000000000..7e852123ab3e
--- /dev/null
+++ b/sysutils/gdisk/distinfo
@@ -0,0 +1,3 @@
+MD5 (gdisk-0.6.9.tgz) = 48740d8de518f79ae9dae7ec58068d05
+SHA256 (gdisk-0.6.9.tgz) = 9f24215f357a5e005118fd3785dee02e8bab4a2c45a9a9db9d9ed464c13c1364
+SIZE (gdisk-0.6.9.tgz) = 129191
diff --git a/sysutils/gdisk/files/patch-gdisk.8 b/sysutils/gdisk/files/patch-gdisk.8
new file mode 100644
index 000000000000..73e4e7bb8d01
--- /dev/null
+++ b/sysutils/gdisk/files/patch-gdisk.8
@@ -0,0 +1,21 @@
+--- gdisk.8 2010-07-04 05:25:20.000000000 +0000
++++ gdisk.8 2010-07-13 20:20:44.000000000 +0000
+@@ -652,12 +652,12 @@
+
+
+ .SH "SEE ALSO"
+-\fBcfdisk (8)\fR,
+-\fBfdisk (8)\fR,
+-\fBmkfs (8)\fR,
+-\fBparted (8)\fR,
+-\fBsfdisk (8)\fR
+-\fBsgdisk (8)\fR
++\fBbsdlabel(8)\fR,
++\fBfdisk(8)\fR,
++\fBgpart(8)\fR,
++\fBgpt(8)\fR,
++\fBnewfs(8)\fR,
++\fBsgdisk(8)\fR
+
+ \fIhttp://en.wikipedia.org/wiki/GUID_Partition_Table\fR
+
diff --git a/sysutils/gdisk/files/patch-gdisk.html b/sysutils/gdisk/files/patch-gdisk.html
new file mode 100644
index 000000000000..47d3293e51db
--- /dev/null
+++ b/sysutils/gdisk/files/patch-gdisk.html
@@ -0,0 +1,21 @@
+--- gdisk.html 2010-07-04 05:25:20.000000000 +0000
++++ gdisk.html 2010-07-14 00:38:37.000000000 +0000
+@@ -763,12 +763,12 @@
+ <A NAME="lbAH">&nbsp;</A>
+ <H2>SEE ALSO</H2>
+
+-<B>cfdisk (8)</B>,
+-<B>fdisk (8)</B>,
+-<B>mkfs (8)</B>,
+-<B>parted (8)</B>,
+-<B>sfdisk (8)</B>
+-<B>sgdisk (8)</B>
++<B>bsdlabel(8)</B>,
++<B>fdisk(8)</B>,
++<B>gpart(8)</B>,
++<B>gpt(8)</B>,
++<B>newfs(8)</B>
++<B>sgdisk(8)</B>
+ <P>
+ <I><A HREF="http://en.wikipedia.org/wiki/GUID_Partition_Table">http://en.wikipedia.org/wiki/GUID_Partition_Table</A></I>
+ <P>
diff --git a/sysutils/gdisk/files/patch-sgdisk.8 b/sysutils/gdisk/files/patch-sgdisk.8
new file mode 100644
index 000000000000..34b23af4a89e
--- /dev/null
+++ b/sysutils/gdisk/files/patch-sgdisk.8
@@ -0,0 +1,21 @@
+--- sgdisk.8 2010-07-04 05:25:20.000000000 +0000
++++ sgdisk.8 2010-07-13 20:21:03.000000000 +0000
+@@ -535,12 +535,12 @@
+ * Justin Maggard (justin.maggard@netgear.com)
+
+ .SH "SEE ALSO"
+-\fBcfdisk (8)\fR,
+-\fBfdisk (8)\fR,
+-\fBgdisk (8)\fR,
+-\fBmkfs (8)\fR,
+-\fBparted (8)\fR,
+-\fBsfdisk (8)\fR
++\fBbsdlabel(8)\fR,
++\fBfdisk(8)\fR,
++\fBgdisk(8)\fR,
++\fBgpart(8)\fR,
++\fBgpt(8)\fR,
++\fBnewfs(8)\fR
+
+ \fIhttp://en.wikipedia.org/wiki/GUID_Partition_Table\fR
+
diff --git a/sysutils/gdisk/files/patch-sgdisk.html b/sysutils/gdisk/files/patch-sgdisk.html
new file mode 100644
index 000000000000..149a9c24ead4
--- /dev/null
+++ b/sysutils/gdisk/files/patch-sgdisk.html
@@ -0,0 +1,21 @@
+--- sgdisk.html 2010-07-04 05:25:20.000000000 +0000
++++ sgdisk.html 2010-07-14 00:42:23.000000000 +0000
+@@ -620,12 +620,12 @@
+ <A NAME="lbAI">&nbsp;</A>
+ <H2>SEE ALSO</H2>
+
+-<B>cfdisk (8)</B>,
+-<B>fdisk (8)</B>,
+-<B>gdisk (8)</B>,
+-<B>mkfs (8)</B>,
+-<B>parted (8)</B>,
+-<B>sfdisk (8)</B>
++<B>bsdlabel(8)</B>,
++<B>fdisk(8)</B>,
++<B>gdisk(8)</B>,
++<B>gpart(8)</B>,
++<B>gpt(8)</B>,
++<B>newfs(8)</B>
+ <P>
+ <I><A HREF="http://en.wikipedia.org/wiki/GUID_Partition_Table">http://en.wikipedia.org/wiki/GUID_Partition_Table</A></I>
+ <P>
diff --git a/sysutils/gdisk/pkg-descr b/sysutils/gdisk/pkg-descr
new file mode 100644
index 000000000000..292a317e0322
--- /dev/null
+++ b/sysutils/gdisk/pkg-descr
@@ -0,0 +1,16 @@
+GPT fdisk (aka gdisk) by Roderick W. Smith, rodsmith@rodsbooks.com
+
+This software is intended as a (somewhat) fdisk-workalike program for
+GPT-partitioned disks. Specific advantages of gdisk and sgdisk include:
+
+ * Edit GUID partition table (GPT) definitions in Linux, FreeBSD, MacOS X,
+ or Windows
+ * Convert MBR to GPT or back without data loss
+ * Convert BSD disklabels to GPT without data loss
+ * Create hybrid MBR, which permits GPT-unaware
+ OSes to access up to three GPT partitions on the disk
+ * Repair damaged GPT data structures
+ * The ability to specify sector-exact partition sizes
+ * Clear identification of the number of unallocated sectors on a disk
+
+WWW: http://www.rodsbooks.com/gdisk/
diff --git a/sysutils/gdisk/pkg-message b/sysutils/gdisk/pkg-message
new file mode 100644
index 000000000000..64adc77b1603
--- /dev/null
+++ b/sysutils/gdisk/pkg-message
@@ -0,0 +1,14 @@
+###############################################################
+!!! WARNING !!! WARNING !!! WARNING !!! WARNING !!! WARNING !!!
+
+ PLEASE, READ DOCUMENTATION BEFORE USE
+
+See `man gdisk' , `man sgdisk' , `${DOCSDIR}/gdisk.html' ,
+`${DOCSDIR}/sgdisk.html'.
+
+Any errors in usage gdisk (sgdisk) or not understanding
+of that you do, can call loss of your data.
+Make a backup copy of all data of a disk before you use
+these programs for its processing.
+
+###############################################################
diff --git a/sysutils/gdisk/pkg-plist b/sysutils/gdisk/pkg-plist
new file mode 100644
index 000000000000..8680982c1dbc
--- /dev/null
+++ b/sysutils/gdisk/pkg-plist
@@ -0,0 +1,5 @@
+sbin/gdisk
+sbin/sgdisk
+%%PORTDOCS%%%%DOCSDIR%%/gdisk.html
+%%PORTDOCS%%%%DOCSDIR%%/sgdisk.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%