aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gdisk
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-09-19 21:04:07 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-09-19 21:04:07 +0000
commitb04cfa0ba62fc8368effefa30592854958bd6f2e (patch)
tree0074297deea2aea8025dce228968b0b5e6d21bf4 /sysutils/gdisk
parent4d20cd34c0757da6f16f31e4b62ddf7dbc8193c1 (diff)
downloadports-b04cfa0ba62fc8368effefa30592854958bd6f2e.tar.gz
ports-b04cfa0ba62fc8368effefa30592854958bd6f2e.zip
Notes
Diffstat (limited to 'sysutils/gdisk')
-rw-r--r--sysutils/gdisk/Makefile55
-rw-r--r--sysutils/gdisk/distinfo4
-rw-r--r--sysutils/gdisk/files/patch-Makefile.freebsd8
-rw-r--r--sysutils/gdisk/files/patch-cgdisk.825
-rw-r--r--sysutils/gdisk/files/patch-fixparts.825
-rw-r--r--sysutils/gdisk/files/patch-gdisk.816
-rw-r--r--sysutils/gdisk/files/patch-gdisk.html21
-rw-r--r--sysutils/gdisk/files/patch-sgdisk.812
-rw-r--r--sysutils/gdisk/files/patch-sgdisk.html21
-rw-r--r--sysutils/gdisk/pkg-descr4
-rw-r--r--sysutils/gdisk/pkg-message7
-rw-r--r--sysutils/gdisk/pkg-plist5
12 files changed, 122 insertions, 81 deletions
diff --git a/sysutils/gdisk/Makefile b/sysutils/gdisk/Makefile
index 70373d1976b4..134a9e6a34e8 100644
--- a/sysutils/gdisk/Makefile
+++ b/sysutils/gdisk/Makefile
@@ -6,25 +6,30 @@
#
PORTNAME= gdisk
-PORTVERSION= 0.6.14
+PORTVERSION= 0.8.0
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= gptfdisk/gptfdisk/${PORTVERSION}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://sourceforge.net/projects/%SUBDIR%/
+MASTER_SITE_SUBDIR= gptfdisk/files/gptfdisk/${PORTVERSION}
+DISTNAME= gptfdisk-${PORTVERSION}
MAINTAINER= fdn@okbire.ru
COMMENT= GPT fdisk
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid \
popt.0:${PORTSDIR}/devel/popt
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+WRKSRC= ${WRKDIR}/gptfdisk-${PORTVERSION}
FETCH_ARGS= -Rr
ONLY_FOR_ARCHS= i386 amd64
+OPTIONS= CGDISK "A curses-based interactive program" off \
+ UTF16 "Support for Unicode partition names" off
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 701100
@@ -33,22 +38,42 @@ IGNORE= is unsupported on FreeBSD 7.1-RELEASE or earlier
MAKEFILE= Makefile.freebsd
-MAN8= gdisk.8 sgdisk.8
+PROGRAM_LIST= fixparts gdisk sgdisk
+
+.if defined(WITH_CGDISK)
+PROGRAM_LIST+= cgdisk
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+PLIST_SUB+= CGDISK=""
+.else
+PLIST_SUB+= CGDISK="@comment "
+.endif
+
+MAN8=
+.for i in ${PROGRAM_LIST}
+MAN8+= ${i}.8
+.endfor
+
+.if defined(WITH_UTF16)
+LIB_DEPENDS+= icuuc.48:${PORTSDIR}/devel/icu
+.endif
post-patch:
${REINPLACE_CMD} -e 's|/usr/include/||' ${WRKSRC}/guid.h
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Makefile.freebsd
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/${MAKEFILE}
-do-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.if !defined(WITH_CGDISK)
+ ${REINPLACE_CMD} -e '/^all:/s| cgdisk||' ${WRKSRC}/${MAKEFILE}
.endif
-.for i in gdisk sgdisk
+
+.if !defined(WITH_UTF16)
+ ${REINPLACE_CMD} -e 's| -D USE_UTF16||' \
+ -e 's| -licuio||' ${WRKSRC}/${MAKEFILE}
+.endif
+
+do-install:
+.for i in ${PROGRAM_LIST}
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/${i}.8 ${MANPREFIX}/man/man8
-.if !defined(NOPORTDOCS)
- ${INSTALL_MAN} ${WRKSRC}/${i}.html ${DOCSDIR}
-.endif
.endfor
post-install:
diff --git a/sysutils/gdisk/distinfo b/sysutils/gdisk/distinfo
index 057836522d10..451b7b7e5d7a 100644
--- a/sysutils/gdisk/distinfo
+++ b/sysutils/gdisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdisk-0.6.14.tgz) = 9e8ff1d5fe17b9f2d00e8c51ccaa5d8d55e7e74f5cd8d936b99ea9366dd7c93c
-SIZE (gdisk-0.6.14.tgz) = 136062
+SHA256 (gptfdisk-0.8.0.tar.gz) = 613c4b5e3d776a2bb723ee1d071ff9121d0f5a6df0f2f760a4536ecd30add824
+SIZE (gptfdisk-0.8.0.tar.gz) = 154431
diff --git a/sysutils/gdisk/files/patch-Makefile.freebsd b/sysutils/gdisk/files/patch-Makefile.freebsd
index 2a757b641bb4..6bab95cebbfb 100644
--- a/sysutils/gdisk/files/patch-Makefile.freebsd
+++ b/sysutils/gdisk/files/patch-Makefile.freebsd
@@ -1,10 +1,10 @@
---- ./Makefile.freebsd.orig 2010-11-21 19:20:03.000000000 +0100
-+++ ./Makefile.freebsd 2010-11-21 19:20:31.000000000 +0100
+--- Makefile.freebsd 2011-09-11 00:51:13.000000000 +0000
++++ Makefile.freebsd 2011-09-18 20:22:41.000000000 +0000
@@ -1,5 +1,5 @@
-CC=gcc
-CXX=g++
+CC?=gcc
+CXX?=g++
CFLAGS+=-D_FILE_OFFSET_BITS=64
- CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -I/usr/local/include
- LDFLAGS+=
+ CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -D USE_UTF16 -I/usr/local/include
+ #CXXFLAGS+=-Wall -D_FILE_OFFSET_BITS=64 -I /usr/local/include
diff --git a/sysutils/gdisk/files/patch-cgdisk.8 b/sysutils/gdisk/files/patch-cgdisk.8
new file mode 100644
index 000000000000..0780bac17477
--- /dev/null
+++ b/sysutils/gdisk/files/patch-cgdisk.8
@@ -0,0 +1,25 @@
+--- cgdisk.8 2011-09-11 00:51:13.000000000 +0000
++++ cgdisk.8 2011-09-18 15:43:22.000000000 +0000
+@@ -365,14 +365,14 @@
+
+
+ .SH "SEE ALSO"
+-\fBcfdisk (8)\fR,
+-\fBfdisk (8)\fR,
+-\fBgdisk (8)\fR,
+-\fBmkfs (8)\fR,
+-\fBparted (8)\fR,
+-\fBsfdisk (8)\fR
+-\fBsgdisk (8)\fR
+-\fBfixparts (8)\fR
++\fBbsdlabel(8)\fR,
++\fBfdisk(8)\fR,
++\fBfixparts(8)\fR,
++\fBgdisk(8)\fR,
++\fBgpart(8)\fR,
++\fBgpt(8)\fR,
++\fBnewfs(8)\fR,
++\fBsgdisk(8)\fR
+
+ \fIhttp://en.wikipedia.org/wiki/GUID_Partition_Table\fR
+
diff --git a/sysutils/gdisk/files/patch-fixparts.8 b/sysutils/gdisk/files/patch-fixparts.8
new file mode 100644
index 000000000000..a7cc8d674f64
--- /dev/null
+++ b/sysutils/gdisk/files/patch-fixparts.8
@@ -0,0 +1,25 @@
+--- fixparts.8 2011-09-11 00:51:13.000000000 +0000
++++ fixparts.8 2011-09-18 15:23:35.000000000 +0000
+@@ -265,14 +265,14 @@
+
+
+ .SH "SEE ALSO"
+-\fBcfdisk (8)\fR,
+-\fBcgdisk (8)\fR,
+-\fBfdisk (8)\fR,
+-\fBmkfs (8)\fR,
+-\fBparted (8)\fR,
+-\fBsfdisk (8)\fR
+-\fBgdisk (8)\fR
+-\fBsgdisk (8)\fR
++\fBbsdlabel(8)\fR,
++\fBcgdisk(8)\fR,
++\fBfdisk(8)\fR,
++\fBgdisk(8)\fR,
++\fBgpart(8)\fR,
++\fBgpt(8)\fR,
++\fBnewfs(8)\fR,
++\fBsgdisk(8)\fR
+
+ \fIhttp://en.wikipedia.org/wiki/Master_boot_record\fR
+
diff --git a/sysutils/gdisk/files/patch-gdisk.8 b/sysutils/gdisk/files/patch-gdisk.8
index 73e4e7bb8d01..6fa3088cb647 100644
--- a/sysutils/gdisk/files/patch-gdisk.8
+++ b/sysutils/gdisk/files/patch-gdisk.8
@@ -1,21 +1,25 @@
---- gdisk.8 2010-07-04 05:25:20.000000000 +0000
-+++ gdisk.8 2010-07-13 20:20:44.000000000 +0000
-@@ -652,12 +652,12 @@
+--- gdisk.8 2011-09-11 00:51:13.000000000 +0000
++++ gdisk.8 2011-09-18 15:33:20.000000000 +0000
+@@ -666,14 +666,14 @@
.SH "SEE ALSO"
-\fBcfdisk (8)\fR,
+-\fBcgdisk (8)\fR,
-\fBfdisk (8)\fR,
-\fBmkfs (8)\fR,
-\fBparted (8)\fR,
-\fBsfdisk (8)\fR
-\fBsgdisk (8)\fR
+-\fBfixparts (8)\fR
+\fBbsdlabel(8)\fR,
-+\fBfdisk(8)\fR,
++\fBcgdisk(8)\fR,
++\fBfdisk(8)\fR,
++\fBfixparts(8)\fR,
+\fBgpart(8)\fR,
+\fBgpt(8)\fR,
-+\fBnewfs(8)\fR,
-+\fBsgdisk(8)\fR
++\fBnewfs(8)\fR,
++\fBsgdisk(8)\fR
\fIhttp://en.wikipedia.org/wiki/GUID_Partition_Table\fR
diff --git a/sysutils/gdisk/files/patch-gdisk.html b/sysutils/gdisk/files/patch-gdisk.html
deleted file mode 100644
index dc0abac5f2e8..000000000000
--- a/sysutils/gdisk/files/patch-gdisk.html
+++ /dev/null
@@ -1,21 +0,0 @@
---- gdisk.html 2010-09-25 23:48:12.000000000 +0000
-+++ gdisk.html 2010-10-02 23:02:08.000000000 +0000
-@@ -775,12 +775,12 @@
- <A NAME="lbAH">&nbsp;</A>
- <H2>SEE ALSO</H2>
-
--<B>cfdisk (8)</B>,
--<B>fdisk (8)</B>,
--<B>mkfs (8)</B>,
--<B>parted (8)</B>,
--<B>sfdisk (8)</B>
--<B>sgdisk (8)</B>
-+<B>bsdlabel(8)</B>,
-+<B>fdisk(8)</B>,
-+<B>gpart(8)</B>,
-+<B>gpt(8)</B>,
-+<B>newfs(8)</B>,
-+<B>sgdisk(8)</B>
- <P>
- <I><A HREF="http://en.wikipedia.org/wiki/GUID_Partition_Table">http://en.wikipedia.org/wiki/GUID_Partition_Table</A></I>
- <P>
diff --git a/sysutils/gdisk/files/patch-sgdisk.8 b/sysutils/gdisk/files/patch-sgdisk.8
index 34b23af4a89e..b09ee334be1a 100644
--- a/sysutils/gdisk/files/patch-sgdisk.8
+++ b/sysutils/gdisk/files/patch-sgdisk.8
@@ -1,17 +1,21 @@
---- sgdisk.8 2010-07-04 05:25:20.000000000 +0000
-+++ sgdisk.8 2010-07-13 20:21:03.000000000 +0000
-@@ -535,12 +535,12 @@
- * Justin Maggard (justin.maggard@netgear.com)
+--- sgdisk.8 2011-09-11 00:51:13.000000000 +0000
++++ sgdisk.8 2011-09-18 15:37:53.000000000 +0000
+@@ -578,14 +578,14 @@
+
.SH "SEE ALSO"
-\fBcfdisk (8)\fR,
+-\fBcgdisk (8)\fR,
-\fBfdisk (8)\fR,
-\fBgdisk (8)\fR,
-\fBmkfs (8)\fR,
-\fBparted (8)\fR,
-\fBsfdisk (8)\fR
+-\fBfixparts (8)\fR
+\fBbsdlabel(8)\fR,
++\fBcgdisk(8)\fR,
+\fBfdisk(8)\fR,
++\fBfixparts(8)\fR,
+\fBgdisk(8)\fR,
+\fBgpart(8)\fR,
+\fBgpt(8)\fR,
diff --git a/sysutils/gdisk/files/patch-sgdisk.html b/sysutils/gdisk/files/patch-sgdisk.html
deleted file mode 100644
index 149a9c24ead4..000000000000
--- a/sysutils/gdisk/files/patch-sgdisk.html
+++ /dev/null
@@ -1,21 +0,0 @@
---- sgdisk.html 2010-07-04 05:25:20.000000000 +0000
-+++ sgdisk.html 2010-07-14 00:42:23.000000000 +0000
-@@ -620,12 +620,12 @@
- <A NAME="lbAI">&nbsp;</A>
- <H2>SEE ALSO</H2>
-
--<B>cfdisk (8)</B>,
--<B>fdisk (8)</B>,
--<B>gdisk (8)</B>,
--<B>mkfs (8)</B>,
--<B>parted (8)</B>,
--<B>sfdisk (8)</B>
-+<B>bsdlabel(8)</B>,
-+<B>fdisk(8)</B>,
-+<B>gdisk(8)</B>,
-+<B>gpart(8)</B>,
-+<B>gpt(8)</B>,
-+<B>newfs(8)</B>
- <P>
- <I><A HREF="http://en.wikipedia.org/wiki/GUID_Partition_Table">http://en.wikipedia.org/wiki/GUID_Partition_Table</A></I>
- <P>
diff --git a/sysutils/gdisk/pkg-descr b/sysutils/gdisk/pkg-descr
index 292a317e0322..ee49547520c6 100644
--- a/sysutils/gdisk/pkg-descr
+++ b/sysutils/gdisk/pkg-descr
@@ -1,7 +1,8 @@
GPT fdisk (aka gdisk) by Roderick W. Smith, rodsmith@rodsbooks.com
This software is intended as a (somewhat) fdisk-workalike program for
-GPT-partitioned disks. Specific advantages of gdisk and sgdisk include:
+GPT-partitioned disks. Specific advantages of gdisk, cgdisk and
+sgdisk include:
* Edit GUID partition table (GPT) definitions in Linux, FreeBSD, MacOS X,
or Windows
@@ -14,3 +15,4 @@ GPT-partitioned disks. Specific advantages of gdisk and sgdisk include:
* Clear identification of the number of unallocated sectors on a disk
WWW: http://www.rodsbooks.com/gdisk/
+ http://www.rodsbooks.com/fixparts/
diff --git a/sysutils/gdisk/pkg-message b/sysutils/gdisk/pkg-message
index 64adc77b1603..739ff4381059 100644
--- a/sysutils/gdisk/pkg-message
+++ b/sysutils/gdisk/pkg-message
@@ -3,11 +3,10 @@
PLEASE, READ DOCUMENTATION BEFORE USE
-See `man gdisk' , `man sgdisk' , `${DOCSDIR}/gdisk.html' ,
-`${DOCSDIR}/sgdisk.html'.
+See `man gdisk' , `man cgdisk', `man sgdisk', `man fixparts'.
-Any errors in usage gdisk (sgdisk) or not understanding
-of that you do, can call loss of your data.
+Any errors in usage gdisk (cgdisk, sgdisk, fixparts) or
+not understanding of that you do, can call loss of your data.
Make a backup copy of all data of a disk before you use
these programs for its processing.
diff --git a/sysutils/gdisk/pkg-plist b/sysutils/gdisk/pkg-plist
index 8680982c1dbc..18365a35a363 100644
--- a/sysutils/gdisk/pkg-plist
+++ b/sysutils/gdisk/pkg-plist
@@ -1,5 +1,4 @@
+%%CGDISK%%sbin/cgdisk
+sbin/fixparts
sbin/gdisk
sbin/sgdisk
-%%PORTDOCS%%%%DOCSDIR%%/gdisk.html
-%%PORTDOCS%%%%DOCSDIR%%/sgdisk.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%