aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gdmap
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-14 14:36:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-14 14:36:57 +0000
commitbc4d2655da0aaaaac3e147311d0fa97e3b213e47 (patch)
tree8ecbafe475400f5bf85a01530ec064e0abe25825 /sysutils/gdmap
parent84a074775ada8a663fae07a939188da06b7ea7df (diff)
downloadports-bc4d2655da0aaaaac3e147311d0fa97e3b213e47.tar.gz
ports-bc4d2655da0aaaaac3e147311d0fa97e3b213e47.zip
Notes
Diffstat (limited to 'sysutils/gdmap')
-rw-r--r--sysutils/gdmap/Makefile37
-rw-r--r--sysutils/gdmap/distinfo2
-rw-r--r--sysutils/gdmap/pkg-descr12
-rw-r--r--sysutils/gdmap/pkg-plist6
4 files changed, 57 insertions, 0 deletions
diff --git a/sysutils/gdmap/Makefile b/sysutils/gdmap/Makefile
new file mode 100644
index 000000000000..7b938c507b96
--- /dev/null
+++ b/sysutils/gdmap/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gdmap
+# Date created: 13 Oct 2005
+# Whom: Rodrigo Graeff <delphus@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdmap
+PORTVERSION= 0.5.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gdmap
+
+MAINTAINER= delphus@gmail.com
+COMMENT= Graphical disk map Utility
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gtk20
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= gdmap.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Doesn't build on FreeBSD < 5.x"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,<sys/vfs.h>,<sys/statvfs.h>,'
+ ${WRKSRC}/src/gui_main.c
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/gdmap/distinfo b/sysutils/gdmap/distinfo
new file mode 100644
index 000000000000..bbde12b4c393
--- /dev/null
+++ b/sysutils/gdmap/distinfo
@@ -0,0 +1,2 @@
+MD5 (gdmap-0.5.0.tar.gz) = 3630f8de748c5f3b2f0a957eddfb76a6
+SIZE (gdmap-0.5.0.tar.gz) = 155508
diff --git a/sysutils/gdmap/pkg-descr b/sysutils/gdmap/pkg-descr
new file mode 100644
index 000000000000..89d8fe997cbe
--- /dev/null
+++ b/sysutils/gdmap/pkg-descr
@@ -0,0 +1,12 @@
+GdMap is a tool which allows to visualize disk space.
+Ever wondered why your hard disk is full or what directory and
+files take up most of the space? With GdMap these questions can
+be answered quickly. To display directory structures cushion
+treemaps are used which visualize a complete folder or even the
+whole hard drive with one picture.
+
+Cushion treemaps display directories and files in rectangular areas.
+The larger a file is the larger is the rectangle which represents it.
+All files in one directory are painted within the rectangle of that directory.
+
+WWW: http://gdmap.sourceforge.net/
diff --git a/sysutils/gdmap/pkg-plist b/sysutils/gdmap/pkg-plist
new file mode 100644
index 000000000000..d3ccb3fd8cef
--- /dev/null
+++ b/sysutils/gdmap/pkg-plist
@@ -0,0 +1,6 @@
+bin/gdmap
+share/gnome/applications/gdmap.desktop
+share/gnome/pixmaps/gdmap_icon.png
+share/gnome/gdmap/pixmaps/gdmap_icon.png
+@dirrm share/gnome/gdmap/pixmaps
+@dirrm share/gnome/gdmap