aboutsummaryrefslogtreecommitdiff
path: root/sysutils/geomgui/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-10 22:52:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-10 22:52:51 +0000
commitb849dfb5df921d68c6136da81eba77b540823a67 (patch)
tree712969fd5654b3c8312c422071ff435b97fda3a8 /sysutils/geomgui/Makefile
parent8b338e3c4d5b2542a5c9acbc2201dadc9f19af78 (diff)
Notes
Diffstat (limited to 'sysutils/geomgui/Makefile')
-rw-r--r--sysutils/geomgui/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/sysutils/geomgui/Makefile b/sysutils/geomgui/Makefile
index 1762b1c1db16..8fd80d788a82 100644
--- a/sysutils/geomgui/Makefile
+++ b/sysutils/geomgui/Makefile
@@ -7,24 +7,21 @@ CATEGORIES= sysutils
MASTER_SITES= http://tinkering.hambrew.net/geomgui/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= xride
-USE_BZIP2= yes
MAINTAINER= xride@FreeBSD.org
COMMENT= Viewer for kernel geom layer
-LIB_DEPENDS= gvc:${PORTSDIR}/graphics/graphviz
+LIB_DEPENDS= libgvc.so:${PORTSDIR}/graphics/graphviz
-USE_AUTOTOOLS= libtool
USE_GNOME= gtk20 librsvg2
-USES= iconv pkgconfig
+USES= iconv pkgconfig libtool tar:bzip2
GNU_CONFIGURE= yes
-MAN1= geomgui.1
-PLIST_FILES= bin/geomgui
+PLIST_FILES= bin/geomgui \
+ man/man1/geomgui.1.gz
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/local|${STAGEDIR}${PREFIX}|' \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.mk>