aboutsummaryrefslogtreecommitdiff
path: root/sysutils/geteltorito
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 09:26:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 09:26:09 +0000
commit94352510d71903f7dc7411d795915c81ff9b22fd (patch)
tree6461f096fcc47effb72be1b6ffd57739045d8d17 /sysutils/geteltorito
parentf6daf54c013cbfa34e7e2852979444b410d46db6 (diff)
downloadports-94352510d71903f7dc7411d795915c81ff9b22fd.tar.gz
ports-94352510d71903f7dc7411d795915c81ff9b22fd.zip
Notes
Diffstat (limited to 'sysutils/geteltorito')
-rw-r--r--sysutils/geteltorito/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/sysutils/geteltorito/Makefile b/sysutils/geteltorito/Makefile
index 4d1500799665..f5963e222abb 100644
--- a/sysutils/geteltorito/Makefile
+++ b/sysutils/geteltorito/Makefile
@@ -12,13 +12,18 @@ MAINTAINER= valerio.daelli@gmail.com
COMMENT= El Torito image extractor
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
PLIST_FILES= bin/${PORTNAME}
+SHEBANG_FILES= geteltorito.pl
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${DISTDIR}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>