aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gfslicer/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-10 19:04:28 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-10 19:04:28 +0000
commit0f46ae5a25e7466968fc26e4cc5531ab010b68a3 (patch)
treed306e42beff26f5cf312809172fc0d8ef87b7d3d /sysutils/gfslicer/Makefile
parentff3ad09477d28fad84428fdabde8b612989dc915 (diff)
Notes
Diffstat (limited to 'sysutils/gfslicer/Makefile')
-rw-r--r--sysutils/gfslicer/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/gfslicer/Makefile b/sysutils/gfslicer/Makefile
new file mode 100644
index 000000000000..a4298f9ba7a2
--- /dev/null
+++ b/sysutils/gfslicer/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: gfslicer
+# Date created: Jan 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gfslicer
+PORTVERSION= 1.5.4
+CATEGORIES= sysutils
+MASTER_SITES= http://www.geocities.com/gfslicer/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+MANCOMPRESSED= yes
+MAN1= gfslicer.1
+
+post-extract:
+.for file in install-sh missing mkinstalldirs
+ @${LN} -sf ${LOCALBASE}/share/automake/${file} ${WRKSRC}
+.endfor
+ @${RM} -f ${WRKSRC}/config.cache
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+post-install:
+ @${CP} ${WRKSRC}/${MAN1}.gz ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>