aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gigolo
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-12-06 00:02:45 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-12-06 00:02:45 +0000
commit97b1f0305654f5dc1ee2f94a797451d2195e201e (patch)
tree1da6eae3b574eec7896aa8cc46344fdc4ca152a4 /sysutils/gigolo
parent69ba078f350b3993e43c6a811256892db68957d8 (diff)
downloadports-97b1f0305654f5dc1ee2f94a797451d2195e201e.tar.gz
ports-97b1f0305654f5dc1ee2f94a797451d2195e201e.zip
Notes
Diffstat (limited to 'sysutils/gigolo')
-rw-r--r--sysutils/gigolo/Makefile36
-rw-r--r--sysutils/gigolo/distinfo2
-rw-r--r--sysutils/gigolo/pkg-descr10
-rw-r--r--sysutils/gigolo/pkg-plist44
4 files changed, 92 insertions, 0 deletions
diff --git a/sysutils/gigolo/Makefile b/sysutils/gigolo/Makefile
new file mode 100644
index 000000000000..07ab2215cdac
--- /dev/null
+++ b/sysutils/gigolo/Makefile
@@ -0,0 +1,36 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= gigolo
+PORTVERSION= 0.4.1
+CATEGORIES= sysutils
+MASTER_SITES= http://files.uvena.de/gigolo/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Frontend to easily manage filesystem connections
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
+
+USE_BZIP2= yes
+USE_GNOME= gtk20 gvfs
+USE_XORG= x11
+USE_PYTHON= yes
+USE_GETTEXT= yes
+
+MAN1= gigolo.1
+
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO COPYING
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf configure --mandir=${PREFIX}/man
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf build
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf install
+
+.include <bsd.port.mk>
diff --git a/sysutils/gigolo/distinfo b/sysutils/gigolo/distinfo
new file mode 100644
index 000000000000..a4ba27b8fb74
--- /dev/null
+++ b/sysutils/gigolo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gigolo-0.4.1.tar.bz2) = 82f3b5f0ce3ff19c1facac1c89117d67bdf1d4fac66e42fb7a98a8b0d74a17f9
+SIZE (gigolo-0.4.1.tar.bz2) = 194112
diff --git a/sysutils/gigolo/pkg-descr b/sysutils/gigolo/pkg-descr
new file mode 100644
index 000000000000..02f842493ca9
--- /dev/null
+++ b/sysutils/gigolo/pkg-descr
@@ -0,0 +1,10 @@
+Gigolo is a frontend to easily manage connections to local and
+remote filesystems using GIO/GVfs. It allows you to
+quickly connect/mount a remote filesystem and manage bookmarks of such.
+
+It is part of the Xfce Goodies project and the Subversion respository
+is hosted on the Xfce servers though it does not have any hard
+Xfce dependencies and can be used on other desktop environments as well.
+The only hard dependency is GTK2.
+
+WWW: http://www.uvena.de/gigolo/
diff --git a/sysutils/gigolo/pkg-plist b/sysutils/gigolo/pkg-plist
new file mode 100644
index 000000000000..106950f1c542
--- /dev/null
+++ b/sysutils/gigolo/pkg-plist
@@ -0,0 +1,44 @@
+bin/gigolo
+share/applications/gigolo.desktop
+share/locale/bg/LC_MESSAGES/gigolo.mo
+share/locale/ca/LC_MESSAGES/gigolo.mo
+share/locale/cs/LC_MESSAGES/gigolo.mo
+share/locale/da/LC_MESSAGES/gigolo.mo
+share/locale/de/LC_MESSAGES/gigolo.mo
+share/locale/el/LC_MESSAGES/gigolo.mo
+share/locale/es/LC_MESSAGES/gigolo.mo
+share/locale/eu/LC_MESSAGES/gigolo.mo
+share/locale/fi/LC_MESSAGES/gigolo.mo
+share/locale/fr/LC_MESSAGES/gigolo.mo
+share/locale/gl/LC_MESSAGES/gigolo.mo
+share/locale/hr/LC_MESSAGES/gigolo.mo
+share/locale/hu/LC_MESSAGES/gigolo.mo
+share/locale/id/LC_MESSAGES/gigolo.mo
+share/locale/it/LC_MESSAGES/gigolo.mo
+share/locale/ja/LC_MESSAGES/gigolo.mo
+share/locale/lv/LC_MESSAGES/gigolo.mo
+share/locale/nl/LC_MESSAGES/gigolo.mo
+share/locale/pl/LC_MESSAGES/gigolo.mo
+share/locale/pt/LC_MESSAGES/gigolo.mo
+share/locale/pt_BR/LC_MESSAGES/gigolo.mo
+share/locale/ru/LC_MESSAGES/gigolo.mo
+share/locale/sk/LC_MESSAGES/gigolo.mo
+share/locale/sv/LC_MESSAGES/gigolo.mo
+share/locale/tr/LC_MESSAGES/gigolo.mo
+share/locale/uk/LC_MESSAGES/gigolo.mo
+share/locale/zh_CN/LC_MESSAGES/gigolo.mo
+share/locale/ast/LC_MESSAGES/gigolo.mo
+share/locale/kk/LC_MESSAGES/gigolo.mo
+share/locale/ug/LC_MESSAGES/gigolo.mo
+share/locale/ur/LC_MESSAGES/gigolo.mo
+share/locale/ur_PK/LC_MESSAGES/gigolo.mo
+@dirrmtry share/locale/ur_PK/LC_MESSAGES
+@dirrmtry share/locale/ur_PK
+@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/applications