aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gkrellm-trayicons/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-12 20:36:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-12 20:36:35 +0000
commitadf472aa0e21f907634a23bc8a9d150a7a5341e0 (patch)
treeb40c3d63a1b4cbeaa221f638778430990345bcf1 /sysutils/gkrellm-trayicons/Makefile
parent4413c331041f56fd0fd858da2e2abf376f478cc6 (diff)
Notes
Diffstat (limited to 'sysutils/gkrellm-trayicons/Makefile')
-rw-r--r--sysutils/gkrellm-trayicons/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/gkrellm-trayicons/Makefile b/sysutils/gkrellm-trayicons/Makefile
new file mode 100644
index 000000000000..d8af3dd8e263
--- /dev/null
+++ b/sysutils/gkrellm-trayicons/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gkrellm-trayicons
+# Date created: Wed Jun 23 14:55:49 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trayicons
+PORTVERSION= 1.02
+CATEGORIES= sysutils
+MASTER_SITES= http://depot.fsck.ch/mirror/distfiles/ \
+ http://sweb.cz/tripie/gkrellm/trayicons/dist/
+PKGNAMEPREFIX= gkrellm-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@fsck.ch
+COMMENT= GKrellM2 plugin to display definable icons as notifiers or launchers
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+PLIST_FILES= libexec/gkrellm2/plugins/trayicons.so
+
+ALL_TARGET= trayicons.so
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.so ${PREFIX}/libexec/gkrellm2/plugins/
+
+.include <bsd.port.mk>