aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gkrellmwho
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-13 13:14:29 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-13 13:14:29 +0000
commit6b25727d605d42925e0563597d60b693e02a950c (patch)
tree719433213fe5b606e172c3215bbd367f70fa1657 /sysutils/gkrellmwho
parentdc8e3f8160546d987bb175d8d1d7a5bb214e4e11 (diff)
downloadports-6b25727d605d42925e0563597d60b693e02a950c.tar.gz
ports-6b25727d605d42925e0563597d60b693e02a950c.zip
Notes
Diffstat (limited to 'sysutils/gkrellmwho')
-rw-r--r--sysutils/gkrellmwho/Makefile29
-rw-r--r--sysutils/gkrellmwho/distinfo1
-rw-r--r--sysutils/gkrellmwho/files/patch-Makefile19
-rw-r--r--sysutils/gkrellmwho/files/patch-gkrellmwho.c14
-rw-r--r--sysutils/gkrellmwho/pkg-comment1
-rw-r--r--sysutils/gkrellmwho/pkg-descr8
-rw-r--r--sysutils/gkrellmwho/pkg-plist2
7 files changed, 74 insertions, 0 deletions
diff --git a/sysutils/gkrellmwho/Makefile b/sysutils/gkrellmwho/Makefile
new file mode 100644
index 000000000000..68a242ebad32
--- /dev/null
+++ b/sysutils/gkrellmwho/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gkrellmwho
+# Date Created: 11.August 2002
+# Whom: Steffen Vogelreuter
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellmwho
+PORTVERSION= 0.4
+CATEGORIES= sysutils
+MASTER_SITES= http://web.wt.net/~billw/gkrellm/Plugins/
+
+MAINTAINER= steffen@vogelreuter.de
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_IMLIB= yes
+USE_GMAKE= yes
+ALL_TARGET= #empty
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/gkrellmwho.so \
+ ${PREFIX}/libexec/gkrellm/plugins
+
+.include <bsd.port.mk>
diff --git a/sysutils/gkrellmwho/distinfo b/sysutils/gkrellmwho/distinfo
new file mode 100644
index 000000000000..2828c1b75b94
--- /dev/null
+++ b/sysutils/gkrellmwho/distinfo
@@ -0,0 +1 @@
+MD5 (gkrellmwho-0.4.tar.gz) = f12870678fb901208c0f8102840c35fd
diff --git a/sysutils/gkrellmwho/files/patch-Makefile b/sysutils/gkrellmwho/files/patch-Makefile
new file mode 100644
index 000000000000..32171230bb7b
--- /dev/null
+++ b/sysutils/gkrellmwho/files/patch-Makefile
@@ -0,0 +1,19 @@
+
+$FreeBSD$
+
+--- Makefile.orig Thu Aug 2 05:39:29 2001
++++ Makefile Tue Aug 13 15:05:36 2002
+@@ -1,9 +1,9 @@
+ # Modify INCLUDE to point to gkrellm.h (if it's not in /usr/local/include)
+-INCLUDE = /usr/local/include
++INCLUDE = ${X11BASE}/include/gkrellm
+
+-CC = gcc
+-CFLAGS = -Wall -O2 -fPIC -I$(INCLUDE) \
+- `gtk-config --cflags` `imlib-config --cflags-gdk`
++#CC = gcc
++CFLAGS+= -fPIC -I$(INCLUDE) \
++ `gtk12-config --cflags` `imlib-config --cflags-gdk`
+ LDFLAGS =
+ TARGET = gkrellmwho
+
diff --git a/sysutils/gkrellmwho/files/patch-gkrellmwho.c b/sysutils/gkrellmwho/files/patch-gkrellmwho.c
new file mode 100644
index 000000000000..36447dbc1094
--- /dev/null
+++ b/sysutils/gkrellmwho/files/patch-gkrellmwho.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- gkrellmwho.c.orig Thu Aug 2 05:42:49 2001
++++ gkrellmwho.c Tue Aug 13 15:04:21 2002
+@@ -65,7 +65,7 @@
+
+ #define MAX_USERS 10 /* set this statically to avoid realloc() */
+ #define USERS_LEN MAX_USERS*MAX_USER_LEN + 1
+-#define COMMAND "w -hs | sort | grep -v $LOGNAME"
++#define COMMAND "w -h | sort | grep -v $LOGNAME"
+ #define DEF_NONE_MSG "no users"
+ static gchar users[USERS_LEN]; // list of users
+ static int users_xoff; // length of users string in pixels
diff --git a/sysutils/gkrellmwho/pkg-comment b/sysutils/gkrellmwho/pkg-comment
new file mode 100644
index 000000000000..d6081ce8dbc6
--- /dev/null
+++ b/sysutils/gkrellmwho/pkg-comment
@@ -0,0 +1 @@
+A plugin that scrolls in a panel a list of currently logged on users
diff --git a/sysutils/gkrellmwho/pkg-descr b/sysutils/gkrellmwho/pkg-descr
new file mode 100644
index 000000000000..b4d0dbe17f92
--- /dev/null
+++ b/sysutils/gkrellmwho/pkg-descr
@@ -0,0 +1,8 @@
+A GKrellm-Plugin that horizontally scrolls in a panel a list of currently
+logged on users (excluding the invoking user).
+
+Author: Ernesto Novillo <ernie@cs.ualberta.ca>
+WWW: http://www.cs.ualberta.ca/~ernie
+
+-- Steffen Vogelreuter
+steffen@vogelreuter.de
diff --git a/sysutils/gkrellmwho/pkg-plist b/sysutils/gkrellmwho/pkg-plist
new file mode 100644
index 000000000000..225ac34e250d
--- /dev/null
+++ b/sysutils/gkrellmwho/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+libexec/gkrellm/plugins/gkrellmwho.so