aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /sysutils/gnome-control-center/Makefile
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Notes
Notes: svn path=/head/; revision=160863
Diffstat (limited to 'sysutils/gnome-control-center/Makefile')
-rw-r--r--sysutils/gnome-control-center/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index 94b63a0febd0..10adbe119774 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -3,15 +3,15 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnomecontrolcenter2/Makefile,v 1.85 2005/10/03 15:29:07 ahze Exp $
+# $MCom: ports/sysutils/gnomecontrolcenter2/Makefile,v 1.109 2006/04/18 02:28:56 marcus Exp $
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.12.3
-PORTREVISION= 1
+PORTVERSION= 2.14.1
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.12
+MASTER_SITE_SUBDIR= sources/control-center/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,16 +21,20 @@ COMMENT= Control center for GNOME 2 project
LIB_DEPENDS= xklavier.10:${PORTSDIR}/x11/libxklavier
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GSTREAMER= yes
+USE_GSTREAMER= good
WANT_GNOME= yes
USE_GNOME= gnomeprefix gnomehack intlhack metacity nautilus2 \
- gnomemenus desktopfileutils
+ gnomemenus desktopfileutils nautilus2
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-gstreamer=0.10 \
+ --disable-hal
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
@@ -48,10 +52,6 @@ WITH_GNOME= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on 4.X
-.endif
-
.if ${HAVE_GNOME:Mevolutiondataserver}!=""
USE_GNOME+= evolutiondataserver
CONFIGURE_ARGS+=--enable-aboutme
@@ -64,8 +64,6 @@ PLIST_SUB+= ABOUTME="@comment "
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|[{]prefix[}]/share/pixmaps|{datadir}/pixmaps|g'
- @${REINPLACE_CMD} -e 's|mozilla-thunderbird|thunderbird|g' \
- ${WRKSRC}/capplets/default-applications/gnome-default-applications-properties-structs.c
@${REINPLACE_CMD} -e 's|/bin/tar|/usr/bin/tar|g ; \
s|/bin/gzip|/usr/bin/gzip|g' \
${WRKSRC}/capplets/theme-switcher/gnome-theme-installer.c