aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /sysutils/gnome-control-center/Makefile
parent27d17afba2c21f490ea8472d7aa37495e02e3ed8 (diff)
downloadports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.tar.gz
ports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.zip
Notes
Diffstat (limited to 'sysutils/gnome-control-center/Makefile')
-rw-r--r--sysutils/gnome-control-center/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index a740f6b1916c..5af729474976 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -6,25 +6,29 @@
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.2.2
+PORTVERSION= 2.4.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.2
+MASTER_SITE_SUBDIR= sources/control-center/2.4
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Control center for GNOME 2.0 project
+COMMENT= Control center for GNOME 2 project
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack gnomehier gnomedesktop metacity
-USE_LIBTOOL= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier metacity nautilus2
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[{]prefix[}]/share/pixmaps|{datadir}/pixmaps|g'
.include <bsd.port.mk>