aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center1/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:17:03 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:17:03 +0000
commit1a811e09896f1d6f3d4eeeec42326d7155b35cb5 (patch)
treea38dd93b46e44e92f2b7514aac6e866c06534a89 /sysutils/gnome-control-center1/Makefile
parent1e22de094022b9b6c70098694edb2a3f4ba01e8b (diff)
downloadports-1a811e09896f1d6f3d4eeeec42326d7155b35cb5.tar.gz
ports-1a811e09896f1d6f3d4eeeec42326d7155b35cb5.zip
Notes
Diffstat (limited to 'sysutils/gnome-control-center1/Makefile')
-rw-r--r--sysutils/gnome-control-center1/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/sysutils/gnome-control-center1/Makefile b/sysutils/gnome-control-center1/Makefile
index b436bf414a24..bad62d52c0f6 100644
--- a/sysutils/gnome-control-center1/Makefile
+++ b/sysutils/gnome-control-center1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomecontrolcenter
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/control-center
@@ -14,7 +14,8 @@ DISTNAME= control-center-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
@@ -23,10 +24,16 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-gnome=${PREFIX}
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>