aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-mount
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /sysutils/gnome-mount
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
Notes
Diffstat (limited to 'sysutils/gnome-mount')
-rw-r--r--sysutils/gnome-mount/Makefile33
-rw-r--r--sysutils/gnome-mount/distinfo3
-rw-r--r--sysutils/gnome-mount/files/mntent.h56
-rw-r--r--sysutils/gnome-mount/files/patch-src_gnome-mount.c29
-rw-r--r--sysutils/gnome-mount/pkg-descr2
-rw-r--r--sysutils/gnome-mount/pkg-plist12
6 files changed, 135 insertions, 0 deletions
diff --git a/sysutils/gnome-mount/Makefile b/sysutils/gnome-mount/Makefile
new file mode 100644
index 000000000000..f4232382adc8
--- /dev/null
+++ b/sysutils/gnome-mount/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gnome-mount
+# Date created: 04 June 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/gnome-mount/Makefile,v 1.4 2006/10/05 07:37:38 mezz Exp $
+#
+
+PORTNAME= gnome-mount
+PORTVERSION= 0.4
+PORTREVISION= 1
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://people.freedesktop.org/~david/dist/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A font-end to mount, umount, and eject using HAL
+
+LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal
+
+USE_XLIB= yes
+USE_GNOME= gnomeprefix gnomehack intlhack nautilus2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-nautilus-extension
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gnome-mount.schemas
+
+post-extract:
+ @${CP} -f ${FILESDIR}/mntent.h ${WRKSRC}/src
+
+.include <bsd.port.mk>
diff --git a/sysutils/gnome-mount/distinfo b/sysutils/gnome-mount/distinfo
new file mode 100644
index 000000000000..656c038250f9
--- /dev/null
+++ b/sysutils/gnome-mount/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome-mount-0.4.tar.gz) = 75f260ea6b0ec3c5e0af3c722fbd9568
+SHA256 (gnome-mount-0.4.tar.gz) = fa9456c0cd1adeda962721fed955914bdc23723a403bebf31bd95a1f54211dd8
+SIZE (gnome-mount-0.4.tar.gz) = 364546
diff --git a/sysutils/gnome-mount/files/mntent.h b/sysutils/gnome-mount/files/mntent.h
new file mode 100644
index 000000000000..078b246cd02e
--- /dev/null
+++ b/sysutils/gnome-mount/files/mntent.h
@@ -0,0 +1,56 @@
+/*
+ * mntent
+ * mntent.h - compatability header for FreeBSD
+ *
+ * Copyright (c) 2001 David Rufino <daverufino@btinternet.com>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#if defined(HAVE_MNTENT_H)
+#include <mntent.h>
+#else
+#ifndef _MNTENT_H
+#define _MNTENT_H
+#include <stdio.h>
+
+#define MOUNTED "dummy"
+
+#define MNTTYPE_NFS "nfs"
+
+struct mntent {
+ char *mnt_fsname;
+ char *mnt_dir;
+ char *mnt_type;
+ char *mnt_opts;
+ int mnt_freq;
+ int mnt_passno;
+};
+
+#define setmntent(x,y) ((FILE *)0x1)
+struct mntent *getmntent __P ((FILE *fp));
+char *hasmntopt __P ((const struct mntent *mnt, const char *option));
+#define endmntent(x) ((int)1)
+
+#endif /* _MNTENT_H */
+#endif /* HAVE_MNTENT_H */
diff --git a/sysutils/gnome-mount/files/patch-src_gnome-mount.c b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
new file mode 100644
index 000000000000..eb78bab377f5
--- /dev/null
+++ b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
@@ -0,0 +1,29 @@
+--- src/gnome-mount.c.orig Mon Sep 4 21:41:09 2006
++++ src/gnome-mount.c Mon Sep 4 21:45:53 2006
+@@ -42,7 +42,7 @@
+ #include <libhal.h>
+ #include <libhal-storage.h>
+
+-#include <mntent.h>
++#include "mntent.h"
+
+ static DBusConnection *dbus_connection;
+ static LibHalContext *hal_ctx;
+@@ -477,7 +477,7 @@
+
+ mount_point = NULL;
+ device_file = get_dev_file (volume, drive);
+-
++#ifdef __linux__
+ if (device_file != NULL) {
+ FILE *f;
+ struct mntent mnt;
+@@ -497,7 +497,7 @@
+ endmntent (f);
+ }
+ }
+-
++#endif
+ g_print (_("Mounted %s at \"%s\"\n"), device_file, mount_point);
+ g_free (mount_point);
+ }
diff --git a/sysutils/gnome-mount/pkg-descr b/sysutils/gnome-mount/pkg-descr
new file mode 100644
index 000000000000..a75d36294fe4
--- /dev/null
+++ b/sysutils/gnome-mount/pkg-descr
@@ -0,0 +1,2 @@
+gnome-mount is a HAL-based front-end to mount, umount, and eject which
+offers a centralized place where settings for these commands are maintained.
diff --git a/sysutils/gnome-mount/pkg-plist b/sysutils/gnome-mount/pkg-plist
new file mode 100644
index 000000000000..0ae3f4092a0a
--- /dev/null
+++ b/sysutils/gnome-mount/pkg-plist
@@ -0,0 +1,12 @@
+bin/gnome-eject
+bin/gnome-mount
+bin/gnome-umount
+lib/nautilus/extensions-1.0/libgnome-mount.a
+lib/nautilus/extensions-1.0/libgnome-mount.la
+lib/nautilus/extensions-1.0/libgnome-mount.so
+libdata/pkgconfig/gnome-mount.pc
+share/gnome/gnome-mount/gnome-mount-properties.glade
+share/locale/it/LC_MESSAGES/gnome-mount.mo
+share/locale/ja/LC_MESSAGES/gnome-mount.mo
+share/locale/nb/LC_MESSAGES/gnome-mount.mo
+@dirrm share/gnome/gnome-mount