aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-mount
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /sysutils/gnome-mount
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'sysutils/gnome-mount')
-rw-r--r--sysutils/gnome-mount/Makefile8
-rw-r--r--sysutils/gnome-mount/files/patch-src_gnome-mount.c21
2 files changed, 25 insertions, 4 deletions
diff --git a/sysutils/gnome-mount/Makefile b/sysutils/gnome-mount/Makefile
index 2ac81de1a8bc..603aeaf248c0 100644
--- a/sysutils/gnome-mount/Makefile
+++ b/sysutils/gnome-mount/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-mount/Makefile,v 1.24 2008/02/04 23:18:46 mezz Exp $
+# $MCom: ports/sysutils/gnome-mount/Makefile,v 1.28 2011/03/08 19:25:20 kwm Exp $
#
PORTNAME= gnome-mount
PORTVERSION= 0.8
-PORTREVISION= 7
+PORTREVISION= 9
CATEGORIES= sysutils gnome
MASTER_SITES= http://hal.freedesktop.org/releases/
@@ -16,8 +16,8 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A front-end to mount, umount, and eject using HAL
LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal \
- notify.1:${PORTSDIR}/devel/libnotify \
- gnome-keyring:${PORTSDIR}/security/gnome-keyring
+ notify.4:${PORTSDIR}/devel/libnotify \
+ gnome-keyring:${PORTSDIR}/security/libgnome-keyring
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/polkit-gnome.pc:${PORTSDIR}/sysutils/policykit-gnome
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gtk20
diff --git a/sysutils/gnome-mount/files/patch-src_gnome-mount.c b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
new file mode 100644
index 000000000000..fb1a6719263d
--- /dev/null
+++ b/sysutils/gnome-mount/files/patch-src_gnome-mount.c
@@ -0,0 +1,21 @@
+--- src/gnome-mount.c.orig 2010-12-26 14:53:42.000000000 +0100
++++ src/gnome-mount.c 2010-12-26 18:19:30.000000000 +0100
+@@ -38,7 +38,7 @@
+
+ #include <glib/gi18n.h>
+ #include <gconf/gconf-client.h>
+-#include <gdk/gdkx.h>
++#include <gtk/gtk.h>
+ #include "copy-paste/gnome-password-dialog.h"
+ #include <gnome-keyring.h>
+ #include <libnotify/notify.h>
+@@ -1577,8 +1577,7 @@
+ message = g_strdup_printf (_("There is data that needs to be written to the device %s before it can be removed. Please do not remove the media or disconnect the drive."), unmount_note_drive_name);
+ unmount_note = notify_notification_new (summary,
+ message,
+- "gnome-dev-harddisk", /* TODO: use appropriate icon */
+- NULL);
++ "gnome-dev-harddisk");
+ if (unmount_note == NULL) {
+ g_warning ("Cannot create note for unmount cache sync");
+ } else {