aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-pkgview/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-04-03 23:51:33 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-04-03 23:51:33 +0000
commit2e390b6f4fa463a8353378495eb54c6322aa3192 (patch)
treee3b233aa492736c31faa5b80fcb15630e7b9c1ad /sysutils/gnome-pkgview/Makefile
parent7fb02623a911ae28c87b63230bdec0f60b741b2f (diff)
downloadports-2e390b6f4fa463a8353378495eb54c6322aa3192.tar.gz
ports-2e390b6f4fa463a8353378495eb54c6322aa3192.zip
Notes
Diffstat (limited to 'sysutils/gnome-pkgview/Makefile')
-rw-r--r--sysutils/gnome-pkgview/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/sysutils/gnome-pkgview/Makefile b/sysutils/gnome-pkgview/Makefile
index ecefbfdebfa6..c3312f9948d8 100644
--- a/sysutils/gnome-pkgview/Makefile
+++ b/sysutils/gnome-pkgview/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= gnome-pkgview
-PORTVERSION= 1.0.4
-PORTREVISION= 5
+PORTVERSION= 1.0.6
CATEGORIES= sysutils gnome
MASTER_SITES= http://www.greatnorthern.demon.co.uk/packages/gnome-pkgview/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Displays the version of GNOME components installed
-USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeui intlhack
+USE_GETTEXT= yes
+USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -28,5 +27,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/config-path.c
+ @${REINPLACE_CMD} -e 's|Icon=|Icon=${PREFIX}/share/gnome/pixmaps/|g' \
+ ${WRKSRC}/gnome-pkgview.desktop.in
.include <bsd.port.mk>