aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-power-manager/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /sysutils/gnome-power-manager/Makefile
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'sysutils/gnome-power-manager/Makefile')
-rw-r--r--sysutils/gnome-power-manager/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/gnome-power-manager/Makefile b/sysutils/gnome-power-manager/Makefile
new file mode 100644
index 000000000000..6f9106ffdfee
--- /dev/null
+++ b/sysutils/gnome-power-manager/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gnome-power-manager
+# Date created: 03 May 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/gnome-power-manager/Makefile,v 1.13 2006/09/29 23:25:32 marcus Exp $
+#
+
+PORTNAME= gnome-power-manager
+PORTVERSION= 2.16.1
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Power management system for the GNOME Desktop
+
+LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal \
+ notify.2:${PORTSDIR}/devel/libnotify
+
+USE_GETTEXT= yes
+USE_BZIP2= yes
+USE_XLIB= yes
+USE_GMAKE= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libwnck \
+ gnomedocutils
+CONFIGURE_ARGS= --disable-icon-framing
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gnome-power-manager.schemas
+
+.include <bsd.port.mk>