aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-power-manager
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /sysutils/gnome-power-manager
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'sysutils/gnome-power-manager')
-rw-r--r--sysutils/gnome-power-manager/Makefile7
-rw-r--r--sysutils/gnome-power-manager/files/patch-src_gpm-manager.c15
2 files changed, 20 insertions, 2 deletions
diff --git a/sysutils/gnome-power-manager/Makefile b/sysutils/gnome-power-manager/Makefile
index fd13bee4c29f..093254d5f728 100644
--- a/sysutils/gnome-power-manager/Makefile
+++ b/sysutils/gnome-power-manager/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-power-manager/Makefile,v 1.69 2010/09/27 18:49:22 kwm Exp $
+# $MCom: ports/sysutils/gnome-power-manager/Makefile,v 1.73 2011/04/30 20:43:26 mezz Exp $
#
PORTNAME= gnome-power-manager
PORTVERSION= 2.32.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,11 +18,13 @@ COMMENT= Power management system for the GNOME Desktop
LIB_DEPENDS= upower-glib.1:${PORTSDIR}/sysutils/upower \
canberra-gtk.0:${PORTSDIR}/audio/libcanberra \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
execinfo:${PORTSDIR}/devel/libexecinfo \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
RUN_DEPENDS= pkexec:${PORTSDIR}/sysutils/polkit
+CONFLICTS= gnome-power-manager-3.[0-9]*
+
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c b/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c
new file mode 100644
index 000000000000..a71c447da691
--- /dev/null
+++ b/sysutils/gnome-power-manager/files/patch-src_gpm-manager.c
@@ -0,0 +1,15 @@
+--- src/gpm-manager.c.orig 2011-03-07 12:49:54.000000000 +0100
++++ src/gpm-manager.c 2011-03-07 12:51:08.000000000 +0100
+@@ -481,11 +481,7 @@ gpm_manager_notify (GpmManager *manager,
+ gpm_manager_notify_close (manager, *notification_class);
+
+ /* if the status icon is hidden, don't point at it */
+- if (manager->priv->status_icon != NULL &&
+- gtk_status_icon_is_embedded (manager->priv->status_icon))
+- notification = notify_notification_new_with_status_icon (title, message, icon, manager->priv->status_icon);
+- else
+- notification = notify_notification_new (title, message, icon, NULL);
++ notification = notify_notification_new (title, message, icon);
+ notify_notification_set_timeout (notification, timeout);
+ notify_notification_set_urgency (notification, urgency);
+ g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);