aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-schedule
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-11-08 03:48:48 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-11-08 03:48:48 +0000
commit85ba138c8be0d5225e1193f53d8347ca0e647f17 (patch)
tree85a606f50755924e8b66b047bcba74d99ad83b63 /sysutils/gnome-schedule
parentffa392e695e8b97dd65c245c7f4e67f990679e54 (diff)
downloadports-85ba138c8be0d5225e1193f53d8347ca0e647f17.tar.gz
ports-85ba138c8be0d5225e1193f53d8347ca0e647f17.zip
Notes
Diffstat (limited to 'sysutils/gnome-schedule')
-rw-r--r--sysutils/gnome-schedule/Makefile46
-rw-r--r--sysutils/gnome-schedule/distinfo2
-rw-r--r--sysutils/gnome-schedule/pkg-descr3
-rw-r--r--sysutils/gnome-schedule/pkg-plist50
4 files changed, 101 insertions, 0 deletions
diff --git a/sysutils/gnome-schedule/Makefile b/sysutils/gnome-schedule/Makefile
new file mode 100644
index 000000000000..8bf97a9fe8f3
--- /dev/null
+++ b/sysutils/gnome-schedule/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gnome-schedule
+# Date created: 2004-11-06
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-schedule
+PORTVERSION= 0.1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME GUI for configuring a users crontab
+
+USE_PYTHON= yes
+USE_GNOME= gnomeprefix pygnome2
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+DATADIR= ${PREFIX}/share/gnome
+
+PORTDOCS= addingandediting.html index.html
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if defined(NOPORTDOCS)
+.for f in ${PORTDOCS}
+ @${REINPLACE_CMD} -e 's|${f}||' ${WRKSRC}/doc/Makefile.in
+.endfor
+.else
+ @${REINPLACE_CMD} -e 's|gnome-schedule-$$(VERSION)|gnome-schedule|' \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+ @${REINPLACE_CMD} -e 's|/usr/share/icons|${X11BASE}/share/icons|; \
+ s|@prefix@/share|${DATADIR}|; \
+ s|/usr/local/share/|${DATADIR}|; \
+ s|/usr/share/|${DATADIR}|; \
+ s|/usr/bin/gnome-help|${X11BASE}/bin/gnome-help|; \
+ s|$$(prefix)/share/|$$(datadir)/|' \
+ ${WRKSRC}/src/*.* ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/pixmaps/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/gnome-schedule/distinfo b/sysutils/gnome-schedule/distinfo
new file mode 100644
index 000000000000..00eb95b67d5f
--- /dev/null
+++ b/sysutils/gnome-schedule/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome-schedule-0.1.0.tar.gz) = e31b82633a2cd2d11906b0f064a82e2e
+SIZE (gnome-schedule-0.1.0.tar.gz) = 320146
diff --git a/sysutils/gnome-schedule/pkg-descr b/sysutils/gnome-schedule/pkg-descr
new file mode 100644
index 000000000000..29813ffba519
--- /dev/null
+++ b/sysutils/gnome-schedule/pkg-descr
@@ -0,0 +1,3 @@
+Gnome GUI for configuring a users crontab for Vixie cron or similar.
+
+WWW: http://gnome-schedule.sourceforge.net/
diff --git a/sysutils/gnome-schedule/pkg-plist b/sysutils/gnome-schedule/pkg-plist
new file mode 100644
index 000000000000..e9a42ebb8902
--- /dev/null
+++ b/sysutils/gnome-schedule/pkg-plist
@@ -0,0 +1,50 @@
+bin/gnome-schedule
+share/gnome/applications/gnome-schedule.desktop
+share/gnome/gnome-schedule/addWindow.py
+share/gnome/gnome-schedule/addWindow.pyc
+share/gnome/gnome-schedule/addWindow.pyo
+share/gnome/gnome-schedule/at.py
+share/gnome/gnome-schedule/at.pyc
+share/gnome/gnome-schedule/at.pyo
+share/gnome/gnome-schedule/atEditor.py
+share/gnome/gnome-schedule/atEditor.pyc
+share/gnome/gnome-schedule/atEditor.pyo
+share/gnome/gnome-schedule/config.py
+share/gnome/gnome-schedule/config.pyc
+share/gnome/gnome-schedule/config.pyo
+share/gnome/gnome-schedule/crontab.py
+share/gnome/gnome-schedule/crontab.pyc
+share/gnome/gnome-schedule/crontab.pyo
+share/gnome/gnome-schedule/crontabEditor.py
+share/gnome/gnome-schedule/crontabEditor.pyc
+share/gnome/gnome-schedule/crontabEditor.pyo
+share/gnome/gnome-schedule/crontabEditorHelper.py
+share/gnome/gnome-schedule/crontabEditorHelper.pyc
+share/gnome/gnome-schedule/crontabEditorHelper.pyo
+share/gnome/gnome-schedule/editor.py
+share/gnome/gnome-schedule/editor.pyc
+share/gnome/gnome-schedule/editor.pyo
+share/gnome/gnome-schedule/gnome-schedule.glade
+share/gnome/gnome-schedule/gnome-schedule.py
+share/gnome/gnome-schedule/gnome-schedule.pyc
+share/gnome/gnome-schedule/gnome-schedule.pyo
+share/gnome/gnome-schedule/lang.py
+share/gnome/gnome-schedule/lang.pyc
+share/gnome/gnome-schedule/lang.pyo
+share/gnome/gnome-schedule/mainWindow.py
+share/gnome/gnome-schedule/mainWindow.pyc
+share/gnome/gnome-schedule/mainWindow.pyo
+share/gnome/gnome-schedule/preset.py
+share/gnome/gnome-schedule/preset.pyc
+share/gnome/gnome-schedule/preset.pyo
+share/gnome/gnome-schedule/schedule.py
+share/gnome/gnome-schedule/schedule.pyc
+share/gnome/gnome-schedule/schedule.pyo
+share/gnome/gnome-schedule/setuserWindow.py
+share/gnome/gnome-schedule/setuserWindow.pyc
+share/gnome/gnome-schedule/setuserWindow.pyo
+share/gnome/gnome-schedule/support.py
+share/gnome/gnome-schedule/support.pyc
+share/gnome/gnome-schedule/support.pyo
+share/gnome/pixmaps/gnome-schedule.png
+@dirrm share/gnome/gnome-schedule