aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-settings-daemon
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /sysutils/gnome-settings-daemon
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'sysutils/gnome-settings-daemon')
-rw-r--r--sysutils/gnome-settings-daemon/Makefile33
-rw-r--r--sysutils/gnome-settings-daemon/distinfo3
-rw-r--r--sysutils/gnome-settings-daemon/files/patch-gsd_typing-break_gsd-typing-break-manager.c10
-rw-r--r--sysutils/gnome-settings-daemon/files/patch-plugins_media-keys_gsd-media-keys-manager.c26
-rw-r--r--sysutils/gnome-settings-daemon/pkg-descr1
-rw-r--r--sysutils/gnome-settings-daemon/pkg-plist187
6 files changed, 260 insertions, 0 deletions
diff --git a/sysutils/gnome-settings-daemon/Makefile b/sysutils/gnome-settings-daemon/Makefile
new file mode 100644
index 000000000000..c1c432debab2
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gnome-settings-daemon
+# Date created: 14 Jan 2008
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/gnome-settings-daemon/Makefile,v 1.16 2008/03/14 06:19:50 mezz Exp $
+#
+
+PORTNAME= gnome-settings-daemon
+PORTVERSION= 2.22.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME 2 settings daemon
+
+USE_XORG= xxf86misc
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop libgnomekbd
+USE_GETTEXT= yes
+USE_GSTREAMER= good
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-gstreamer=0.10
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= apps_gnome_settings_daemon_keybindings.schemas \
+ apps_gnome_settings_daemon_screensaver.schemas \
+ desktop_gnome_font_rendering.schemas \
+ gnome-settings-daemon.schemas
+
+.include <bsd.port.mk>
diff --git a/sysutils/gnome-settings-daemon/distinfo b/sysutils/gnome-settings-daemon/distinfo
new file mode 100644
index 000000000000..677f21c818b0
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome-settings-daemon-2.22.0.tar.bz2) = 5bb2b129342e3149c00892aa18926317
+SHA256 (gnome-settings-daemon-2.22.0.tar.bz2) = 265cc72958fd8ad66f7a7e2f98968bf74018c1391b5d8abb38ea1c6120c6aea5
+SIZE (gnome-settings-daemon-2.22.0.tar.bz2) = 1192937
diff --git a/sysutils/gnome-settings-daemon/files/patch-gsd_typing-break_gsd-typing-break-manager.c b/sysutils/gnome-settings-daemon/files/patch-gsd_typing-break_gsd-typing-break-manager.c
new file mode 100644
index 000000000000..6fce0da1831a
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/files/patch-gsd_typing-break_gsd-typing-break-manager.c
@@ -0,0 +1,10 @@
+--- plugins/typing-break/gsd-typing-break-manager.c.orig 2008-01-14 01:20:09.000000000 +0100
++++ plugins/typing-break/gsd-typing-break-manager.c 2008-01-14 01:20:37.000000000 +0100
+@@ -27,6 +27,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/signal.h>
+
+ #include <locale.h>
+
diff --git a/sysutils/gnome-settings-daemon/files/patch-plugins_media-keys_gsd-media-keys-manager.c b/sysutils/gnome-settings-daemon/files/patch-plugins_media-keys_gsd-media-keys-manager.c
new file mode 100644
index 000000000000..1db1bb16efe8
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/files/patch-plugins_media-keys_gsd-media-keys-manager.c
@@ -0,0 +1,26 @@
+--- plugins/media-keys/gsd-media-keys-manager.c.orig 2008-01-29 15:58:30.000000000 -0600
++++ plugins/media-keys/gsd-media-keys-manager.c 2008-01-29 16:00:55.000000000 -0600
+@@ -667,7 +667,11 @@
+ if ((command != NULL) && (strcmp (command, "") != 0)) {
+ execute (manager, command, FALSE, FALSE);
+ } else {
++#if __FreeBSD__
++ execute (manager, "cdcontrol eject", FALSE, FALSE);
++#else
+ execute (manager, "eject -T", FALSE, FALSE);
++#endif
+ }
+
+ g_free (command);
+@@ -869,7 +873,11 @@
+ do_mail_action (manager);
+ break;
+ case SLEEP_KEY:
++#if __FreeBSD__
++ do_sleep_action ("zzz", "xset dpms force off");
++#else
+ do_sleep_action ("apm", "xset dpms force off");
++#endif
+ break;
+ case SCREENSAVER_KEY:
+ if ((cmd = g_find_program_in_path ("gnome-screensaver-command"))) {
diff --git a/sysutils/gnome-settings-daemon/pkg-descr b/sysutils/gnome-settings-daemon/pkg-descr
new file mode 100644
index 000000000000..42b586789ffe
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/pkg-descr
@@ -0,0 +1 @@
+GNOME 2 settings daemon.
diff --git a/sysutils/gnome-settings-daemon/pkg-plist b/sysutils/gnome-settings-daemon/pkg-plist
new file mode 100644
index 000000000000..5b7ee38e5a94
--- /dev/null
+++ b/sysutils/gnome-settings-daemon/pkg-plist
@@ -0,0 +1,187 @@
+include/gnome-settings-daemon-2.0/gnome-settings-daemon/gnome-settings-client.h
+lib/gnome-settings-daemon-2.0/a11y-keyboard.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/background.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/clipboard.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/dummy.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/font.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/keybindings.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/keyboard.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/liba11y-keyboard.a
+lib/gnome-settings-daemon-2.0/liba11y-keyboard.la
+lib/gnome-settings-daemon-2.0/liba11y-keyboard.so
+lib/gnome-settings-daemon-2.0/libbackground.a
+lib/gnome-settings-daemon-2.0/libbackground.la
+lib/gnome-settings-daemon-2.0/libbackground.so
+lib/gnome-settings-daemon-2.0/libclipboard.a
+lib/gnome-settings-daemon-2.0/libclipboard.la
+lib/gnome-settings-daemon-2.0/libclipboard.so
+lib/gnome-settings-daemon-2.0/libdummy.a
+lib/gnome-settings-daemon-2.0/libdummy.la
+lib/gnome-settings-daemon-2.0/libdummy.so
+lib/gnome-settings-daemon-2.0/libfont.a
+lib/gnome-settings-daemon-2.0/libfont.la
+lib/gnome-settings-daemon-2.0/libfont.so
+lib/gnome-settings-daemon-2.0/libkeybindings.a
+lib/gnome-settings-daemon-2.0/libkeybindings.la
+lib/gnome-settings-daemon-2.0/libkeybindings.so
+lib/gnome-settings-daemon-2.0/libkeyboard.a
+lib/gnome-settings-daemon-2.0/libkeyboard.la
+lib/gnome-settings-daemon-2.0/libkeyboard.so
+lib/gnome-settings-daemon-2.0/libmedia-keys.a
+lib/gnome-settings-daemon-2.0/libmedia-keys.la
+lib/gnome-settings-daemon-2.0/libmedia-keys.so
+lib/gnome-settings-daemon-2.0/libmouse.a
+lib/gnome-settings-daemon-2.0/libmouse.la
+lib/gnome-settings-daemon-2.0/libmouse.so
+lib/gnome-settings-daemon-2.0/libscreensaver.a
+lib/gnome-settings-daemon-2.0/libscreensaver.la
+lib/gnome-settings-daemon-2.0/libscreensaver.so
+lib/gnome-settings-daemon-2.0/libsound.a
+lib/gnome-settings-daemon-2.0/libsound.la
+lib/gnome-settings-daemon-2.0/libsound.so
+lib/gnome-settings-daemon-2.0/libtyping-break.a
+lib/gnome-settings-daemon-2.0/libtyping-break.la
+lib/gnome-settings-daemon-2.0/libtyping-break.so
+lib/gnome-settings-daemon-2.0/libxrandr.a
+lib/gnome-settings-daemon-2.0/libxrandr.la
+lib/gnome-settings-daemon-2.0/libxrandr.so
+lib/gnome-settings-daemon-2.0/libxrdb.a
+lib/gnome-settings-daemon-2.0/libxrdb.la
+lib/gnome-settings-daemon-2.0/libxrdb.so
+lib/gnome-settings-daemon-2.0/libxsettings.a
+lib/gnome-settings-daemon-2.0/libxsettings.la
+lib/gnome-settings-daemon-2.0/libxsettings.so
+lib/gnome-settings-daemon-2.0/media-keys.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/mouse.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/screensaver.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/sound.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/typing-break.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/xrandr.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/xrdb.gnome-settings-plugin
+lib/gnome-settings-daemon-2.0/xsettings.gnome-settings-plugin
+libdata/pkgconfig/gnome-settings-daemon.pc
+libexec/gnome-settings-daemon
+share/dbus-1/services/org.gnome.SettingsDaemon.service
+%%DATADIR%%/acme-eject.png
+%%DATADIR%%/acme.glade
+%%DATADIR%%/modmap-dialog.glade
+%%DATADIR%%/xrdb/Editres.ad
+%%DATADIR%%/xrdb/Emacs.ad
+%%DATADIR%%/xrdb/General.ad
+%%DATADIR%%/xrdb/Motif.ad
+%%DATADIR%%/xrdb/Tk.ad
+%%DATADIR%%/xrdb/Xaw.ad
+share/locale/af/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/am/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ar/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/az/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/be/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/be@latin/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/bg/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/bn/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/bn_IN/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/br/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/bs/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ca/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/cs/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/cy/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/da/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/de/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/dz/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/el/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/en_CA/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/en_GB/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/es/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/et/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/eu/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/fa/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/fi/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/fr/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ga/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/gl/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/gu/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/he/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/hi/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/hr/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/hu/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/id/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/is/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/it/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ja/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ka/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ko/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ku/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/lt/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/lv/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/mg/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/mk/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ml/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/mn/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/mr/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ms/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/nb/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ne/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/nl/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/nn/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/nso/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/oc/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/or/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/pa/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/pl/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/pt/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ro/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ru/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/rw/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/si/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/sk/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/sl/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/sq/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/sr/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/sr@Latn/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/sv/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/ta/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/te/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/th/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/tr/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/uk/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/vi/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/wa/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/xh/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-settings-daemon.mo
+share/locale/zu/LC_MESSAGES/gnome-settings-daemon.mo
+@dirrm %%DATADIR%%/xrdb
+@dirrm %%DATADIR%%
+@dirrm lib/gnome-settings-daemon-2.0
+@dirrm include/gnome-settings-daemon-2.0/gnome-settings-daemon
+@dirrm include/gnome-settings-daemon-2.0
+@dirrmtry share/locale/zu/LC_MESSAGES
+@dirrmtry share/locale/zu
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/nso/LC_MESSAGES
+@dirrmtry share/locale/nso
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin