aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-system-tools
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /sysutils/gnome-system-tools
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'sysutils/gnome-system-tools')
-rw-r--r--sysutils/gnome-system-tools/Makefile22
-rw-r--r--sysutils/gnome-system-tools/distinfo4
-rw-r--r--sysutils/gnome-system-tools/files/patch-backends_replace.pl.in34
-rw-r--r--sysutils/gnome-system-tools/files/patch-backends_service-list.pl.in10
-rw-r--r--sysutils/gnome-system-tools/files/patch-configure6
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c18
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c11
-rw-r--r--sysutils/gnome-system-tools/files/patch-src_network_location.c11
-rw-r--r--sysutils/gnome-system-tools/pkg-plist102
9 files changed, 64 insertions, 154 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index f1ce787bb4c6..1dca8a647c5c 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -6,23 +6,27 @@
#
PORTNAME= gnomesystemtools
-PORTVERSION= 1.0.2
+PORTVERSION= 1.2.0
+PORTREVISION= 2
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-tools/1.0
+MASTER_SITE_SUBDIR= sources/gnome-system-tools/1.2
DISTNAME= gnome-system-tools-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Tools to configure workstations
+BUILD_DEPENDS= ${X11BASE}/share/setup-tool-backends/scripts/xml.pl:${PORTSDIR}/sysutils/system-tools-backends
+RUN_DEPENDS= ${X11BASE}/share/setup-tool-backends/scripts/xml.pl:${PORTSDIR}/sysutils/system-tools-backends
+
USE_BZIP2= yes
USE_GMAKE= yes
-USE_PERL5= yes
USE_X_PREFIX= yes
-INSTALLS_OMF= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui
+GNOME_DESKTOP_VERSION=2
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack nautilus2
USE_LIBTOOL_VER=15
+INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -30,17 +34,11 @@ GCONF_SCHEMAS= gnome-system-tools.schemas
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500000
+.if ${OSVERSION} >= 500000
CONFIGURE_ARGS+= --enable-services
PLIST_SUB+= SERVICES=""
.else
PLIST_SUB+= SERVICES="@comment "
.endif
-.if ${PERL_LEVEL} < 500600
-post-configure:
- @${FIND} ${WRKSRC}/backends \( -name "*.pl" -or -name "*-conf" \) | \
- ${XARGS} ${REINPLACE_CMD} -e 's|@scriptsdir|[@]scriptsdir|g'
-.endif
-
.include <bsd.port.post.mk>
diff --git a/sysutils/gnome-system-tools/distinfo b/sysutils/gnome-system-tools/distinfo
index 6b2fb5abceac..6eb37fa99a84 100644
--- a/sysutils/gnome-system-tools/distinfo
+++ b/sysutils/gnome-system-tools/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-system-tools-1.0.2.tar.bz2) = 674611d3fb195fde940223821cfa6dda
-SIZE (gnome2/gnome-system-tools-1.0.2.tar.bz2) = 2766787
+MD5 (gnome2/gnome-system-tools-1.2.0.tar.bz2) = fbcf8866ecea8b330cbe53cf8b0df55e
+SIZE (gnome2/gnome-system-tools-1.2.0.tar.bz2) = 1780677
diff --git a/sysutils/gnome-system-tools/files/patch-backends_replace.pl.in b/sysutils/gnome-system-tools/files/patch-backends_replace.pl.in
deleted file mode 100644
index 7f7cce28ee37..000000000000
--- a/sysutils/gnome-system-tools/files/patch-backends_replace.pl.in
+++ /dev/null
@@ -1,34 +0,0 @@
---- backends/replace.pl.in.orig Fri Oct 22 02:41:56 2004
-+++ backends/replace.pl.in Fri Oct 22 02:42:48 2004
-@@ -1113,19 +1113,19 @@
-
- return -1 if (!&gst_replace_interfaces_iface_stanza_locate ($buff, \$line_no, $iface));
-
-- delete $$buff[$line_no];
-+ splice @{$buff},$line_no,1;
- $line_no ++;
-
- while (&gst_replace_interfaces_get_next_option ($buff, \$line_no) != -1)
- {
-- delete $$buff[$line_no];
-+ splice @{$buff},$line_no,1;
- $line_no ++;
- }
-
- $line_no = 0;
- if (&gst_replace_interfaces_auto_stanza_locate ($buff, \$line_no, $iface))
- {
-- delete $$buff[$line_no];
-+ splice @{$buff},$line_no,1;
- }
-
- &gst_file_buffer_clean ($buff);
-@@ -1663,7 +1663,7 @@
- }
- else
- {
-- delete $$buff[$i];
-+ splice @{$buff},$i,1;
- }
- }
- }
diff --git a/sysutils/gnome-system-tools/files/patch-backends_service-list.pl.in b/sysutils/gnome-system-tools/files/patch-backends_service-list.pl.in
deleted file mode 100644
index 16861791c1ca..000000000000
--- a/sysutils/gnome-system-tools/files/patch-backends_service-list.pl.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- backends/service-list.pl.in.orig Sun Sep 19 13:20:02 2004
-+++ backends/service-list.pl.in Sun Sep 19 13:20:10 2004
-@@ -225,6 +225,7 @@
- "atm3\.sh",
- "ccd",
- "cleanvar",
-+ "cleartmp",
- "devdb",
- "devfs",
- "dhclient",
diff --git a/sysutils/gnome-system-tools/files/patch-configure b/sysutils/gnome-system-tools/files/patch-configure
index b854cde3a70f..712bb1defc9f 100644
--- a/sysutils/gnome-system-tools/files/patch-configure
+++ b/sysutils/gnome-system-tools/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed May 26 12:02:51 2004
-+++ configure Wed May 26 12:03:23 2004
-@@ -22623,7 +22623,7 @@
+--- configure.orig Thu Jan 13 17:15:39 2005
++++ configure Thu Jan 13 17:17:13 2005
+@@ -22990,7 +22990,7 @@
GST_CFLAGS="$GST_DEPENDS_CFLAGS $GST_CRACK_LIB_CFLAGS $GST_DEPRECATED_FLAGS"
GST_TOOL_LIBS="$GST_LIBS -lutil \$(top_builddir)/src/common/libsetuptool.a"
diff --git a/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c b/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
new file mode 100644
index 000000000000..9272d918136c
--- /dev/null
+++ b/sysutils/gnome-system-tools/files/patch-src_common_gst-auth.c
@@ -0,0 +1,18 @@
+--- src/common/gst-auth.c.orig Thu Mar 10 14:39:18 2005
++++ src/common/gst-auth.c Thu Mar 10 14:39:50 2005
+@@ -142,12 +142,12 @@ gst_auth_run_term (GstTool *tool, gchar
+ unsetenv("LANG");
+ unsetenv("LANGUAGE");
+
+- dup2 (p[1], 1);
+- dup2 (p[1], 2);
++ dup2 (p[1], STDOUT_FILENO);
++ /*dup2 (p[1], 2);*/
+ close (p[0]);
+
+ execv (args[0], args);
+- exit (255);
++ _exit (255);
+ } else {
+ #ifndef __FreeBSD__
+ /* Linux's su works ok with echo disabling */
diff --git a/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c b/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c
new file mode 100644
index 000000000000..5134f30e581b
--- /dev/null
+++ b/sysutils/gnome-system-tools/files/patch-src_common_gst-tool.c
@@ -0,0 +1,11 @@
+--- src/common/gst-tool.c.orig Thu Mar 10 14:39:54 2005
++++ src/common/gst-tool.c Thu Mar 10 14:40:00 2005
+@@ -1653,7 +1653,7 @@ poll_backend (GstTool *tool)
+ struct pollfd fd;
+
+ fd.fd = tool->read_fd;
+- fd.events = POLLIN || POLLPRI;
++ fd.events = POLLIN | POLLPRI;
+
+ while (poll (&fd, 1, 100) <= 0) {
+ while (gtk_events_pending ())
diff --git a/sysutils/gnome-system-tools/files/patch-src_network_location.c b/sysutils/gnome-system-tools/files/patch-src_network_location.c
new file mode 100644
index 000000000000..e2577a6a49e0
--- /dev/null
+++ b/sysutils/gnome-system-tools/files/patch-src_network_location.c
@@ -0,0 +1,11 @@
+--- src/network/location.c.orig Thu Dec 23 13:16:33 2004
++++ src/network/location.c Thu Dec 23 13:16:40 2004
+@@ -687,7 +687,7 @@
+ static void
+ copy_tag_list (xmlNodePtr source, xmlNodePtr dest, const gchar *list[])
+ {
+- gchar **string = (gchar **) list;;
++ gchar **string = (gchar **) list;
+ gchar *value;
+
+ while (*string)
diff --git a/sysutils/gnome-system-tools/pkg-plist b/sysutils/gnome-system-tools/pkg-plist
index 6a980fb7574e..a52125a51fcd 100644
--- a/sysutils/gnome-system-tools/pkg-plist
+++ b/sysutils/gnome-system-tools/pkg-plist
@@ -1,24 +1,23 @@
bin/network-admin
%%SERVICES%%bin/services-admin
+bin/shares-admin
bin/time-admin
bin/users-admin
-etc/X11/sysconfig/network.desktop
-%%SERVICES%%etc/X11/sysconfig/services.desktop
-etc/X11/sysconfig/time.desktop
-etc/X11/sysconfig/users.desktop
+lib/nautilus/extensions-1.0/libnautilus-gst-shares.so
libdata/pkgconfig/gnome-system-tools.pc
-libdata/pkgconfig/system-tools-backends.pc
share/gnome-system-tools/interfaces/boot.glade
share/gnome-system-tools/interfaces/common.glade
share/gnome-system-tools/interfaces/disks.glade
share/gnome-system-tools/interfaces/network.glade
share/gnome-system-tools/interfaces/services.glade
+share/gnome-system-tools/interfaces/shares.glade
share/gnome-system-tools/interfaces/time.glade
share/gnome-system-tools/interfaces/users.glade
share/gnome-system-tools/pixmaps/16_ethernet.xpm
share/gnome-system-tools/pixmaps/16_loopback.xpm
share/gnome-system-tools/pixmaps/16_plip.xpm
share/gnome-system-tools/pixmaps/16_ppp.xpm
+share/gnome-system-tools/pixmaps/archlinux.png
share/gnome-system-tools/pixmaps/black_panther.png
share/gnome-system-tools/pixmaps/boot.png
share/gnome-system-tools/pixmaps/computer.png
@@ -26,6 +25,7 @@ share/gnome-system-tools/pixmaps/conectiva.png
share/gnome-system-tools/pixmaps/connection-ethernet.png
share/gnome-system-tools/pixmaps/connection-modem.png
share/gnome-system-tools/pixmaps/debian.png
+share/gnome-system-tools/pixmaps/disks.png
share/gnome-system-tools/pixmaps/fedora.png
share/gnome-system-tools/pixmaps/freebsd.png
share/gnome-system-tools/pixmaps/gentoo.png
@@ -47,6 +47,7 @@ share/gnome-system-tools/pixmaps/redhat.png
share/gnome-system-tools/pixmaps/server.png
share/gnome-system-tools/pixmaps/services.png
share/gnome-system-tools/pixmaps/settings.png
+share/gnome-system-tools/pixmaps/shares.png
share/gnome-system-tools/pixmaps/slackware.png
share/gnome-system-tools/pixmaps/specifix.png
share/gnome-system-tools/pixmaps/suse.png
@@ -63,6 +64,7 @@ share/gnome-system-tools/pixmaps/wavelan-48.png
share/gnome-system-tools/pixmaps/world_map-960.png
share/gnome/applications/network.desktop
%%SERVICES%%share/gnome/applications/services.desktop
+share/gnome/applications/shares.desktop
share/gnome/applications/time.desktop
share/gnome/applications/users.desktop
share/gnome/help/boot-admin/C/boot-admin.xml
@@ -90,145 +92,59 @@ share/gnome/omf/gnome-system-tools/time-admin-C.omf
share/gnome/omf/gnome-system-tools/users-admin-C.omf
share/locale/am/LC_MESSAGES/gnome-system-tools.mo
share/locale/ar/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ar/LC_MESSAGES/setup-tools-backends.mo
share/locale/az/LC_MESSAGES/gnome-system-tools.mo
-share/locale/az/LC_MESSAGES/setup-tools-backends.mo
share/locale/bg/LC_MESSAGES/gnome-system-tools.mo
-share/locale/bg/LC_MESSAGES/setup-tools-backends.mo
-share/locale/bn/LC_MESSAGES/setup-tools-backends.mo
share/locale/bn/LC_MESSAGES/gnome-system-tools.mo
-share/locale/bs/LC_MESSAGES/setup-tools-backends.mo
share/locale/ca/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ca/LC_MESSAGES/setup-tools-backends.mo
share/locale/cs/LC_MESSAGES/gnome-system-tools.mo
-share/locale/cs/LC_MESSAGES/setup-tools-backends.mo
share/locale/da/LC_MESSAGES/gnome-system-tools.mo
-share/locale/da/LC_MESSAGES/setup-tools-backends.mo
share/locale/de/LC_MESSAGES/gnome-system-tools.mo
-share/locale/de/LC_MESSAGES/setup-tools-backends.mo
share/locale/el/LC_MESSAGES/gnome-system-tools.mo
-share/locale/el/LC_MESSAGES/setup-tools-backends.mo
share/locale/en_CA/LC_MESSAGES/gnome-system-tools.mo
-share/locale/en_CA/LC_MESSAGES/setup-tools-backends.mo
share/locale/en_GB/LC_MESSAGES/gnome-system-tools.mo
-share/locale/en_GB/LC_MESSAGES/setup-tools-backends.mo
share/locale/es/LC_MESSAGES/gnome-system-tools.mo
-share/locale/es/LC_MESSAGES/setup-tools-backends.mo
share/locale/et/LC_MESSAGES/gnome-system-tools.mo
share/locale/eu/LC_MESSAGES/gnome-system-tools.mo
-share/locale/eu/LC_MESSAGES/setup-tools-backends.mo
share/locale/fi/LC_MESSAGES/gnome-system-tools.mo
-share/locale/fi/LC_MESSAGES/setup-tools-backends.mo
share/locale/fr/LC_MESSAGES/gnome-system-tools.mo
-share/locale/fr/LC_MESSAGES/setup-tools-backends.mo
share/locale/ga/LC_MESSAGES/gnome-system-tools.mo
share/locale/gl/LC_MESSAGES/gnome-system-tools.mo
-share/locale/gu/LC_MESSAGES/setup-tools-backends.mo
share/locale/gu/LC_MESSAGES/gnome-system-tools.mo
+share/locale/hi/LC_MESSAGES/gnome-system-tools.mo
share/locale/hr/LC_MESSAGES/gnome-system-tools.mo
-share/locale/hr/LC_MESSAGES/setup-tools-backends.mo
share/locale/hu/LC_MESSAGES/gnome-system-tools.mo
share/locale/id/LC_MESSAGES/gnome-system-tools.mo
-share/locale/id/LC_MESSAGES/setup-tools-backends.mo
share/locale/it/LC_MESSAGES/gnome-system-tools.mo
-share/locale/it/LC_MESSAGES/setup-tools-backends.mo
share/locale/ja/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ja/LC_MESSAGES/setup-tools-backends.mo
share/locale/ko/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ko/LC_MESSAGES/setup-tools-backends.mo
share/locale/lt/LC_MESSAGES/gnome-system-tools.mo
-share/locale/lt/LC_MESSAGES/setup-tools-backends.mo
share/locale/lv/LC_MESSAGES/gnome-system-tools.mo
share/locale/mk/LC_MESSAGES/gnome-system-tools.mo
share/locale/ml/LC_MESSAGES/gnome-system-tools.mo
share/locale/mn/LC_MESSAGES/gnome-system-tools.mo
share/locale/ms/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ms/LC_MESSAGES/setup-tools-backends.mo
-share/locale/nb/LC_MESSAGES/gnome-system-tools.mo
-share/locale/nb/LC_MESSAGES/setup-tools-backends.mo
share/locale/nl/LC_MESSAGES/gnome-system-tools.mo
-share/locale/nl/LC_MESSAGES/setup-tools-backends.mo
share/locale/nn/LC_MESSAGES/gnome-system-tools.mo
share/locale/no/LC_MESSAGES/gnome-system-tools.mo
-share/locale/no/LC_MESSAGES/setup-tools-backends.mo
-share/locale/pa/LC_MESSAGES/setup-tools-backends.mo
share/locale/pa/LC_MESSAGES/gnome-system-tools.mo
share/locale/pl/LC_MESSAGES/gnome-system-tools.mo
-share/locale/pl/LC_MESSAGES/setup-tools-backends.mo
share/locale/pt/LC_MESSAGES/gnome-system-tools.mo
-share/locale/pt/LC_MESSAGES/setup-tools-backends.mo
share/locale/pt_BR/LC_MESSAGES/gnome-system-tools.mo
-share/locale/pt_BR/LC_MESSAGES/setup-tools-backends.mo
share/locale/ro/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ro/LC_MESSAGES/setup-tools-backends.mo
share/locale/ru/LC_MESSAGES/gnome-system-tools.mo
share/locale/sk/LC_MESSAGES/gnome-system-tools.mo
share/locale/sq/LC_MESSAGES/gnome-system-tools.mo
-share/locale/sq/LC_MESSAGES/setup-tools-backends.mo
share/locale/sr/LC_MESSAGES/gnome-system-tools.mo
-share/locale/sr/LC_MESSAGES/setup-tools-backends.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-system-tools.mo
-share/locale/sr@Latn/LC_MESSAGES/setup-tools-backends.mo
share/locale/sv/LC_MESSAGES/gnome-system-tools.mo
-share/locale/sv/LC_MESSAGES/setup-tools-backends.mo
share/locale/ta/LC_MESSAGES/gnome-system-tools.mo
-share/locale/ta/LC_MESSAGES/setup-tools-backends.mo
+share/locale/th/LC_MESSAGES/gnome-system-tools.mo
share/locale/tr/LC_MESSAGES/gnome-system-tools.mo
share/locale/uk/LC_MESSAGES/gnome-system-tools.mo
-share/locale/uk/LC_MESSAGES/setup-tools-backends.mo
share/locale/vi/LC_MESSAGES/gnome-system-tools.mo
share/locale/wa/LC_MESSAGES/gnome-system-tools.mo
share/locale/zh_CN/LC_MESSAGES/gnome-system-tools.mo
-share/locale/zh_CN/LC_MESSAGES/setup-tools-backends.mo
share/locale/zh_TW/LC_MESSAGES/gnome-system-tools.mo
-share/locale/zh_TW/LC_MESSAGES/setup-tools-backends.mo
-share/setup-tool-backends/files/debian_ipchains
-share/setup-tool-backends/scripts/boot-conf
-share/setup-tool-backends/scripts/boot-grub.pl
-share/setup-tool-backends/scripts/boot-lilo.pl
-share/setup-tool-backends/scripts/boot-yaboot.pl
-share/setup-tool-backends/scripts/boot.pl
-share/setup-tool-backends/scripts/debug.pl
-share/setup-tool-backends/scripts/dhcpd-conf
-share/setup-tool-backends/scripts/dhcpd.pl
-share/setup-tool-backends/scripts/disks-conf
-share/setup-tool-backends/scripts/display-conf
-share/setup-tool-backends/scripts/file.pl
-share/setup-tool-backends/scripts/filesys.pl
-share/setup-tool-backends/scripts/font-conf
-share/setup-tool-backends/scripts/font.pl
-share/setup-tool-backends/scripts/general.pl
-share/setup-tool-backends/scripts/guess_system.sh
-share/setup-tool-backends/scripts/internetsharing-conf
-share/setup-tool-backends/scripts/ishare.pl
-share/setup-tool-backends/scripts/media.pl
-share/setup-tool-backends/scripts/memory-conf
-share/setup-tool-backends/scripts/mouse-conf
-share/setup-tool-backends/scripts/network-conf
-share/setup-tool-backends/scripts/network.pl
-share/setup-tool-backends/scripts/package-conf
-share/setup-tool-backends/scripts/parse.pl
-share/setup-tool-backends/scripts/partition.pl
-share/setup-tool-backends/scripts/platform.pl
-share/setup-tool-backends/scripts/print-conf
-share/setup-tool-backends/scripts/print.pl
-share/setup-tool-backends/scripts/replace.pl
-share/setup-tool-backends/scripts/report.pl
-share/setup-tool-backends/scripts/service-list.pl
-share/setup-tool-backends/scripts/service.pl
-share/setup-tool-backends/scripts/services-conf
-share/setup-tool-backends/scripts/share.pl
-share/setup-tool-backends/scripts/shares-conf
-share/setup-tool-backends/scripts/time-conf
-share/setup-tool-backends/scripts/tokenizer.pl
-share/setup-tool-backends/scripts/type1inst
-share/setup-tool-backends/scripts/users-conf
-share/setup-tool-backends/scripts/util.pl
-share/setup-tool-backends/scripts/x.pl
-share/setup-tool-backends/scripts/xml.pl
-@dirrm share/setup-tool-backends/scripts
-@dirrm share/setup-tool-backends/files
-@dirrm share/setup-tool-backends
@dirrm share/gnome/omf/gnome-system-tools
@dirrm share/gnome/help/users-admin/C/figures
@dirrm share/gnome/help/users-admin/C