aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnomesystemmonitor
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /sysutils/gnomesystemmonitor
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
downloadports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.tar.gz
ports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.zip
Notes
Diffstat (limited to 'sysutils/gnomesystemmonitor')
-rw-r--r--sysutils/gnomesystemmonitor/Makefile8
-rw-r--r--sysutils/gnomesystemmonitor/distinfo4
-rw-r--r--sysutils/gnomesystemmonitor/files/patch-src_util.c28
-rw-r--r--sysutils/gnomesystemmonitor/pkg-plist5
4 files changed, 37 insertions, 8 deletions
diff --git a/sysutils/gnomesystemmonitor/Makefile b/sysutils/gnomesystemmonitor/Makefile
index 24082cb98839..ddf03c8cbaf9 100644
--- a/sysutils/gnomesystemmonitor/Makefile
+++ b/sysutils/gnomesystemmonitor/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomesystemmonitor
-PORTVERSION= 2.4.0
-PORTREVISION= 1
+PORTVERSION= 2.6.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-monitor/2.4
+MASTER_SITE_SUBDIR= sources/gnome-system-monitor/2.6
DISTNAME= gnome-system-monitor-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,7 +21,8 @@ LIB_DEPENDS= gtop-2.0.2:${PORTSDIR}/devel/libgtop2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui libwnck
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix intlhack lthack gnomehack libgnomeui libwnck
USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lutil"
diff --git a/sysutils/gnomesystemmonitor/distinfo b/sysutils/gnomesystemmonitor/distinfo
index 7115f703da96..75cc73e5deaa 100644
--- a/sysutils/gnomesystemmonitor/distinfo
+++ b/sysutils/gnomesystemmonitor/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-system-monitor-2.4.0.tar.bz2) = f855d85adcc2eb0f20f639cbc2f00cbf
-SIZE (gnome2/gnome-system-monitor-2.4.0.tar.bz2) = 546873
+MD5 (gnome2/gnome-system-monitor-2.6.0.tar.bz2) = 1bc8709baa43fdca7eee8cad1dc76b17
+SIZE (gnome2/gnome-system-monitor-2.6.0.tar.bz2) = 597694
diff --git a/sysutils/gnomesystemmonitor/files/patch-src_util.c b/sysutils/gnomesystemmonitor/files/patch-src_util.c
index b7e262b0c599..288ccc26adc0 100644
--- a/sysutils/gnomesystemmonitor/files/patch-src_util.c
+++ b/sysutils/gnomesystemmonitor/files/patch-src_util.c
@@ -1,5 +1,5 @@
---- src/util.c.orig Thu May 9 01:16:48 2002
-+++ src/util.c Thu May 9 01:17:13 2002
+--- src/util.c.orig Fri Dec 12 02:26:57 2003
++++ src/util.c Fri Dec 12 02:35:38 2003
@@ -16,6 +16,7 @@
#ifdef __FreeBSD__
@@ -8,3 +8,27 @@
# include <libutil.h>
#endif
+@@ -181,7 +182,11 @@
+ * Make su think we're sending the password from a terminal:
+ */
+
++#ifndef __FreeBSD__
+ if (((t_fd = OPEN_TTY()) < 0) || (grantpt(t_fd) < 0) || (unlockpt(t_fd) < 0)) {
++#else
++ if ((t_fd = OPEN_TTY()) < 0) {
++#endif
+ fprintf (stderr, "Unable to open a terminal\n");
+ ABORT (root);
+ }
+@@ -259,7 +264,11 @@
+ }
+ }
+
++#ifndef __FreeBSD__
+ if(((pts = ptsname(t_fd)) == NULL) || ((t_fd = open(pts, O_RDWR | O_NOCTTY)) < 0)) {
++#else
++ if (((pts = ttyname(t_fd)) == NULL) || ((t_fd = open(pts, O_RDWR | O_NOCTTY)) < 0)) {
++#endif
+ perror ("Unable to open pseudo slave terminal");
+ _exit (-1);
+ }
diff --git a/sysutils/gnomesystemmonitor/pkg-plist b/sysutils/gnomesystemmonitor/pkg-plist
index d035ed3953c7..bf559c2732a3 100644
--- a/sysutils/gnomesystemmonitor/pkg-plist
+++ b/sysutils/gnomesystemmonitor/pkg-plist
@@ -13,6 +13,7 @@ share/gnome/help/gnome-system-monitor/C/figures/addColumn.png
share/gnome/help/gnome-system-monitor/C/figures/changePriority.png
share/gnome/help/gnome-system-monitor/C/figures/colorPanel.png
share/gnome/help/gnome-system-monitor/C/figures/columnContextMenu.png
+share/gnome/help/gnome-system-monitor/C/figures/gnome-system-monitor_window.png
share/gnome/help/gnome-system-monitor/C/figures/memoryMaps.png
share/gnome/help/gnome-system-monitor/C/figures/moreInfo.png
share/gnome/help/gnome-system-monitor/C/figures/processListing.png
@@ -38,6 +39,7 @@ share/locale/cy/LC_MESSAGES/gnome-system-monitor.mo
share/locale/da/LC_MESSAGES/gnome-system-monitor.mo
share/locale/de/LC_MESSAGES/gnome-system-monitor.mo
share/locale/el/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/en_CA/LC_MESSAGES/gnome-system-monitor.mo
share/locale/es/LC_MESSAGES/gnome-system-monitor.mo
share/locale/fa/LC_MESSAGES/gnome-system-monitor.mo
share/locale/fi/LC_MESSAGES/gnome-system-monitor.mo
@@ -46,12 +48,14 @@ share/locale/ga/LC_MESSAGES/gnome-system-monitor.mo
share/locale/gl/LC_MESSAGES/gnome-system-monitor.mo
share/locale/he/LC_MESSAGES/gnome-system-monitor.mo
share/locale/hi/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/hr/LC_MESSAGES/gnome-system-monitor.mo
share/locale/hu/LC_MESSAGES/gnome-system-monitor.mo
share/locale/id/LC_MESSAGES/gnome-system-monitor.mo
share/locale/it/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ja/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ko/LC_MESSAGES/gnome-system-monitor.mo
share/locale/li/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/lt/LC_MESSAGES/gnome-system-monitor.mo
share/locale/lv/LC_MESSAGES/gnome-system-monitor.mo
share/locale/mk/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ml/LC_MESSAGES/gnome-system-monitor.mo
@@ -70,6 +74,7 @@ share/locale/sr/LC_MESSAGES/gnome-system-monitor.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-system-monitor.mo
share/locale/sv/LC_MESSAGES/gnome-system-monitor.mo
share/locale/sq/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/ta/LC_MESSAGES/gnome-system-monitor.mo
share/locale/tr/LC_MESSAGES/gnome-system-monitor.mo
share/locale/uk/LC_MESSAGES/gnome-system-monitor.mo
share/locale/vi/LC_MESSAGES/gnome-system-monitor.mo