aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnomesystemtools
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-21 05:09:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-21 05:09:21 +0000
commitfc69d4c0980aaa62e0b65ef22bf9bdc322c8eea9 (patch)
treee0774dcb7791d9da693cabc8ea0293f1f0605a64 /sysutils/gnomesystemtools
parentfa45acf58dd2001e26c01622701c11313bf1ae91 (diff)
downloadports-fc69d4c0980aaa62e0b65ef22bf9bdc322c8eea9.tar.gz
ports-fc69d4c0980aaa62e0b65ef22bf9bdc322c8eea9.zip
Notes
Diffstat (limited to 'sysutils/gnomesystemtools')
-rw-r--r--sysutils/gnomesystemtools/Makefile1
-rw-r--r--sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c27
2 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/gnomesystemtools/Makefile b/sysutils/gnomesystemtools/Makefile
index 127fd1c3f2c8..69241d508afd 100644
--- a/sysutils/gnomesystemtools/Makefile
+++ b/sysutils/gnomesystemtools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomesystemtools
PORTVERSION= 0.91.0
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-system-tools/0.91
diff --git a/sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c b/sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c
new file mode 100644
index 000000000000..7a5e54ecaaf6
--- /dev/null
+++ b/sysutils/gnomesystemtools/files/patch-src_common_gst-auth.c
@@ -0,0 +1,27 @@
+--- src/common/gst-auth.c.orig Sat Aug 21 01:01:33 2004
++++ src/common/gst-auth.c Sat Aug 21 01:06:24 2004
+@@ -300,6 +300,7 @@
+ lc_all = getenv ("LC_ALL");
+ lang = getenv ("LANG");
+
++#ifndef __FreeBSD__
+ if (lc_all)
+ g_string_append_printf (command, "export LC_ALL=\"%s\" && ", lc_all);
+ else if (lc_messages)
+@@ -308,6 +309,16 @@
+ g_string_append_printf (command, "export LANG=\"%s\" && ", lang);
+ else if (language)
+ g_string_append_printf (command, "export LANGUAGE=\"%s\" && ", language);
++#else
++ if (lc_all)
++ g_string_append_printf (command, "env LC_ALL=\"%s\" ", lc_all);
++ else if (lc_messages)
++ g_string_append_printf (command, "env LC_MESSAGES=\"%s\" ", lc_messages);
++ else if (lang)
++ g_string_append_printf (command, "env LANG=\"%s\" ", lang);
++ else if (language)
++ g_string_append_printf (command, "env LANGUAGE=\"%s\" ", language);
++#endif
+ }
+
+ void