aboutsummaryrefslogtreecommitdiff
path: root/sysutils/graphicboot/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 06:19:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 06:19:38 +0000
commit397d208a6c8895af94e1c810327aaef2533b45cc (patch)
tree180e8ac961cb53591fc02392571dc6340f86be12 /sysutils/graphicboot/Makefile
parentfc665b188411fa01f878128c291693f5c4bedcd5 (diff)
Notes
Diffstat (limited to 'sysutils/graphicboot/Makefile')
-rw-r--r--sysutils/graphicboot/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/graphicboot/Makefile b/sysutils/graphicboot/Makefile
new file mode 100644
index 000000000000..5ee5138a941a
--- /dev/null
+++ b/sysutils/graphicboot/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: graphicboot
+# Date created: 8 July 2005
+# Whom: Matthew Holder <sixxgate@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphicboot
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://matt.sixxgate.com/files/
+
+MAINTAINER= sixxgate@hotmail.com
+COMMENT= Provides graphical X Window startup to FreeBSD during 'rc'
+
+RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage
+
+USE_MOTIF= yes
+USE_BZIP2= yes
+USE_IMAKE= yes
+
+MAN1= graphicboot.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN="The graphical boot requires rcorder which is only on FreeBSD 5 or greater."
+.endif
+
+post-install:
+ ${CAT} pkg-message
+
+.include <bsd.port.post.mk>