aboutsummaryrefslogtreecommitdiff
path: root/sysutils/graphicboot
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 06:19:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 06:19:38 +0000
commit397d208a6c8895af94e1c810327aaef2533b45cc (patch)
tree180e8ac961cb53591fc02392571dc6340f86be12 /sysutils/graphicboot
parentfc665b188411fa01f878128c291693f5c4bedcd5 (diff)
downloadports-397d208a6c8895af94e1c810327aaef2533b45cc.tar.gz
ports-397d208a6c8895af94e1c810327aaef2533b45cc.zip
Notes
Diffstat (limited to 'sysutils/graphicboot')
-rw-r--r--sysutils/graphicboot/Makefile34
-rw-r--r--sysutils/graphicboot/distinfo2
-rw-r--r--sysutils/graphicboot/pkg-descr8
-rw-r--r--sysutils/graphicboot/pkg-message21
-rw-r--r--sysutils/graphicboot/pkg-plist11
5 files changed, 76 insertions, 0 deletions
diff --git a/sysutils/graphicboot/Makefile b/sysutils/graphicboot/Makefile
new file mode 100644
index 000000000000..5ee5138a941a
--- /dev/null
+++ b/sysutils/graphicboot/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: graphicboot
+# Date created: 8 July 2005
+# Whom: Matthew Holder <sixxgate@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphicboot
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://matt.sixxgate.com/files/
+
+MAINTAINER= sixxgate@hotmail.com
+COMMENT= Provides graphical X Window startup to FreeBSD during 'rc'
+
+RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage
+
+USE_MOTIF= yes
+USE_BZIP2= yes
+USE_IMAKE= yes
+
+MAN1= graphicboot.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN="The graphical boot requires rcorder which is only on FreeBSD 5 or greater."
+.endif
+
+post-install:
+ ${CAT} pkg-message
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/graphicboot/distinfo b/sysutils/graphicboot/distinfo
new file mode 100644
index 000000000000..40ee86e60f2c
--- /dev/null
+++ b/sysutils/graphicboot/distinfo
@@ -0,0 +1,2 @@
+MD5 (graphicboot-1.0.tar.bz2) = 35f89a49e34ebebc094ff58726ce36af
+SIZE (graphicboot-1.0.tar.bz2) = 31131
diff --git a/sysutils/graphicboot/pkg-descr b/sysutils/graphicboot/pkg-descr
new file mode 100644
index 000000000000..5a159ffcc594
--- /dev/null
+++ b/sysutils/graphicboot/pkg-descr
@@ -0,0 +1,8 @@
+graphicboot starts the machines local X Window and displays the messages
+echoed during boot up while the rc script is setting up the operating
+system.
+
+WWW: http://matt.sixxgate.com/
+
+- Matthew Holder
+sixxgate@hotmail.com
diff --git a/sysutils/graphicboot/pkg-message b/sysutils/graphicboot/pkg-message
new file mode 100644
index 000000000000..311f799e72a5
--- /dev/null
+++ b/sysutils/graphicboot/pkg-message
@@ -0,0 +1,21 @@
+=========================================================
+WARNING: This port port will start X during the startup.
+Before adding the graphboot="YES" line to your rc.conf
+file please test the port by running it in multi-user
+mode. If you need to make any changes to the xorg.conf
+file, please remember to leave the resolution at 640x480.
+
+Please not that if you are using XDM or another display
+manager for graphical logon, please edit its startup
+script by adding the line at the beginning:
+
+ echo _XGB_EGB
+
+This will cause the graphicboot to end before the
+display manager starts.
+
+To use graphicboot, simply add the line to your rc.conf
+file:
+
+ graphicboot="YES"
+=========================================================
diff --git a/sysutils/graphicboot/pkg-plist b/sysutils/graphicboot/pkg-plist
new file mode 100644
index 000000000000..2b5297f32189
--- /dev/null
+++ b/sysutils/graphicboot/pkg-plist
@@ -0,0 +1,11 @@
+bin/graphicboot
+@cwd /etc/Xboot
+Xserver
+Xresources
+xorg.conf
+Xsplash.jpg
+@cwd /
+@dirrm etc/Xboot
+@cwd /etc/rc.d
+startgraphicboot
+endgraphicboot