aboutsummaryrefslogtreecommitdiff
path: root/sysutils/graveman/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-04 13:36:07 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-04 13:36:07 +0000
commit5432d75fb3e63bea3293a4f2054c41a21c8de4f5 (patch)
tree3675861f76d8b2907a174503b1af463a2ff2a588 /sysutils/graveman/Makefile
parent58a0c2a29a2360db036d2ed7a526d25b28b6a1b8 (diff)
downloadports-5432d75fb3e63bea3293a4f2054c41a21c8de4f5.tar.gz
ports-5432d75fb3e63bea3293a4f2054c41a21c8de4f5.zip
Notes
Diffstat (limited to 'sysutils/graveman/Makefile')
-rw-r--r--sysutils/graveman/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/graveman/Makefile b/sysutils/graveman/Makefile
new file mode 100644
index 000000000000..c0d23f6edec3
--- /dev/null
+++ b/sysutils/graveman/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: graveman
+# Date created: 2005-02-01
+# Whom: Anton Karpov <toxa@toxahost.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graveman
+PORTVERSION= 0.3.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.nongnu.org/${PORTNAME}/
+
+MAINTAINER= toxa@toxahost.ru
+COMMENT= Another GTK2 frontend for cdrecord, mkisofs, readcd and sox
+
+RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+WANT_GNOME= yes
+GNU_CONFIGURE= yes
+USE_GNOME= libglade2 intlhack gnomehack gnomeprefix
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+OPTIONS= MP3 "MP3 Support" off \
+ OGG "OGG Support" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_MP3)
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad \
+ id3tag.2:${PORTSDIR}/audio/libid3tag
+RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
+.else
+CONFIGURE_ARGS+=--disable-mp3
+.endif
+
+.if !defined(WITHOUT_OGG)
+LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+.else
+CONFIGURE_ARGS+=--disable-ogg
+.endif
+
+.include <bsd.port.post.mk>