aboutsummaryrefslogtreecommitdiff
path: root/sysutils/graveman/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-12 17:34:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-12 17:34:35 +0000
commit0fd2d58dcd9d8245fb1857ae143fdc651bc395c6 (patch)
tree9b87f35a555c23a1af0366944dcb9a25abc91501 /sysutils/graveman/Makefile
parent4bc8926ac16118ef112f130648459354109d341e (diff)
- Update to 0.3.12
PR: ports/88806 Submitted by: Anton Karpov <toxa@toxahost.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=148038
Diffstat (limited to 'sysutils/graveman/Makefile')
-rw-r--r--sysutils/graveman/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/sysutils/graveman/Makefile b/sysutils/graveman/Makefile
index a1dae3699baa..1a98fabc145d 100644
--- a/sysutils/graveman/Makefile
+++ b/sysutils/graveman/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= graveman
-PORTVERSION= 0.3.7
-PORTREVISION= 2
+PORTVERSION= 0.3.12
CATEGORIES= sysutils
-MASTER_SITES= http://www.nongnu.org/${PORTNAME}/
+MASTER_SITES= http://graveman.tuxfamily.org/sources/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-4
MAINTAINER= toxa@toxahost.ru
COMMENT= Another GTK2 frontend for cdrecord, mkisofs, readcd and sox
RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools
+LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng
USE_BZIP2= yes
USE_GMAKE= yes
@@ -24,8 +25,11 @@ USE_GNOME= libglade2 intlhack gnomehack gnomeprefix
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+MAN1= graveman.1
+
OPTIONS= MP3 "MP3 Support" off \
- OGG "OGG Support" off
+ OGG "OGG Support" off \
+ DVD "DVD+RW Support" off
.include <bsd.port.pre.mk>
@@ -44,4 +48,8 @@ LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg \
CONFIGURE_ARGS+=--disable-ogg
.endif
+.if defined(WITH_DVD)
+RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
+.endif
+
.include <bsd.port.post.mk>