aboutsummaryrefslogtreecommitdiff
path: root/sysutils/grub/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-18 06:51:01 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-18 06:51:01 +0000
commit243f8f87e16eb5cba54d1c6995975ad29901a65e (patch)
treecc637249c610c3cf1efaf480c30c50d556bdaf53 /sysutils/grub/Makefile
parentc62600f189632453e74a99b071e8129646c88351 (diff)
downloadports-243f8f87e16eb5cba54d1c6995975ad29901a65e.tar.gz
ports-243f8f87e16eb5cba54d1c6995975ad29901a65e.zip
Notes
Diffstat (limited to 'sysutils/grub/Makefile')
-rw-r--r--sysutils/grub/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/sysutils/grub/Makefile b/sysutils/grub/Makefile
index 633406fa4166..e7f555bc8644 100644
--- a/sysutils/grub/Makefile
+++ b/sysutils/grub/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= grub
-PORTVERSION= 0.95
+PORTVERSION= 0.97
CATEGORIES= sysutils
MASTER_SITES= ftp://alpha.gnu.org/gnu/grub/
@@ -18,6 +18,7 @@ USE_AUTOCONF_VER= 259
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-freebsd-freebsd${OSREL}
+CONFIGURE_ARGS+= --libdir=${PREFIX}/share
ONLY_FOR_ARCHS= i386
GRUB_DIR= ${DATADIR:C|^${PREFIX}/||}/i386-freebsd
@@ -27,7 +28,9 @@ MAN8= grub.8 grub-install.8 grub-md5-crypt.8 grub-terminfo.8
INFO= grub multiboot
PLIST_DIRS= ${GRUB_DIR} ${DATADIR:C|^${PREFIX}/||}
PLIST_FILES= bin/mbchk sbin/grub sbin/grub-install sbin/grub-md5-crypt \
- sbin/grub-terminfo ${GRUB_DIR}/stage1 ${GRUB_DIR}/stage2
+ sbin/grub-terminfo sbin/grub-set-default \
+ ${GRUB_DIR}/stage1 ${GRUB_DIR}/stage2
+
.for f in e2fs fat ffs iso9660 jfs minix reiserfs ufs2 vstafs xfs
PLIST_FILES+= ${GRUB_DIR}/${f}_stage1_5
.endfor