aboutsummaryrefslogtreecommitdiff
path: root/sysutils/grub2-efi
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2014-12-03 15:31:18 +0000
committerKris Moore <kmoore@FreeBSD.org>2014-12-03 15:31:18 +0000
commit882db4cbbb74022dd8857c08cc0c093423a2d0a8 (patch)
treed32858c9c4f7628b521f186716ad4b4f1ffecf92 /sysutils/grub2-efi
parent1fe442ad09de6e592b472b4981b2aa6308cd9628 (diff)
Notes
Diffstat (limited to 'sysutils/grub2-efi')
-rw-r--r--sysutils/grub2-efi/Makefile2
-rw-r--r--sysutils/grub2-efi/files/patch-grub-core_partmap_gpt.c20
-rw-r--r--sysutils/grub2-efi/files/patch-include_grub_gpt_partition.h17
3 files changed, 38 insertions, 1 deletions
diff --git a/sysutils/grub2-efi/Makefile b/sysutils/grub2-efi/Makefile
index 2af9c315ba6b..6f3a507b7296 100644
--- a/sysutils/grub2-efi/Makefile
+++ b/sysutils/grub2-efi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grub2-efi
PORTVERSION= 2.02
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils
MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
ftp://ftp.pcbsd.org/pub/software/
diff --git a/sysutils/grub2-efi/files/patch-grub-core_partmap_gpt.c b/sysutils/grub2-efi/files/patch-grub-core_partmap_gpt.c
new file mode 100644
index 000000000000..a249ef819861
--- /dev/null
+++ b/sysutils/grub2-efi/files/patch-grub-core_partmap_gpt.c
@@ -0,0 +1,20 @@
+--- grub-core/partmap/gpt.c.orig 2014-12-02 14:37:43.000000000 +0800
++++ grub-core/partmap/gpt.c 2014-12-02 14:37:49.000000000 +0800
+@@ -37,6 +37,7 @@
+
+ #ifdef GRUB_UTIL
+ static const grub_gpt_part_type_t grub_gpt_partition_type_bios_boot = GRUB_GPT_PARTITION_TYPE_BIOS_BOOT;
++static const grub_gpt_part_type_t grub_gpt_partition_type_freebsd_boot = GRUB_GPT_PARTITION_TYPE_FREEBSD_BOOT;
+ #endif
+
+ /* 512 << 7 = 65536 byte sectors. */
+@@ -155,7 +156,8 @@
+ disk->partition = p2;
+
+ /* If there's an embed region, it is in a dedicated partition. */
+- if (! grub_memcmp (&gptdata.type, &grub_gpt_partition_type_bios_boot, 16))
++ if (! grub_memcmp (&gptdata.type, &grub_gpt_partition_type_bios_boot, 16) ||
++ ! grub_memcmp (&gptdata.type, &grub_gpt_partition_type_freebsd_boot, 16))
+ {
+ ctx->start = p->start;
+ ctx->len = p->len;
diff --git a/sysutils/grub2-efi/files/patch-include_grub_gpt_partition.h b/sysutils/grub2-efi/files/patch-include_grub_gpt_partition.h
new file mode 100644
index 000000000000..4245333aa2d2
--- /dev/null
+++ b/sysutils/grub2-efi/files/patch-include_grub_gpt_partition.h
@@ -0,0 +1,17 @@
+--- include/grub/gpt_partition.h.orig 2014-12-02 14:32:40.000000000 +0800
++++ include/grub/gpt_partition.h 2014-12-02 14:35:03.000000000 +0800
+@@ -43,6 +43,14 @@
+ { 0x74, 0x4e, 0x65, 0x65, 0x64, 0x45, 0x46, 0x49 } \
+ }
+
++#define GRUB_GPT_PARTITION_TYPE_FREEBSD_BOOT \
++ { grub_cpu_to_le32_compile_time (0x83bd6b9d), \
++ grub_cpu_to_le16_compile_time (0x7f41), \
++ grub_cpu_to_le16_compile_time (0x11dc), \
++ { 0xbe, 0x0b, 0x00, 0x15, 0x60, 0xb8, 0x4f, 0x0f } \
++ }
++
++
+ #define GRUB_GPT_PARTITION_TYPE_LDM \
+ { grub_cpu_to_le32_compile_time (0x5808C8AAU),\
+ grub_cpu_to_le16_compile_time (0x7E8F), \