aboutsummaryrefslogtreecommitdiff
path: root/sysutils/grub2-efi
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-01-23 15:53:18 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-01-23 15:53:18 +0000
commitebe6e87b7b999ab573d3df22dcea88b89796aa45 (patch)
treefadb57c80cfbe7ae49033de4a9012aa9b6e93666 /sysutils/grub2-efi
parent9102a9c892d3bb6d7d0dc824c83e0266f7041ef3 (diff)
downloadports-ebe6e87b7b999ab573d3df22dcea88b89796aa45.tar.gz
ports-ebe6e87b7b999ab573d3df22dcea88b89796aa45.zip
Notes
Diffstat (limited to 'sysutils/grub2-efi')
-rw-r--r--sysutils/grub2-efi/Makefile2
-rw-r--r--sysutils/grub2-efi/files/patch-grub-core_disk_efi_efidisk.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/sysutils/grub2-efi/Makefile b/sysutils/grub2-efi/Makefile
index 41bad6285325..754cf188a39c 100644
--- a/sysutils/grub2-efi/Makefile
+++ b/sysutils/grub2-efi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grub2-efi
PORTVERSION= 2.02
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= sysutils
MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
ftp://ftp.pcbsd.org/pub/software/
diff --git a/sysutils/grub2-efi/files/patch-grub-core_disk_efi_efidisk.c b/sysutils/grub2-efi/files/patch-grub-core_disk_efi_efidisk.c
new file mode 100644
index 000000000000..f364c07c3131
--- /dev/null
+++ b/sysutils/grub2-efi/files/patch-grub-core_disk_efi_efidisk.c
@@ -0,0 +1,15 @@
+diff --git a/grub-core/disk/efi/efidisk.c b/grub-core/disk/efi/efidisk.c
+index 3b12c34..97f7456 100644
+--- grub-core/disk/efi/efidisk.c
++++ grub-core/disk/efi/efidisk.c
+@@ -862,9 +862,7 @@ grub_efidisk_get_device_name (grub_efi_handle_t *handle)
+ if (! ctx.partition_name)
+ {
+ grub_disk_close (parent);
+- if (is_cdrom)
+- return grub_strdup (device_name);
+- return 0;
++ return grub_strdup (device_name);
+ }
+
+ dev_name = grub_xasprintf ("%s,%s", parent->name,