aboutsummaryrefslogtreecommitdiff
path: root/sysutils/grub2/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2010-06-11 11:06:20 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2010-06-11 11:06:20 +0000
commita8cca1535f3276a3f9440f46a71850d8aff487d7 (patch)
treed3d4db3339d9497a382fd12685ecf25e016ec0f6 /sysutils/grub2/Makefile
parent35f7020e510dc2879829b6c63f23e0922f9a57a2 (diff)
Notes
Diffstat (limited to 'sysutils/grub2/Makefile')
-rw-r--r--sysutils/grub2/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/grub2/Makefile b/sysutils/grub2/Makefile
new file mode 100644
index 000000000000..2020b44ac54c
--- /dev/null
+++ b/sysutils/grub2/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: grub
+# Whom: sem@FreeBSD.org
+# Date created: 10 June 2010
+#
+# $FreeBSD$
+#
+
+PORTNAME= grub2
+PORTVERSION= 1.98
+CATEGORIES= sysutils
+MASTER_SITES= ftp://alpha.gnu.org/gnu/grub/
+DISTNAME= grub-${PORTVERSION}
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= Multiboot boot loader
+
+CONFLICTS= grub-0*
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BISON= build
+USE_GETTEXT= yes
+ONLY_FOR_ARCHS= i386
+
+INFO= grub
+
+OPTIONS= MKFONT "Build grub-mkfont (require freetype2)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MKFONT)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.else
+MKFONT= "@comment "
+.endif
+
+PLIST_SUB+= MKFONT=${MKFONT}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>