aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gsmartcontrol
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-08-16 14:32:58 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-08-16 14:32:58 +0000
commit4aa45bade9d9e8681582ba2fa8251747e0a69965 (patch)
treed43fb4e53799eb43d35f3a7b16cd86ef78d9e75d /sysutils/gsmartcontrol
parent65fef74d6c4b598e0896d079a26802080df11e9c (diff)
downloadports-4aa45bade9d9e8681582ba2fa8251747e0a69965.tar.gz
ports-4aa45bade9d9e8681582ba2fa8251747e0a69965.zip
Notes
Diffstat (limited to 'sysutils/gsmartcontrol')
-rw-r--r--sysutils/gsmartcontrol/Makefile33
-rw-r--r--sysutils/gsmartcontrol/distinfo4
-rw-r--r--sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in17
-rw-r--r--sysutils/gsmartcontrol/files/patch-src-gsc_text_window.h20
-rw-r--r--sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp13
5 files changed, 26 insertions, 61 deletions
diff --git a/sysutils/gsmartcontrol/Makefile b/sysutils/gsmartcontrol/Makefile
index 41375972f36c..1b03d40834da 100644
--- a/sysutils/gsmartcontrol/Makefile
+++ b/sysutils/gsmartcontrol/Makefile
@@ -5,24 +5,39 @@
# $FreeBSD$
#
-PORTNAME= gsmartcontrol
-PORTVERSION= 0.8.6
-PORTREVISION= 2
-CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_BERLIOS}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+PORTNAME= gsmartcontrol
+PORTVERSION= 0.8.7
+CATEGORIES= sysutils
+MASTER_SITES= http://artificialtime.com/${PORTNAME}/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Graphical user interface for smartmontools
-LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= atkmm-1.6:${PORTSDIR}/accessibility/atkmm \
+ glibmm-2.4:${PORTSDIR}/devel/glibmm \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ cairomm-1.0:${PORTSDIR}/graphics/cairomm \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ pangomm-1.4:${PORTSDIR}/x11-toolkits/pangomm \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
smartctl:${PORTSDIR}/sysutils/smartmontools
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GNOME= pkgconfig
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_PKGCONFIG= build
+USE_GNOME= gtk20
+USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
+ xi xinerama xrandr xrender
INSTALLS_ICONS= yes
MAN1= gsmartcontrol.1
diff --git a/sysutils/gsmartcontrol/distinfo b/sysutils/gsmartcontrol/distinfo
index bb2cf4ee3ae5..6da27a7734cd 100644
--- a/sysutils/gsmartcontrol/distinfo
+++ b/sysutils/gsmartcontrol/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gsmartcontrol-0.8.6.tar.bz2) = b0806c0a6b2c3d33755e78b67bd8a2ce895b07aee2a5a75767132694e0f41eda
-SIZE (gsmartcontrol-0.8.6.tar.bz2) = 673712
+SHA256 (gsmartcontrol-0.8.7.tar.bz2) = 708fa803243abb852ed52050fc82cd3592a798c02743342441996e77f19ffec6
+SIZE (gsmartcontrol-0.8.7.tar.bz2) = 684394
diff --git a/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
deleted file mode 100644
index 764d4a4cc949..000000000000
--- a/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- data/gsmartcontrol-root.in.orig 2011-04-30 20:39:54.000000000 +0200
-+++ data/gsmartcontrol-root.in 2011-10-03 23:31:02.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/usr/bin/env bash
- ############################################################################
- # Copyright:
- # (C) 2008 - 2010 Alexander Shaduri <ashaduri 'at' gmail.com>
-@@ -88,7 +88,7 @@
- # the user's env after all).
- # Note that beesu won't show a GUI login box if /usr/sbin is before /usr/bin,
- # so add it first as well.
--EXTRA_PATHS="/usr/bin:/usr/sbin:/usr/local/sbin";
-+EXTRA_PATHS="/usr/bin:/usr/sbin:@prefix@/sbin";
- export PATH="$EXTRA_PATHS:$PATH"
-
-
diff --git a/sysutils/gsmartcontrol/files/patch-src-gsc_text_window.h b/sysutils/gsmartcontrol/files/patch-src-gsc_text_window.h
deleted file mode 100644
index 85907bf5f942..000000000000
--- a/sysutils/gsmartcontrol/files/patch-src-gsc_text_window.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/gsc_text_window.h.orig 2011-08-15 16:20:00.000000000 +0200
-+++ src/gsc_text_window.h 2011-08-15 16:21:05.000000000 +0200
-@@ -126,7 +126,7 @@
- // by default, delete_event calls hide().
- bool on_delete_event_before(GdkEventAny* e)
- {
-- destroy(this); // deletes this object and nullifies instance
-+ this->destroy(this); // deletes this object and nullifies instance
- return true; // event handled, don't call default virtual handler
- }
-
-@@ -184,7 +184,7 @@
-
- void on_close_window_button_clicked()
- {
-- destroy(this);
-+ this->destroy(this);
- }
-
-
diff --git a/sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp b/sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp
deleted file mode 100644
index ed373255886d..000000000000
--- a/sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- src/applib/storage_detector_other.cpp.orig
-+++ src/applib/storage_detector_other.cpp
-@@ -75,6 +75,7 @@
-
- whitelist.push_back("/^ad[0-9]+$/"); // adN without suffix - fbsd ide
- whitelist.push_back("/^da[0-9]+$/"); // daN without suffix - fbsd scsi, usb
-+ whitelist.push_back("/^ada[0-9]+$/"); // adaN without suffix - fbsd ata cam
- // whitelist.push_back("/ ^sa[0-9]+$/"); // saN without suffix - fbsd scsi tape
- // whitelist.push_back("/^ast[0-9]+$/"); // astN without suffix - fbsd ide tape
- whitelist.push_back("/^aacd[0-9]+$/"); // fbsd adaptec raid