aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gtk-imonc
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-05-28 16:47:10 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-05-28 16:47:10 +0000
commit738e5f0bd1d184b0899e3bf6b475c9c847cc6098 (patch)
tree6b262624d85c630a771e3dd8d96969ae942e5791 /sysutils/gtk-imonc
parent589356884aa40f68e3a4e4c93a063a6a4b9e5598 (diff)
downloadports-738e5f0bd1d184b0899e3bf6b475c9c847cc6098.tar.gz
ports-738e5f0bd1d184b0899e3bf6b475c9c847cc6098.zip
Notes
Diffstat (limited to 'sysutils/gtk-imonc')
-rw-r--r--sysutils/gtk-imonc/Makefile20
-rw-r--r--sysutils/gtk-imonc/distinfo4
-rw-r--r--sysutils/gtk-imonc/files/patch-timer.c30
-rw-r--r--sysutils/gtk-imonc/pkg-descr11
-rw-r--r--sysutils/gtk-imonc/pkg-plist10
5 files changed, 53 insertions, 22 deletions
diff --git a/sysutils/gtk-imonc/Makefile b/sysutils/gtk-imonc/Makefile
index 1f217f2dd975..9d3b69c5c200 100644
--- a/sysutils/gtk-imonc/Makefile
+++ b/sysutils/gtk-imonc/Makefile
@@ -6,26 +6,20 @@
#
PORTNAME= gtk-imonc
-PORTVERSION= 0.4.4
-PORTREVISION= 1
+PORTVERSION= 0.6.2
CATEGORIES= sysutils
MASTER_SITES= http://userpage.fu-berlin.de/~zeank/gtk-imonc/download/
-MAINTAINER= steffen@vogelreuter.de
-COMMENT= A gtk based client to control an one disc fli4l router
+MAINTAINER= aberg@doomnet.de
+COMMENT= A GTK2-based imond-client to control an on(e) disc fli4l router
-WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} \
- --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_GETTEXT= yes
-USE_GMAKE= yes
-USE_GNOME= gtk12
USE_ICONV= yes
-USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
USE_X_PREFIX= yes
-pre-configure:
- @${REINPLACE_CMD} -e 's|ac_default_prefix=/usr/local|ac_default_prefix=${PREFIX}|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/sysutils/gtk-imonc/distinfo b/sysutils/gtk-imonc/distinfo
index 869e130d2d4b..28f86466361b 100644
--- a/sysutils/gtk-imonc/distinfo
+++ b/sysutils/gtk-imonc/distinfo
@@ -1,2 +1,2 @@
-MD5 (gtk-imonc-0.4.4.tar.gz) = 4e6a6a5f5bdbba928940571d8b2d3774
-SIZE (gtk-imonc-0.4.4.tar.gz) = 230487
+MD5 (gtk-imonc-0.6.2.tar.gz) = 200c5fe17f87b4c18cbd767d7a43438e
+SIZE (gtk-imonc-0.6.2.tar.gz) = 293640
diff --git a/sysutils/gtk-imonc/files/patch-timer.c b/sysutils/gtk-imonc/files/patch-timer.c
new file mode 100644
index 000000000000..fd2bbe871eb8
--- /dev/null
+++ b/sysutils/gtk-imonc/files/patch-timer.c
@@ -0,0 +1,30 @@
+--- src/timer.c.orig Mon May 17 23:58:51 2004
++++ src/timer.c Tue May 18 00:18:15 2004
+@@ -298,14 +298,14 @@
+ }
+ else
+ {
+- tmpbytes = atoll (strtok (NULL, " "));
++ tmpbytes = strtoll (strtok (NULL, " "), NULL, 10);
+ ibytes += tmpbytes;
+ row[i] = get_bytes (tmpbytes,
+ ibytebuf);
+ }
+ break;
+ case 9: /* OBytes */
+- tmpbytes = atoll (strtok (NULL, " "));
++ tmpbytes = strtoll (strtok (NULL, " "), NULL, 10);
+ obytes += tmpbytes;
+ row[i] = get_bytes (tmpbytes, obytebuf);
+ break;
+@@ -1148,8 +1148,8 @@
+ }
+ else
+ {
+- gtk_clist_set_text (GTK_CLIST (clist), j, 3, get_bytes(atoll(strtok(get_answer (fd)," ")), buf));
+- gtk_clist_set_text (GTK_CLIST (clist), j, 4, get_bytes(atoll(strtok(NULL, " ")), buf));
++ gtk_clist_set_text (GTK_CLIST (clist), j, 3, get_bytes(strtoll(strtok(get_answer (fd)," "), NULL, 10), buf));
++ gtk_clist_set_text (GTK_CLIST (clist), j, 4, get_bytes(strtoll(strtok(NULL, " "), NULL, 10), buf));
+ }
+
+ send_command (fd, "online-time pppoe");
diff --git a/sysutils/gtk-imonc/pkg-descr b/sysutils/gtk-imonc/pkg-descr
index 631739ba2061..a6c9539aca2d 100644
--- a/sysutils/gtk-imonc/pkg-descr
+++ b/sysutils/gtk-imonc/pkg-descr
@@ -1,8 +1,9 @@
-A gtk-based client to control the one disc linux router fli4l
-You can dial, hangup, add lins, remove links, check timetables ...
+GTK-Imonc is a GTK2-based imond-client to control an on(e) disc fli4l
+router. You can dial/hangup the connection, show status information
+(traffic, cpu), shutdown/reboot and even remotely update the router.
-Author: Stefan "Steve" Strigler <zeank@x-berg.de>
+Author: Stefan "Steve" Strigler <steve@zeank.in-berlin.de>
WWW: http://userpage.fu-berlin.de/%7Ezeank/gtk-imonc/
--- Steffen Vogelreuter
-steffen@vogelreuter.de
+- berg
+aberg@doomnet.de
diff --git a/sysutils/gtk-imonc/pkg-plist b/sysutils/gtk-imonc/pkg-plist
index e2610dbd7406..844509e1a2cc 100644
--- a/sysutils/gtk-imonc/pkg-plist
+++ b/sysutils/gtk-imonc/pkg-plist
@@ -1,9 +1,15 @@
bin/gtk-imonc
-share/gtk-imonc/pixmaps/fli4l.xpm
+share/gnome/apps/Internet/gtk-imonc.desktop
+share/gtk-imonc/pixmaps/docklet-inactive.png
+share/gtk-imonc/pixmaps/docklet-offline.png
+share/gtk-imonc/pixmaps/docklet-online.png
share/gtk-imonc/pixmaps/gtk-imonc.png
+share/gtk-imonc/pixmaps/offline.png
share/gtk-imonc/pixmaps/offline.xpm
+share/gtk-imonc/pixmaps/online.png
share/gtk-imonc/pixmaps/online.xpm
-share/gnome/apps/Internet/gtk-imonc.desktop
+share/gtk-imonc/pixmaps/reboot.png
+share/gtk-imonc/pixmaps/shutdown.png
share/locale/de/LC_MESSAGES/gtk-imonc.mo
share/pixmaps/gtk-imonc.png
@dirrm share/gtk-imonc/pixmaps