aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gupsc
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-03-13 15:08:45 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-03-13 15:08:45 +0000
commita5849a02aab663c6c16d99c4ffad0b1b00d82287 (patch)
treef9719ca7a770e2849b7ffd9a8d7765cf556d0932 /sysutils/gupsc
parent4c3916fc00f60d95cf3f3f8d1afde020a1f435e6 (diff)
downloadports-a5849a02aab663c6c16d99c4ffad0b1b00d82287.tar.gz
ports-a5849a02aab663c6c16d99c4ffad0b1b00d82287.zip
Notes
Diffstat (limited to 'sysutils/gupsc')
-rw-r--r--sysutils/gupsc/Makefile31
-rw-r--r--sysutils/gupsc/distinfo1
-rw-r--r--sysutils/gupsc/pkg-comment1
-rw-r--r--sysutils/gupsc/pkg-descr9
-rw-r--r--sysutils/gupsc/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/gupsc/Makefile b/sysutils/gupsc/Makefile
new file mode 100644
index 000000000000..f40f382b05eb
--- /dev/null
+++ b/sysutils/gupsc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gupsc
+# Date created: 13 March 2001
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gupsc
+PORTVERSION= 0.3.1
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://www.stud.ifi.uio.no/~hennikul/gupsc/download/
+
+MAINTAINER= demon@FreeBSD.org
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOMELIBS= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure \
+ ${WRKSRC}/src/Makefile.in
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/sysutils/gupsc/distinfo b/sysutils/gupsc/distinfo
new file mode 100644
index 000000000000..38b2edd42a0d
--- /dev/null
+++ b/sysutils/gupsc/distinfo
@@ -0,0 +1 @@
+MD5 (gupsc-0.3.1.tar.bz2) = da182496ff347dccc4c24f2e9c803a06
diff --git a/sysutils/gupsc/pkg-comment b/sysutils/gupsc/pkg-comment
new file mode 100644
index 000000000000..a53c3cc36008
--- /dev/null
+++ b/sysutils/gupsc/pkg-comment
@@ -0,0 +1 @@
+A free Gnome client for the Network UPS Tools
diff --git a/sysutils/gupsc/pkg-descr b/sysutils/gupsc/pkg-descr
new file mode 100644
index 000000000000..43663607d1d8
--- /dev/null
+++ b/sysutils/gupsc/pkg-descr
@@ -0,0 +1,9 @@
+This is a GNOME client for the Network UPS Tools Package.
+It will display information about battery-status, load-status, AC-current
+and AC-frequency in a window. You can choose which machine to get the
+information from, and the rate at which it gets this information.
+
+This package requires NUT on the machine the UPS is connected to. It does
+not require NUT installed on the machine you want to run gupsc on.
+For information about how to configure NUT, and how to allow external
+machines to connect to the upsd, please check the documentation for NUT.
diff --git a/sysutils/gupsc/pkg-plist b/sysutils/gupsc/pkg-plist
new file mode 100644
index 000000000000..8fedf513fa1d
--- /dev/null
+++ b/sysutils/gupsc/pkg-plist
@@ -0,0 +1,5 @@
+bin/gupsc
+share/locale/no/LC_MESSAGES/gupsc.mo
+share/gnome/pixmaps/gupsc/ups.png
+share/gnome/gnome/apps/System/gupsc.desktop
+@dirrm share/gnome/pixmaps/gupsc