aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hachoir-urwid/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-25 04:45:45 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-25 04:45:45 +0000
commit59f2c010e81a752e5ba5a82dea2890cfb21ca232 (patch)
tree9b9bfacebc277db315e15448b50159b27a8a6833 /sysutils/hachoir-urwid/Makefile
parentae2ce33730857dda77cc70d9c89beedddc26d5f3 (diff)
downloadports-59f2c010e81a752e5ba5a82dea2890cfb21ca232.tar.gz
ports-59f2c010e81a752e5ba5a82dea2890cfb21ca232.zip
Notes
Diffstat (limited to 'sysutils/hachoir-urwid/Makefile')
-rw-r--r--sysutils/hachoir-urwid/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/hachoir-urwid/Makefile b/sysutils/hachoir-urwid/Makefile
new file mode 100644
index 000000000000..3e7e6b69856d
--- /dev/null
+++ b/sysutils/hachoir-urwid/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hachoir-urwid
+# Date created: 25 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hachoir-urwid
+PORTVERSION= 0.7.1
+CATEGORIES= sysutils python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/h/${PORTNAME}/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Binary file explorer
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/hachoir_parser/__init__.py:${PORTSDIR}/devel/hachoir-parser \
+ ${PYTHON_SITELIBDIR}/urwid/__init__.py:${PORTSDIR}/devel/py-urwid
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>