aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-07-22 23:23:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-07-22 23:23:46 +0000
commitd26ead7b13deadedc8b3e978e75714b7f310322a (patch)
tree26fce07ef1d4b7fd625a90ca155007ff43d17a92 /sysutils/hal
parent7dcfe067ba942c740c113cd2e6d103798482d878 (diff)
downloadports-d26ead7b13deadedc8b3e978e75714b7f310322a.tar.gz
ports-d26ead7b13deadedc8b3e978e75714b7f310322a.zip
Notes
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_hf-storage.c20
2 files changed, 18 insertions, 4 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index 356b4bb40542..f93076836367 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_hf-storage.c b/sysutils/hal/files/patch-hald_hf-storage.c
index 99755c770568..e2fedeed9406 100644
--- a/sysutils/hal/files/patch-hald_hf-storage.c
+++ b/sysutils/hal/files/patch-hald_hf-storage.c
@@ -1,5 +1,5 @@
--- hald/freebsd/hf-storage.c.orig 2009-08-24 08:42:29.000000000 -0400
-+++ hald/freebsd/hf-storage.c 2010-08-29 12:22:03.000000000 -0400
++++ hald/freebsd/hf-storage.c 2011-07-20 20:52:51.000000000 -0400
@@ -30,6 +30,7 @@
#include <limits.h>
#include <inttypes.h>
@@ -50,7 +50,21 @@
geom_obj->type = -1; /* We use -1 here to denote a missing type. */
geom_obj->hash = hash;
-@@ -589,11 +621,18 @@ hf_storage_devd_notify (const char *syst
+@@ -458,6 +490,13 @@ hf_storage_parse_conftxt (const char *co
+ {
+ g_free(geom_obj->class);
+ geom_obj->class = g_strdup(fields[12]);
++ if (! strcmp(geom_obj->class, "BSD") &&
++ geom_obj->type == FS_UNUSED)
++ {
++ geom_obj->type = FS_BSDFFS;
++ g_free(geom_obj->str_type);
++ geom_obj->str_type = g_strdup("freebsd-ufs");
++ }
+ }
+ }
+ }
+@@ -589,11 +628,18 @@ hf_storage_devd_notify (const char *syst
char *conftxt;
GSList *new_disks;
@@ -70,7 +84,7 @@
new_disks = hf_storage_parse_conftxt(conftxt);
g_free(conftxt);
-@@ -669,7 +708,7 @@ hf_storage_conftxt_timeout_cb (gpointer
+@@ -669,7 +715,7 @@ hf_storage_conftxt_timeout_cb (gpointer
if (hf_is_waiting)
return TRUE;