aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-02-26 18:07:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-02-26 18:07:19 +0000
commit5b3183ba11043b72bf7a04242033b87e4bd4fb33 (patch)
treeec45a72f6abb9043085b5394a0eaaebeb4247adb /sysutils/hal
parent80799940e7e110fe10107e565b99a305000d46a6 (diff)
downloadports-5b3183ba11043b72bf7a04242033b87e4bd4fb33.tar.gz
ports-5b3183ba11043b72bf7a04242033b87e4bd4fb33.zip
Notes
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-devd.c22
2 files changed, 21 insertions, 3 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index b7e556445346..a83cc2d3a01c 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-devd.c b/sysutils/hal/files/patch-hald_freebsd_hf-devd.c
index 076fb0271d02..de85692da9a0 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-devd.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-devd.c
@@ -1,5 +1,23 @@
---- hald/freebsd/hf-devd.c.orig 2011-01-08 12:59:30.000000000 -0500
-+++ hald/freebsd/hf-devd.c 2011-01-08 13:04:46.000000000 -0500
+--- hald/freebsd/hf-devd.c.orig 2009-08-24 08:42:29.000000000 -0400
++++ hald/freebsd/hf-devd.c 2011-02-26 13:03:00.000000000 -0500
+@@ -122,7 +122,7 @@ hf_devd_parse_add_remove (const char *ev
+ g_return_val_if_fail(parent != NULL, FALSE);
+
+ if ((params_ptr = strchr(event, ' '))
+- && (at_ptr = strstr(params_ptr + 1, " at "))
++ && (at_ptr = strstr(params_ptr, "at "))
+ && (parent_ptr = strstr(at_ptr + 4, " on ")))
+ {
+ char *params_str;
+@@ -130,7 +130,7 @@ hf_devd_parse_add_remove (const char *ev
+
+ *name = g_strndup(event, params_ptr - event);
+ params_str = g_strndup(params_ptr + 1, at_ptr - params_ptr - 1);
+- at_str = g_strndup(at_ptr + 4, parent_ptr - at_ptr - 4);
++ at_str = g_strndup(at_ptr + 3, parent_ptr - at_ptr - 3);
+ *parent = g_strdup(parent_ptr + 4);
+
+ if (! strcmp(*parent, ".")) /* sys/kern/subr_bus.c */
@@ -398,7 +398,7 @@ hf_devd_event_cb (GIOChannel *source, GI
hf_devd_process_event(event);
g_free(event);